
Homework 6: Chroma Keying 

 
Due: 5:00pm, Thursday, November 10th  

 

Set Up  
○ Open your home directory (double click on your cs8fxx icon; 2

nd
 icon from the top) and create a new directory in 

your home directory called hw6 (all lowercase). 

○ Copy the folder bookClasses from your Desktop into the hw6 directory. Right click on bookClasses > Copy > Right 

click on hw6 > Paste Into Folder. 

○ When you work in Dr. Java be sure you are editing files in the hw6/bookClasses directory.  

Problems 

1. Chromakey  

This program requires you to use at least 3 images to create a new image. Here is what you will do: 

○ You will take a picture with at least one person wearing a colored T-shirt in front of a green screen.  The T-shirt 

should be of a solid color, preferably white or a color that is in stark contrast with the green screen background. 

○ You will then beg, borrow or steal two pictures of your own choice. One will be the background (to replace the 

green screen) and one will replace the T-shirt. For example, you could take a picture of yourself in front of the green 

screen and then superimpose a background of Hawaii over it and then give your T-shirt a fractal colored look.    

○ There is room for creativity. You can have multiple people in the image, or you could use a blue and a green sheet to 

provide two different backgrounds. The minimum required is replacing one background and one T-shirt. The 

homework will therefore have 2 parts that will be graded: how you replace the background and how you replace the 

T-shirt. Anything done above and beyond this will be used to judge extra credit. 

○ The basic idea for this homework is edge detection, i.e. to detect drastic changes in color within a picture and then 

use that information to do interesting things. 

○ For this project, you have a fairly large range of freedom to make your picture interesting. At the core, you are using 

the colors of the pixels in the image to allow you to substitute pixels from other images. You will be able to take a 

picture of a person wearing a red or white or other colored shirt in front of a green sheet in B230 and make the 

background (canvas) look like another locale (Hawaii, Big Bear, etc.) and their T-shirt have a new design (Tie-Dye, 

Star Wars, etc.).  

To do this, you will:  

● Write one method in Picture.java. 

Method: chromaKeyColor (int threshold, Picture pic) 

1. Add a method to Picture.java called chromaKeyColor where the "Color" is the color you are replacing. (be 

sure to use hw6/bookClasses/Picture.java).  So you can have methods like chromaKeyGreen(), 

chromaKeyRed(), chromaKeyBlue(), chromaKeyBlack() and so on. 

2. This method will alter the calling object (this) and take at least two parameters. One (or more) integer 

parameters providing the threshold values of red, blue, and/or green. The other parameter is a Picture, 

which will be the picture you use when replacing pixels.   

 

Some examples are: 

○ Example 1: void chromakeyGreen(int greenthreshold, Picture input). Any pixel in the calling object 

with a green value greater than the greenthreshold is replaced with the corresponding pixel from the 

input picture.  

○ Example 2: void chromakeyBlack(int bluethresh, int redthresh, int greenthresh, Picture input). Any 

pixel in the calling object with ALL the RGB values less than the thresholds is replaced with the 

corresponding pixel from the input picture. (We are thresholding all pixels below the standard 

because the target color is black.)  

○ You may optionally have a second input Picture parameter, which is the original source image. (See 

below for clarification.) 

3. You may use other heuristics in addition to the threshold value. For example, you may want to check to see 

if the green is over the threshold and if the green value is greater than the red and the blue components. 

 

 

 



2. HW6.java 

Testing your method (in an application):  

○ Create a new file called HW6.java where you will write an application to test your methods.  

○ REQUIREMENT: You must use the picture that you and your partner took using the sheet in the lab (B230) as the 

source picture. The background and shirt pictures can be used from pictures in media sources or from the Internet or 

any pictures that you might have taken using your digital camera.  

○ IMPORTANT: In order for the grader to grade your submission your code must work with different paths. To 

obtain each media file, do NOT use the file path or MediaPath functions. Copy the images you want to use for your 

final submission into the same folder as your code, i.e., inside your hw6/bookClasses folder. Then ensure that the 

file path is simply "imagename.jpg". For example, if you want to use pic1.jpg, use  

■ Picture pic1 = new Picture("pic1.jpg");  
○ Using the above method for creating pictures, you will open your three images.  

○ Show your original image (the picture of you in front of the green screen).  

○ You will then call your chromakey method to change the background.  

○ For example: If your background is a green sheet, you would call chromakeyGreen on your picture and pass it the 

threshold(s) and the background picture. This will cause the green pixels in your image to be replaced with the 

background.  

○ You will then call your chromakey method to change the T-shirt color.  

○ For example: If your T-shirt is white you would call chromakeyWhite on your picture and pass it the picture for the 

T-shirt and thresholds. This will cause the white pixels in your image be replaced with the new T-shirt picture.  

○ You may also use a "source" Picture as a parameter to the second chromakey method. Let's say you replace your 

green background with a scene from Star Wars. Then you want to replace the red in your shirt, but the red lasers in 

the new Star Wars background are also getting replaced. For this, the best thing to do is to pass the original "source" 

Picture (before any changes) as an additional parameter to the method. You would then check the "source" picture 

for red values and if they are red, replace the pixels in the calling object with the pixels from your T-shirt 

background. 

○ Finally, show your new picture!  

 

 

STANDARD CREDIT: 

• To get the standard credit for correctness you need to do two things:  

o replace the background with a background image 

o replace the T-shirt with some other image of your choice 

• Your total credit for the correctness section would be decided on how clean your edge detection algorithm is for the 

background and the T-shirt. 

• Other things like commenting, style of coding, method and class headers etc. will still apply like all previous homework you 

have done so far. 

 

EXTRA CREDIT: 

● You are absolutely encouraged to be creative in this assignment; we expect some AWESOME looking pictures to be turned 

in!  

● Make sure it looks good, this assignment shouldn't take too long, so we expect the final picture to look almost real.  

● Based on your creativity you can receive up to 5 points extra credit!!   

 

SOME TIPS: 

• Load your picture of you and your partner in solid colored t-shirts in front of the bright green sheet into Dr. Java and use the 

explore() method on it to see what levels of red, green and blue are in the green sheet that are not in your skin or hair or 

clothes. This will help you to determine your threshold for the colors so that you can make your green screen effect as best as 

possible. (Explore your shirts too so that you can make sure these are as clean as possible).] 

 

• When you are taking your picture BE CREATIVE, use chairs or jump up! 

 

• DO NOT color your picture based on x,y location (the top half is all green so I’m just going to color  

while y < pic.getHeight()/2 – NO! You MUST use COLOR THRESHOLDS, not x,y locations. 

 

• If your skin has very similar RGB values to the green sheet, you MAY load the picture into Paint first and make the green 

brighter, but you MAY NOT color in the green in Paint with your new background. The picture you load into your program 

must be green screen with solid T’s. 

 



• You may run into the problem that your new background has blue in it and then you try to color your blue T-Shirt and it 

colors also the new background. DO NOT fix this by using location specific code, think of more creative ways. (i.e. 

referencing the original picture but coloring the new one). 

 

• You may run into the problem that your picture is bigger than the new background you want to use or vice-versa. You can 

solve this in a few ways. One is you are allowed to re-size in Paint beforehand, but this may still be an issue when you are 

trying to copy a small image (100,100) onto your shirt (located starting at 200,200 in your big picture). In this case, you need 

to keep track of two different indices – the one to your picture and the one to the shirt picture. Same goes for the background. 

It may be simpler if you make all your images the same dimension. 

 

• Try to make your pictures look as awesome as possible, take a little time to plan out the picture first. 

 

• As an example, take a look at what previous students have done for this homework by looking at the pictures 

displayed on the walls of the basement corridor. These pictures are all around the basement walls. Feel free to get 

inspired by them. 

 

• START EARLY and get into the lab playing with this ASAP. Tutors will be there to help, but it won’t be much help if you 

are all there on Thursday trying to get help when you had most of the week! Also, this one is supposed to be fun, so the 

earlier you start, the more fun you can have with it ! 

 

More tips: How to improve the green of your screen or the color of your t-shirt using The GIMP.  

 

The GIMP is the powerful (and free!) image editor available on the lab computers. It is also available for download on Windows and 

Mac. 

 

1. Under the Applications menu go to Graphics->The GIMP. If you have never used GIMP before you might get some setup screens, 

just keep clicking continue.  

 

2. Open your file from within The GIMP. You can use File->Open.. or Ctrl-O. 

 

3. One of the tools looks like a magic wand, select it. Now click somewhere on the green screen. 

 

4. Holding the shift key keep clicking on new areas of the screen, even previously selected areas, to increase your selection. If you 

found you have selected too much you can undo with Ctrl-Z and then go back to selecting with the shift key held down. You can 

change the threshold value in the tool panel to fine tune the range of colors that get selected. 

 

5. Keep doing this until you are happy with the selection. Focus on getting the screen around the person's image, you can easily paint 

over the outlying areas by hand if necessary. 

 

6. Now go to Tools->Color Tools->Color Balance and set the magenta-green slider all the way to the right and the other sliders all the 

way to the left. The selected area should now be a nice green color. 

 

7. Use the eyedropper tool to get a sample of the green background and then paint over any remaining areas that were not selected. 

You can deselect the image with Shift+Ctrl+A. 

 

Rinse and repeat for the t-shirt if necessary. 

 

Note: Another option is to use the paint bucket for the last step and just fill the selected area with a green color. I find that this often 

makes the edges look weird so I don't like this solution myself. 

 

 

 

How to turnin your homework electronically  

Only ONE partner should run the turnin script - do not submit two copies of the same homework. 

Make sure the program works correctly in your cs8fxx login on the workstations in the labs in the basement of the CSE 

building when the workstations are booted under Linux (CentOS). 

 

When you are ready to turn your program in, first open a terminal window by right clicking on the empty area of your 

computer’s desktop and select "Open a new Terminal."  

 



In addition - you can submit up to 3 pictures of your choosing (NO MORE THAN 3 PLEASE!!) 

 

Make sure all the files that you want to submit are in your hw6/bookClasses folder. 

 

Type in the following command 

 
turnin hw6 

 

Three files are required to be submitted for hw6:  

● Picture.java 

● HW6.java 

●   Any additional (no more than 3) pictures you want to submit in the form: pic1.jpg (where pic1.jpg is the name of your file)  
 

You can verify your turnin with the following command 

 
verify hw6 

 

It is your responsibility to make sure you properly turned in your assignment. 

 


