
 

 

 

 

 

 

Photoshop is an extremely powerful program.  (And an extremely expensive one!  The full version you 

are using on these lab computers is roughly $700.  You can download a free trial version for 30 days if 

you want to do your homework at home rather than in the lab.) 

This lab is going to be in two parts:  First, you will learn how to use some of the basic (and not so basic) 

tools by performing a "makeover" of an image of Madonna and then a caricature of her as well.  Next, 

you will use some more advanced techniques to create a pseudo-scientific simulation animation of a 

glacier melting. 

A. Photoshop Basics 

To introduce some of the basic (and not so basic) tools in Photoshop, we are going to play with an image 

of Madonna.  The image was chosen because it is large enough that pixilation is not generally a problem 

even when zoomed in. 

Step 1: 

• Create a Lab8 folder in your CSE3 folder and download the image Madonna.jpg from you class 

website.   

• Save the file in your Lab8 folder and open Photoshop CS4 from the start menu.    

• Once in Photoshop, choose File->Open... and select Madonna.jpg from your Lab8 folder. 

 

Step 2: 

You can use the Magnifying glass icon  on either the left side vertical toolbar or the top horizontal 

toolbar at any time to zoom in or out on portions of your image.  When you click on that icon, a new 

zoom toolbar appears at the top of your screen with various options: 

 
You may want to choose "Fit Screen" for the next step. 

 

Step 3: 

You can always UNDO or REDO something by selecting Edit->Step Forwards or Edit-> Step Backwards. 

I find that Edit->Step Backwards (shortcut <Ctrl>+<Alt>+Z) is the most useful, though it only steps back a 

certain number of times.   

 

To DESELECT an area, hit <Ctrl>+d. 
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Step 4: 

Let's crop the image to focus mainly on her head and the top part of her shoulders.  To do this, use the 

crop tool towards the top of the toolbar on the left-hand side of your screen:  

• Draw a rectangle around Madonna's head and 

shoulders.   

• Don't worry about getting it placed perfectly.  You can 

resize the crop area by clicking and dragging on the 

little squares on the sides and corners of your 

rectangle. 

• When you are satisfied with your selection, either hit 

enter, or click the little checkbox in crop toolbar above 

your image.  

• When you are finished, you should see something like 

this: 

 

 

Step 5: 

I don't like the white patches in the background, so let's try to 

get rid of them.  Perhaps the first thing you might think of is to 

try using the magic brush tool and the eye dropper/paint bucket tool to fix the background. 

• Use the eyedropper tool  to select the color of one of the blue pixels in the background. 

• Use the magic brush tool  (just above the crop tool) to try and select the blue background.  

Use the magic brush toolbar to change the size and/or the add or subtract magic brush tool and 

try to select the blue background but not her hair.  Tough, huh? 

• Once you have the background selected to your satisfaction, you can use the Paint Bucket Tool 

to fill it with the blue color that you sampled with the eyedropper in the previous step.  The 

Paint Bucket Tool is hiding behind the gradient tool:  

so you want to right click that tool and choose "Paint 

Bucket Tool" to fill in the area selected. 

• You'll notice this method doesn't work so well around her hair: 

 

 

 

 

 

 

 

 

 



Step 6: 

Let's try using the eyedropper and paintbrush tools to get rid of those white splotches next. 

• Use the Paintbrush Tool  to try and paint the background so it is a consistent blue color 

(you already grabbed the blue color using the Eyedropper Tool in the previous step).  Note that 

when you select the Paintbrush Tool, a Paintbrush Toolbar appears above your image:   

 

• Try some of the different options here, especially 

the brush size and type and the Opacity. 

• The problem is, unless you are VERY careful with 

the settings, you could end up with something 

like: 

• To solve this problem, try using the setting from 

the Paintbrush Toolbar shown above.  The 

lowered "hardness" (to about 50%) and the 

lowered opacity lets you get close to the hair 

without hiding it though you still need to be 

careful how many times you pass over it so that 

you don't turn her hair blue.  If you are careful, 

you should get something that looks pretty good. 

 

Step 7: 

Next, let's get rid of those lines and wrinkles under her eyes.  This is the perfect job for the Healing Brush 

Tool.  If you were to try and do this with the Paintbrush Tool, you'd just replace the dark lines with light 

lines which would not look good.  The Spot Healing Brush Tool is great if you just have a little blemish, 

like a zit, but the Healing Brush Tool is better for when there is a large area to cover. 

•  Select the Zoom tool and draw a rectangle around both eyes to see them better. 

 

• Select the Healing Brush Tool by right clicking on the 

bandaid icon and choosing the second option:  

• The healing brush tool is a little bit tricky to use.  I suggest 

using a small brush (around 30 pixels in size).  You want to 

select a "source" to start with.  I would suggest the area 



right underneath the lines (marked with a star in the image above).  To select the source, hold 

down the <Alt> button and click on the image. 

• Unclick the <Alt> key and stroke outwards over the wrinkle with the Healing Brush Tool.  It may 

take you a couple of tries to get it to come out well. 

• You will want to use multiple "source" locations for different wrinkles. 

• The default setting for the Healing Brush Tool is "Normal" which blends both parts together.  

You can also select "Replace" which replaces the old location with the selected location. 

 
 

Step 8: 

Next, lets hide her roots. 

 

• We can use the Healing Brush Tool for this as well.  The Healing Brush Tool is great when you 

have a color and texture that you want to repeat rather than just a color. 

• Again, we want to select a "source" by holding <Alt> and clicking the Healing Brush Tool on the 

spot suggested by the star.   

• This time, move your brush inwards just enough to cover the brown roots. 

• You will want to use multiple "source" locations so that the hair looks as natural as possible.  

You are not going to be able to get rid of the darkness entirely without making it look very fake, 

but you can certainly make it look much better than before! 

 

 

 

 

 

 



Step 9: 

Finally, let's get rid of her distinctive gap between her teeth.  

• Zoom way in on her mouth and teeth. 

 

• First, let's use the Rectangular Marquee Tool  to select a small rectangle of tooth just on 

the edge of the gap: 

 

• Next select Edit -> Free Transform. 

• Grab the little box on the gap side of the selection and carefully drag so that the tooth covers 

half of the gap. 

• Do the same thing with the other tooth. 

 

• If the line is still a bit dark, you can use the Blur Tool to soften it:  

 

 



Step 10: 

Your picture of Madonna should be looking pretty nice by now!  But there's still one more thing we can 

do.  Let's cut down on some of the glare on her face by using an Adjustment Layer Mask. 

• From the Layer menu item, choose New Adjustment Layer -> Brightness/Contrast... 

• Move the Brightness slider until it's somewhere between -10 and -15.  This will make the entire 

picture a little bit darker. 

• Hopefully you should now see a Layers sidebar on the right 

side of your screen:  

• You should have two Layers (we'll talk a lot more about 

Layers in the second part of this lab).  You can turn each layer 

on or off by clicking on the little eye icon to the left of the 

layer. 

• This is going to sound strange, but, while the 

Brightness/Contrast layer is still selected, you want to color 

the entire picture black. 

• Probably the easiest way to do this is to make sure that 

selected color is black.  If you click on the little icon above the 

color squares in the bottom part of the left-side 

toolbar:  you will default to the black/white background/foreground colors.   Next, if 

you hit the little double headed arrow next to it, you will swap the black into the 

foreground. 

• Use the Paint Bucket Tool to fill the entire layer in black. (If you don't see the Paint Bucket Tool, 

remember to right click on the Gradient Tool and select it from the menu.) 

• You have just MASKED the entire negative Brightness  effect over the entire picture.  We now 

want to UNMASK just the portions of the picture that look shiny. 

• Select the Paintbrush Tool and resize it (shortcut = the square brackets keys  '[' and ']') so that 

the brush is roughly the size of the shiny patches. 

• Lower the opacity to only 25% or so so that you 

don't overdo it by accident. 

• Re-click on that little double arrow so that WHITE is 

in the foreground again and carefully 

dab over the shiny areas to let some of 

that negative Brightness layer back in. 

 

Step 11: 

Once you have your picture looking the way you want, you 

should collapse the layers to make it into a single picture. 

• Go to Layer -> Flatten Image on the menu bar. 

 



 

Step 12: 

Make sure you SAVE you photoshopped picture!  You will want to choose Save As... and save it as type 

.JPG otherwise Photoshop will try to have you save it as type .PSD which you don't want.  Just say OK to 

any options that it asks you about. 

 

Step 13: 

If you want to have some fun and make a Characature of Madonna, select Filter -> Liquify... from the 

menu bar.  If your TA has enough time, they can show you how to use the various toolbar items:  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

B. Scientific Animation 

It is often useful when presenting data or information to be able to demonstrate simulations of how you 

believe things occurred.   It is important to note that this is NOT truly scientific, but it can be useful to 

visualize whatever you are studying.   

 

We are going to put together a simulation of a glacier melting from two pictures: a "before" picture 

taken in 1958 with a large glacier, and an "after" picture of a shrunken glacier taken in 2003.  Because 

we DO NOT know the RATE at which the glacier has been shrinking, our simulation is going to assume a 

CONSTANT rate.  This is a giant assumption and part of what makes this simulation non-scientific, 

though still potentially useful. 

 

Step 1: 

If you haven't already, download the before and after images (GlacierBefore.jpg and GlacierAfter.jpg) 

into your Lab8 folder from your class webpage. 

Forward Warp Tool 

Reconstruct Tool 

Twirl Clockwise Tool 

Pucker Tool 

Bloat Tool 

Push Left Tool 

Mirror Tool 

Freeze Mask Tool 

Thaw Mask Tool 

Hand Tool 

Zoom Tool 

Turbulence Tool 



 
 

Step 2: 

Open both pictures in Photoshop. 

 

Step 3: 

From the GlacierAfter.jpg, choose Layer -> New -> Layer... to create a new layer the same size as the 

image.  Name your new layer "Before". 

 

Step 4: 

Go back to the GlacierBefore.jpg 

and use the Magnetic Lasso Tool 

to outline the glacier.  We haven't 

seen this tool before, and to find 

it, you want to right-click on the 

normal Lasso Tool near the top of 

the 

toolbar.

 
You can use the Magnetic Lasso 

Tool to carefully outline the 

glacier.  Click once along an edge 

and just keep moving it around till 

you reach your starting point.  

Click one more time to close the 

loop. 

1958 2003 



 

Step 5: 

Once you have your starting glacier selected, copy it and paste it into the new layer that you created in 

GlacierAfter.jpg. 

 

Step 6: 

The glacier is unlikely to be in the correct place in the GlacierAfter image.  You should use the Move 

Tool  to grab the bigger glacier and place it over the later image as well as you can.  Don't expect it to 

be perfect just yet. 

 
 

If you look in the Layer's sidebar, you should see that you have two layers - one a background image 

with the GlacierAfter.jpg and the other just checkboxes with a glacier on it. 

 

If you click on the eye icon next to the Background image, you can 

turn it off and just see the glacier itself. 

 

 

 

 

 

 

 



 

Step 7: 

The "before" glacier has some rough edges and doesn't blend very well into the "after" image.  To fix 

this: 

• Select the glacier by holding down the <Ctrl> key and clicking on the SMALL THUMBNAIL IMAGE 

OF THE GLACIER IN THE LAYERS SIDEBAR. 

• From the menu, choose Select -> Refine Edge... 

• Set the Smooth slide-bar to roughly 10 

• Set the Feather slide-bar to 0 

• Set the Contract/Expand slide-bar to roughly -25 

• Then click OK 

• From the menu, choose Select -> Inverse 

• And then Edit -> Cut 

• You should now see something similar to 

GlacierBefore.jpg except for a stream in front of 

the glacier and maybe some rough edges around 

the side and back.  We're not going to worry 

about any of this right now. 

 

 

Step 8: 

We're going to create a rather simple animation that only has 5 frames: The before (that we've been 

working on so far), the after image (GlacierBefore.jpg) and three in the middle.  The easiest way to 

create the three intermediate frames is by first creating the very middle frame as half-way between the 

beginning and the end, and then creating the second and fourth frame as each halfway between an 

endpoint and the middle. 

 

To create the middle image: 

• Make sure your "Before" layer is selected in the Layers sidebar.  

• From the menu, select Layer -> Duplicate Layer... 

• Name your new layer "Middle" 

• You can drag the layers around 

to put them in the right order. 

• Uncheck they eye icon from the 

Before layer so that only the 

Background layer and the 

Middle layer are showing. 

• Change the Opacity on the 

Middle layer to around 50% 

• You should now be able to sort 

of see the Background "After" 



picture of the glacier through the Middle "before image. 

• Select the Middle image by holding the <Ctrl> button and clicking on the thumbnail view in the 

Layers sidebar. 

• From the menu, choose Edit -> Transform -> Warp 

• This is where the real "art" of Photoshop comes in:  You want to warp the Middle image so that 

it is roughly in between the Before shape (shown by a dotted line) and the After image shape of 

the glacier (shown through the semi-opaque Middle image).  It is not easy to do a good job.  

Spend some time playing with it but don't worry if yours doesn't look quite right. 

 
 

When you are done, you should have 

something like this: 

• Click on the checkmark above the image or 

hit enter to accept the transformation. 

• Change the opacity of the Middle layer 

back to 100%. 

Before Image 

Middle Image 

After Image 



 

 

Step 9: 

You should now be able to create two additional layers/images 

on your own - one called "BeforeMiddle" and the other 

"AfterMiddle" each showing transitional steps of glacier 

movement.  Refer to Step 8 if you need any reminders. 

 

When you are done, you should have a Background layer and 

four other layers: 

 

Step 10: 

Now we want to make the individual images look good against 

the background.  To do this: 

• Right click on the background and choose Duplicate 

Layer...   

• Name your layer something like "BeforeBG" 

• Do this FOUR times ("BeforeMiddleBG", "MiddleBG", 

"AfterMiddleBG") 

• Select ONE duplicate background layer (using the eye 

icon) and ONE of your four intermediate image layers 

and NOTHING ELSE.  Make sure all other images do 

NOT have the eye icon checked. 

• On the menu bar, choose Layer -> Merge Visable and 

those two layers will be combined into one (you also 

have to have one of the two selected for it to work). 

• Do this for all four glacier/background 

pairs.  

 

Selected 



 

Step 11: 

Now it's time to work our Photoshop magic on the individual images to make them look better.  Take a 

few minutes and use some of the "basic" tools you learned in the first part of the lab to clean up your 

four new images. 

Suggestions: 

• Clean up the edges (bottom and top in particular) so that they look more natural and blend in 

with the background. 

• Do something intelligent with the stream so that it doesn't miraculously "appear" out of 

nowhere (continue it up to the glacier, shrink it, get rid of it, etc...) 

• Depending on how much time is left in the lab, you may or may not have time to do a good job 

with this. 

The five layers that I came up with after roughly 15 minutes worth of work are: 

 

 

 

 

 

 

 

 

 

 

 

Step 12: 

Now we want to turn these five images into an animation. 

• From the menu bar, select Window -> Animation 

• In the upper left-hand corner of the animation window, click on the 

little tiny button showing multiple horizontal lines. 

• Choose "Convert to Frame Animation" 

• Click on the button again and choose "Make Frames From Layers" 



• Click on it a third time and choose "Reverse Frames" 

• Now you should see five frames in the Animations window: 

 
 

• Click on the little arrow on each frame 

and change it to 0.5 sec (you may want to 

leave the last frame at 1 sec) 

• Click on the arrow next to "Once" and 

change it to "Forever". 

• Hit the "Play" button, and watch your 

glacier shrink. 

 

Step 13: 

Now let's save your file: 

 

• SAVE your file as GlacierMelting.psd to save it in this format so that you could come back and 

modify it later. 

• On the menu bar, choose File -> Save for Web & Devices... and choose Save and Save when you 

have the option.  This will save your file as GlacierMelting.gif so that you can put it on a 

webpage just like you would any other .gif file. 

 

C.  Putting it all online 

Step 1: 

Modify your CSE3Page.html to include links to your final Madonna picture Madonna.jpg and your 

GlacierMelting.gif   

Step 2: 

Put everything online and get checked off. 

REMEMBER to either drag your ENTIRE CSE3 folder into your public_html folder OR into the 

WHITESPACE inside the public_html folder!!!! 

 

Checkoff: Demonstrate to your TA/Tutor that both your makeover picture and your animation are 

complete. 



 


