
 

 

 

 

 

 

A. Basic Statistics 

There are some very basic statistical concepts that every college educated person should understand.  

These are useful for understanding your grade distributions in classes here at UCSD, current events, and 

all manner of information in your lives.  Because this isn't a math class, we are going to focus on the 

intuition and use of a very few of the most common statistical metrics. 

 Mean 

In most cases, when people say "Average", they are referring to the arithmetic mean.  

For a set of data points, the arithmetic mean or "Average" is the sum of those points 

divided by the number of points.  For example, if we have points 4, 5, and 6, the mean is 

calculated as .  This fits with most people's intuition of the word 

"Average".  In this lab, we will use the words "mean" and "average" interchangeably, 

though Excel has only one function to calculate it: =Average() 

 

 Min/Max 

  The min/max of a set of data points is fairly intuitive and needs no explanation. 

 

 Standard Deviation 

The standard deviation is one of the most commonly used statistics, and one of the least 

commonly understood by non-statisticians.  While the mathematical definition is 

somewhat complicated, the basic intuition is that the standard deviation describes how 

wide-spread the data is - the bigger the spread, the higher the standard deviation.  The 

size of the dataset also affects the standard deviation.  If we only have a few numbers 

ranging between 1 and 10 for example, the standard deviation will likely be higher than 

if we have thousands of numbers ranging between 1 and 10. 

   Example: 

A B 

4, 5, 6, 5, 5 4, 1, 7, 11, 2 

     

    Both these sets A and B have an average of 5. But A has a standard  

    deviation of 0.7 while B has a standard deviation of 4.1.   

   

  Excel has a simple function to calculate the standard deviation of a set of points:  

   =stdev() 

Lab 5 
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In this lab we will learn some more advanced data manipulation 

and analysis techniques using Microsoft Excel 2007.  



B. Download and Import the Data into Excel 

We're going to be working with and analyzing a large dataset describing ocean temperatures in La Jolla 

collected automatically from a buoy over the last 8 years.  Every hour, the buoy takes two temperature 

readings.  Over the last 8 years, that adds up to a LOT of data! 

 

Step 0: 

Create a Lab5 folder in your CSE folder. 

 

Step 1: 

Go to  

http://cdip.ucsd.edu/?nav=historic&sub=data&stn=073&stream=p1&xyrmo=200907&xmap_id=17 

to see a map of the San Diego area data buoys.  Most of the buoys have been decommissioned and are 

no longer gathering data. 

 

Step 2: 

Click on buoy number 100 in the upper left hand corner of your map. 

Select "pm download table" underneath "Monthly products" on the left-hand side of the next screen. 

You should now see a chart of all the information available from that buoy over the last 8 years by 

month. 

 Click on the "All Data" link in the upper left-hand corner of the chart. 

 This may take several minutes due to the enormous quantity of data. 

 

Step 3: 

Once the data has finished downloading (you will be able to tell because you should see today's date as 

the very last entry) we need to save it. 

• On the menu bar, click Edit => Select All 

• Hit Ctrl-C to copy the data 

• Open a new Notepad++ document and Ctrl-V to paste the data (this may take a few minutes) 

• Save the data as Buoy100.txt (watch your spelling!!!!) into your Lab5 folder. 

 

Step 4: 

Now that we have the data saved in text format, we need to import it into Microsoft Excel.  If you had 

tried to save directly into Excel, it would not have worked - it would have tried to save everything into a 

single column rather into many columns as we want it. 

• Open Microsoft Excel 2007.  This dataset is so large, that Excel 2003 could not hold it all. 

• Click on the Microsoft Office Button in the upper left-hand corner of the screen and choose 

"Open" 

• Navigate to your Lab5 folder and look for files of type: "All Files" and then select Buoy100.txt 

• An Import Wizard window will pop up and ask you how you want to import the data into Excel 



o The Delimited option lets you import files where each column is separated by some 

character - a space, a comma, a semicolon, etc... 

o Fixed width allows you to specify the column locations manually in the little window at 

the bottom of the screen 

• Choose the Fixed width option because some of the columns in the data we are importing are 

empty, making using the Delimited option difficult.  Click Next. 

• You will have to manually click to insert line separators in the preview window so that every 

column is separated by a line 

• Click Next then Finish and your data should be imported properly into Excel. 

• SAVE YOUR FILE AS Buoy100.xlsx before you do anything else.  You don't want to lose your work 

later if there is a problem. 

 

Step 5: 

There are a bunch of columns that we are not going to be using.  Descriptions of what these columns 

mean can be found at: 

 http://cdip.ucsd.edu/?nav=documents&sub=index&xitem=description&xdoc=pm_format 

 

Step 6: 

Select columns D-N and right-click to delete them. 

Select columns E and F and delete them as well. 

 

C. Data "Massaging" 

You should now have four columns of data remaining: 

 Year, Month (MO), Day (DY), and Temp 

 

Step 1: 

Select the second row and delete it. 

Rename D1 as "Temp ( C )" and label cell E1 as "Temp ( F )" 

 

Step 2: 

The temperature data is all in Celsius.  Most of you are probably more familiar with Fahrenheit as a 

measure of temperature, so let's convert it. 

The formula to convert from Celsius to Fahrenheit is: Tf = (9/5)*Tc+32 

 Where : 

  Tf = temperature in degrees Fahrenheit 

  Tc = temperature in degrees Celsius 

 

In cell E2, use the formula above to calculate the  temperature in Fahrenheit  

 (HINT: you should get 57.56 degrees) 

 



 

 

 

Step 3: 

We want this formula to be dragged down so it converts every temperature to Fahrenheit, but 146 

thousand rows, you'd be at it all day.  There is an easier way: 

• Select cell E2 

• Hit Ctrl-C to copy the formula 

• Use the scroll-bar to scroll to the bottom of your data 

• Hold the SHIFT button and select cell E146142 so that the entire column is selected 

• Press Ctrl-V to paste the formula into each one of those cells 

 

Step 4: 

The date information is broken up into three columns.  It would be nice if we could get it to look like a 

"normal" date, i.e. 1/30/01 for the first entry. 

• Insert a column between columns C and D (Right click on the letter "D" at the top and "Insert") 

and label it "Date" 

• Use the formula =date(year,month,day) to create a single date for the first entry 

• Use the method from Step 3 to copy the date formula down for the entire spreadsheet 

 

Step 5: 

We now again have a bunch of extra data in our spreadsheet that we don't need.  The problem is that if 

we simply delete columns that we don't want anymore, none of our formulas will work.  We want to get 

rid of the formulas and just have values in all the columns so that we can delete those that we no longer 

need. 

• Select the entire spreadsheet by clicking on the little square above the row 1 and to the left of 

column A 

• Ctrl-C to copy the entire spreadsheet 

• While it is still selected, click on the bottom half of the Paste button on the Home tab and select 

"Paste Values" (this will take a few moments) 

• Now you can delete columns C and E (make sure you delete Temp (C), and NOT Temp (F)) 

• Keep columns A and B for now (we'll use them again later) 

 

Step 6: 

Lets calculate some basic statistics about the data we have massaged so far. 

• In cells F2 through F6 type in the labels: "Min", "Max", "Average", "Std. Dev" 

• In cells G2 through G6 use equations to calculate these values.   

 =min() 

 =max() 

 =average() 

 =stdev() 



In this case, since the range between the minimum and maximum values is fairly big (24.5 degrees F) 

and there are so very many data points, a standard deviation of 4.7 is not large but certainly not tiny.  

You'll see why that is when we start graphing the data in the next section. 

 

D. Analyzing the Data 

Now that we've got our data cleaned up a bit, let's start playing with it. 

 

We'd like to create a graph of the Temperature over time, but right now we have more data points than 

Excel can chart.  Besides, we don't need to have almost 50 datapoints per day!  Let's take the average 

temperature for each day in our dataset instead. 

 

Step 1: 

• At the bottom of the spreadsheet, click the "New Tab" button just to the right of the current 

tab.  This will create a new tab called "Sheet1". 

• Right click on the word "Sheet1" and click "Rename" 

• Name this tab "Daily Mean" 

• In cell A1 and B1 type the labels "Day" and "Mean" or "Average"  

• In cell A2, type 1/30/01 and underneath it in cell A3 type 1/31/01 (this is where our data starts) 

• Select both cells A2 and A3 

• Grab the fill handle in the lower right-hand corner of the selected cells and drag down until you 

reach today's date (7/14/09).  

• In cell B2, use the function =averageif(range,condition,[ave-range]) to calculate the daily mean 

  range = C column in spreadsheet tab "Buoy100" 

  condition = cell A2 in the "Daily Mean" spreadsheet 

  [ave-range] = Temp (F) column (column D) in spreadsheet tab "Buoy100" 

• Either drag this formula down or copy/select/paste to replicate it for each day 

 

Step 2: 

Now that we've got our daily averages, let's graph it! 

• Select columns A and B in the Daily Mean spreadsheet tab 

• On the Insert tab, choose the first option under the Line chart menu in the Charts group 

• Format the resulting chart by modifying the Title, legend, and axis labels appropriately.  Your 

chart may look something like this: 



 

 

 

Step 3: 

Now that we've got our chart, let's try to interpret it. 

• First, notice how the temperature oscillates between the low winter temperatures and the high 

summer temperatures.  This oscillation helps explain why the Standard Deviation was as big as it 

was even with so many data points. 

• Next, note that there are three horizontal lines from the temperature line to the bottom axis.  If 

you zoom in on these areas, you'll find that there is data missing at these spots 

o 8/14/03 is missing from the original spreadsheet entirely 

o 10/31/05 to 11/3/05 is missing 

o 12/6/07 to 12/11/07 is also missing 

The data may be missing through some accident, or perhaps the buoy was broken on those 

days, but whatever the cause, we need to do something intelligent to deal with the problem. 

 

Step 4: 

The data may be missing in the "Buoy100" spreadsheet tab, but it's not missing in the "Daily Mean" tab 

because we just generated dates for every day over those 8 and a half years.  If we just deleted those 

rows from the "Daily Mean" chart as well, it would fix the problem temporarily, but we'd run into more 

problems later. 

Instead, let's use the average of the days on either side of the missing data to fill in the gaps. 



• Using a calculator or even Excel, calculate the average value of the temperatures on either side 

of all three gaps. 

• Replace the missing values in the "Daily Mean" spreadsheet with these average values. 

• This kind of data replacement is a perfectly reasonable thing to do AS LONG AS YOU describe it 

in whatever report or paper you describe your data analysis in. 

 

Step 5: 

Now that you have a nice graph displaying average daily temperatures over a period of eight and a half 

years, let's look at some trendlines and see if we can see any effects of Global Warming in our Ocean 

Temperature data. 

 

Excel has a number of different built-in methods to analyze data.  We're going to use Linear Regression 

to create a trendline for our data.  Trendlines can be used to understand existing data and to predict 

future data.  

• In your finished chart, right-click on some data point (the blue line in the example shown above) 

• Select "Add Trendline" 

• In the Trendline window that shows up, you'll see lots of options for different types of 

regression models.  We want to choose a "Linear" model. 

Our data is clearly nonlinear - however a linear model will help us see trends in where 

the data is headed - it will effectively average out the high's and the low's of a year and 

create a line that represents the "center" of the data.  The direction of this center line 

will tell us if the water in this particular buoy location has been changing temperature 

over the last several years or not. 

• At the bottom of the Trendline window, also check the "Display Equation on chart" checkbox 

and hit Close. 

• Your chart will now look something like this: 



 

 

• Because the slope of the trendline is zero to 3 decimal places, it would be very 

reasonable to claim that "Ocean Temperatures as measured at this buoy over the last 

8.5 years have stayed roughly constant and show no signs of increasing".  Of course, 

data covering many more years would be much more useful than this "small" amount of 

data that we have available to us. 

 

Step 6: 

Let's now create a new tab that will let us compare days across all 8.5 years of the available data at the 

same time. 

• Create new tab named "Daily Summary Statistics" to compare daily values by year 

• In cells B1 to J1, create column labels for 2001 - 2009 

• In cell A1 create the column label "Day" 

• In cell A2, type 1/1/09 and in cell A3 type 1/2/09 

• Select these two cells and drag down until you reach 12/31/09 ( all the days in the year) 

• Select the entire "A" column and format it on the Home tab, Number group as a date of type  

  "3/14" using the "More Number Formats..." menu item. 

• Manually copy data from the "Daily Mean" tab for year 2001 (starts Jan 30) 

o Select the average temperature associated with the date 1/30/01 (cell B2) 

o Scroll down the page until you see 12/31/01 

o Holding the SHIFT button down, click on the cell containing the average temperature for 

 12/31/01 to select all temperatures for 2001 

o Return to the "Daily Summary Statistics" tab 

o In the column for 2001 (the B column), select the cell associated with 1/30/01 (cell B31) 



o Paste Special (either using the button on the Home tab or by right clicking and selecting  

 from the menu) 

o Choose the "Values" radiobutton and click OK 

• Repeat this process to copy the data for each year into the appropriate location 

• You will notice that years 2004 and 2008 were leap years.  They both have an extra entry.  We  

 are not particularly worried about this and will ignore it. 

 

Step 7: 

Now that we've got our daily averages separated out by year, let's graph it! 

• Select cells A2 through J366 in the Daily Summary Statistics spreadsheet tab 

• On the Insert tab, choose the first option under the Line chart menu in the Charts group 

• You may notice that while you have a bunch of colored lines representing each year, none of the 

lines is labeled with the year.  This is because there is some kind of bug with Excel 2007 that will 

not let you (or at least wouldn't let me!) include the column names in this graph.  To deal with 

this: 

o Select the chart 

o Click on the "Select Data" button in the Data group on the left hand side of the Design 

tab. 

o Select "Series1" on the left-hand side of the pop-up window and click the Edit button 

o Type in "2001" for the Series name and hit OK. 

o Repeat this process for each series, from 2001 to 2009 

• Format the resulting chart by modifying the Title, legend, and axis labels appropriately.  You can 

also Format the vertical axis by right clicking on one of the temperature numbers.  This will let 

you specify the minimum/maximum values on the horizontal axis.  Your chart may look 

something like this: 

 



 

 

  

Step 8: 

Cool as this chart is, it's a little bit hard to read.  Why don't we use some simple statistics to create a 

chart that summarizes this information in a way that is MUCH easier to understand. 

• In the "Daily Summary Statistics" spreadsheet tab, create three new columns labels to the right 

of the yearly numbers:  

 "Min", "Max", and "Average" 

• Calculate the min/max/mean for each day over all the years using the functions: 

   =min() 

   =max() 

   =average() 

• Drag these formulas down to cover every entry 

• Select the A column and hold down SHIFT and select the three columns containing your 

statistical calculations 

• On the Insert tab, choose the first option under the Line chart menu in the Charts group 

• Format the resulting chart by modifying the Title, legend, and axis labels appropriately.  You can 

also Format the vertical axis by right clicking on one of the temperature numbers.  This will let 

you specify the minimum/maximum values on the horizontal axis.  Your chart may look 

something like this: 

 



 

  

• From looking at this chart, you should notice that there is a larger range of temperatures in the 

summer months than in the winter.  This means the standard deviation is going to be higher 

during these times than where the min and the max are close to each other. 

 

E.  Putting it all online 

Step 1: 

Modify your CSE3Page.html to include links to your Buoy100.xlsx file.  WATCH YOUR 

SPELLING!!! 

Step 2: 

Put everything online and get checked off. 

REMEMBER to either drag your ENTIRE CSE3 folder into your public_html folder OR into the 

WHITESPACE inside the public_html folder!!!! 

 

Checkoff: Go to your homepage via the class webpage and demonstrate to the TA/Tutor that your 

Buoy100.xlsx and all the relevant graphs are complete. 

 


