
 

 

 

 

 

A. CSV FILES and EXCEL INTRODUCTION 
CSV files are data files in table format where a new line separates a row and a comma separates the 
columns.  
CSV stands for “comma separated values” and Microsoft Excel can read these files. 
 
Step 1: Open your CSE3 folder and create a new Lab4 folder. 
Go to  your class homepage and save the files demographics.csv and interests.csv into your Lab4 
directory.  
Be sure to Download/Save with Right-Click. Do not open these links with a Left-Click. 
 

Step 2:  
Open Microsoft Excel 2007 (NOT 2003) 

Start => All Programs => Microsoft Office => Microsoft Office Excel 2007 

Click on the Microsoft Office Button  in the upper left hand corner of your screen and click Open  
Go to your Lab4 directory and select All Files from Files of Type at the bottom of the window.  
Open interests.csv 
 

Step 3:  
Now we want to save it as an xls file instead of csv file.  

Click on the Microsoft Office Button  and select Save As => Excel Workbook  
Verify that the new name is interests.xlsx 
Save it in your CSE3/Lab4 folder! 
 

Step 4:  
Once you have the file saved and open, we’re going to “massage” the data. 
 
First, make it so you can actually see the information in the first column.   

• Put your curser on the line between the A and the B in the header row at the top of your screen. 

• Double click to auto-resize the column width. 
 
Next, add a new row at the very top of the page.  There are two ways to do this: 

1) Select the existing row by clicking on the row number on the left-hand side of 
your screen.  On the Home tab of the Ribbon, click on the Insert button in the 
Cells group. 

2) Right-click on the existing row number on the left-hand side of your screen and select Insert. 
 
Use your new row to add labels for the existing columns of data: 

• Add the word Topic in the first column 

• Frequency in the second column 

• Percentage in the third column. 
Make the whole row bold by selecting the row and clicking on the B format button. 
Resize the columns for greater readability. 
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Step 5:  
We’re going to use formulas to calculate information in our spreadsheet.  Formulas and equations 
ALWAYS start with an equal sign!! 

• In cell C2, type the formula =B2/92 
o B2 is the location of the cell we want to divide 
o The number 92 comes from the number of votes the maximum topic had 

• This formula calculates the percentage of the current topic compared to the maximum - HTML 

• If we want to calculate the percentage of EACH topic compared to the maximum topic.  We 
don’t have to re-enter the formula in each cell.  Rather we can click and drag the formula 
through all the cells we want. 

o Select the cell C2 
o Grab the little square at the bottom right corner of the cell (fill handle) 
o While holding your left-mouse button down, drag the curser to cell C20 and release. 

 

Step 6: 
Just like you can select an entire row by clicking on the row number on the left hand side of the 
window, you can also select an entire column by clicking on the column letter at the top of the window.  
You can also select the entire spreadsheet by clicking on the box above the 1 and to the left of the A.  

• Select the whole spreadsheet and click on the Data tab on the Ribbon.  Click on 
the Sort button in the Sort & Filter group.  

o Here you can choose the ordering and whether you want it ascending or 
descending.  

o In our case, sort by Frequency in Largest to Smallest order.  
o Note that HTML has the highest frequency. 

 

B. RELATIVE and ABSOLUTE ADDRESSING 
Just like with files, cells can be referenced using either Relative or Absolute addressing. 

• If you click on cell C2 and then C3, you will notice the formula is slightly different. 
o This is because the formula we created in C2 is a Relative address so when we dragged 

the formula to other cells, the formulas changed relative to the original cell.   
o This also happens if you copy and paste a formula. 

• Sometimes we don’t want the formulas to change.   
o We can make a formula use an absolute address by inserting a dollar sign $ before the 

letter or number you are referencing that you don’t want to change. 
� For example, if you always want to reference column A regardless of where you 

move it, you would use the formula =$A1+$A2.  
� If you always want to reference row 1 and 2 from the previous formula, you 

would use =A$1+A$2.  
� Lastly, you can combine them if you always want to use specific cells (e.g. A1 

and A2). To do this, you would use the formula =$A$1 + $A$2.  
o You can use dollar signs $ in any formula where you reference a cell. 

 
 
 
 
 
 
 



Step 1:  
Below is a spreadsheet snippet with two formulas. For each question, there is a formula in B2 and you 
copy and paste that formula into B3. What is the resulting value of B3? (The value in B2 is always 3). 
 

 A B C 

1 2 1 2 

2 4   

3 7   

 
Formula in cell B2 is: “=A2-A1+B1”.   

You copy and paste or drag it into B3. Value of B3 is ________ 
 You copy and paste or drag it into C2. Value of C2 is ________ 
 You copy and paste or drag it into C3. Value of C3 is ________ 
Formula in cell B2 is: “=A$2-A$1+B1”.   

You copy and paste or drag it into B3. Value of B3 is ________ 
You copy and paste or drag it into C2. Value of C2 is ________ 

 You copy and paste or drag it into C3. Value of C3 is ________ 
Formula in cell B2 is: “=$A2-$A1+B1”.   

You copy and paste or drag it into B3. Value of B3 is ________ 
You copy and paste or drag it into C2. Value of C2 is ________ 

 You copy and paste or drag it into C3. Value of C3 is ________ 
Formula in cell B2 is: “=$A$2-$A$1+$B$1”.   

You copy and paste or drag it into B3. Value of B3 is ________ 
You copy and paste or drag it into C2. Value of C2 is ________ 

 You copy and paste or drag it into C3. Value of C3 is ________ 
 
 
 
 

C. FORMULA FUNCTIONS 
When using Excel spreadsheets, you will probably want to use more sophisticated functions than 
simple arithmetic. Excel comes with a library of various financial, statistical, and various formula 
functions that you can use. Instead of writing 92 directly in the formula in C2, we are going to use a 
function to compute the maximum value. 
 

Step 1:  
Delete the contents in cell C2. Then click on the cell C2 (the cell you want to insert the formula 
function in).   
Choose Formulas on the Ribbon. 
Select the Insert Function button in the Function Library group. 
 

Step 2:  
Choose MAX and click OK. The MAX function takes in a range of numbers and returns the maximum 
value in that range.  

Click and drag the values you want in the range and click OK.  
Use the range from B2 to B20.  
The value in cell C2 should now be 92 because that is the maximum in the range B2:B20. 

 



Step 3:  
Because we want a percentage, modify the formula to so to divide the Frequency value in B2 by the 
maximum frequency.  

Cell C2 should have the formula =B2/MAX(B2:B20) 
 

Step 4:  
Is the MAX(B2:B20) an absolute value or a relative value?   

• It’s relative because we don’t have any dollar signs in the formula. 

• Do we WANT it to be relative? 
o As we drag our formula to cells C2-C20, do we want the range in the formula to 

change? 
o NO! 

 
Use dollar signs to fix the formula. 
 

Step 5:  
Now fill the formula down from C2 to C20. You should see a 1 in cell C2. 
 

Step 6:  
Reformat the cells in column C to be percentages. 

• Select column C by moving your mouse over the letter C.  

• When it turns into a down arrow, click on it so the column is selected. 

• In the Home tab of the Ribbon, click on the little arrow next to 
General in the Number group 

• Choose Percentage 

• You should now see nice percentage numbers in column C. 
 
 

D. CLUSTERED COLUMN CHART 
Now let’s create our first chart. There are various ways to format your chart, and we’ll walk through 
one now.  
 
Step 1: Select cells A1 through B20. Click and drag from cell A1 to B20 to do this. 
Step 2: From the Insert tab on the Ribbon, click on Column in the Charts group, and select the first 
2-D option – Clustered Column Chart 
Step 3: In the Chart Tools Design tab, click the Move Chart button in the Location group all the way 
on the right. 

• Choose New Sheet 

• Rename the sheet Topics of Interest 

• Click OK 
Step 4: Change the chart title to CSE 3 Topics of Interest. 
Step 5: In the Chart Tools Layout tab, use the Labels group to  

• Change the label on the Horizontal axis to Topic. 

• Turn off the Legend 

• Play with the Data Labels 
Step 6: Save everything now. 
 



E. STACKED COLUMN CHART 
Now we’ll create another chart using the demographics of CSE3. We want to determine enrollment per 
quarter by class level. 
 
Step 1: Open up demographics.csv in Excel and save it as a Microsoft Office Excel Workbook in your 
Lab4 folder. 
Step 2: Select cells A1:R5 (the class level data).  
Step 3: From the Insert tab on the Ribbon, click on Column in the Charts group, and select the 
second option – Stacked Column 2-D or Stacked Column 3-D 
Step 4: In the Chart Tools Design tab, click the Move Chart button in the Location group all the way 
on the right. 

• Choose New Sheet 

• Rename the sheet Enrollment by Class Level 

• Click OK 

•  
Step 5: In the Chart Tools Layout tab, use the Labels group to  

• Give the chart a title: CSE 3 Enrollment per Quarter by Class Level 

• Change the horizontal axis label to Quarter.  

• Change the vertical axis to Enrollment by Class Level.  

• Show the Data Table. 
Step 6: Save everything now. 
 

F. PIE CHART 
Now we want to determine cumulative enrollment by college. 
 
Step 1: Click on the demographics tab at the bottom of the window to switch back to your data. 
Step 2: Insert a column before column B ("FA05"). Label the new column All Quarters. (This is 
similar to how you inserted a new row.) 
Step 3: In the All Quarters column, add a SUM formula in cell B2. You want to sum from C2 to S2. 
Now fill down the formula from B2 to B54. Do we need to use any absolute cell references? 
Step 4: Select the cells containing the cumulative enrollment by college (A8:B13) 
Step 5: From the Insert tab on the Ribbon, click on Pie in the Charts group, and select either the first 
or second option  
Step 6: In the Chart Tools Design tab, click the Move Chart button in the Location group all the way 
on the right. 

• Choose New Sheet 

• Rename the sheet Enrollment by College 

• Click OK 
Step 7: In the Chart Tools Layout tab, use the Labels group to  

• Give the chart a title: CSE 3 Cumulative Enrollment by College  

• Turn off the Legend 

• Click on the Data Labels button and select More Data Label Options 
o Check Category Name and Percentage 
o Uncheck Value 
o Play around with the label position 

Step 8: Save everything now. 
 



G. YOUR OWN CHART 
 

Step 1: 

Create your own chart describing something about cumulative enrollment by major (cells A16 to B54).  
After you have finished your chart, save everything. 
 

H. PRESENTATION 
Now we will create a presentation with all the charts you have created. 
 

Step 1:  
Start up PowerPoint by going to Start => All Programs => Microsoft Office => Microsoft Office 

PowerPoint 2007 (NOT 2003) and save it as Presentation.pptx in your CSE3/Lab4 folder. 
 

Step 2:  
You’ll see two empty boxes.  
The first one should be the title of your presentation.   

Something like CSE3 Enrollment Interests.   
The second box should have your name and the quarter. 
 

Step 3:  
Select the Design tab on the Ribbon and select a Theme you like from the Themes group 
 

Step 4:  
Now insert a new slide by going to Insert tab and selecting New Slide from the Slides group. 
Choose Title and Content as your slide type  
You should now see a blank slide. 
 

Step 5:  
Switch back to your interests.xlsx page and copy the entire chart using Ctrl-C 
Use Ctrl-V to paste the chart into the body of the slide.  
Give your slide a title 
 

Step 6:  
Now for the most annoying (fun) part of the lab.  
Select part of your slide – the title or the chart itself. 
Choose the Animations tab on the Ribbon and select the Custom Animation button in the 
Animations group. 
A new toolbar should open up on the right-hand side of your screen. 
Click Add Effect and play with some of the animations.  
 

Step 8:  
Create new slides and insert the rest of your charts into the presentation.  Save everything. 
You should have a total of 5 slides when you’re done.  

• One title slide 

• 4 slides with Charts 
 
 
 



Lab Checkoff:  

Go to your homepage via the class webpage and demonstrate to the TA/Tutor that your 
PowerPoint file is complete (you should have five slides with at least four different charts) and 
linked on your CSE3Page.html.   

You do not need to show the .xlsx files. 

Homework Checkoff for next lab: 

Demonstrate to the TA/Tutor that your Budget.pdf is complete (does not have to be online) and 

that you have created a pie chart of your expenses. 

I. Putting it all online 
 

Step 1: 
Modify your CSE3Page.html to link to:  
 interests.xlsx 
 demographics.xlsx 
 Presentation.pptx 
 

Step 2:  
Using SSH, transfer everything online. 
 

J. Homework 
There is a Excel homework posted on the class webpage.  In it, you will use formulas to create a 
financial budget for yourself.  Financial information is usually private, so you do not need to put your 
budget online.  Your TAs and Tutors WILL NOT look at any of the details in your budget, they will 
look at just enough to verify that you have done it so they can give you credit.  We hope that you will 
use your real information so that this homework is as useful to you as possible.  If this is a problem for 
you, feel free to make up numbers instead (we won't know either way). 


