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Do NOT forget to have your homework checked off in the first five minutes of Lab! 

 

A. Create a basic File Structure 
Let’s start by opening up the My Documents folder on your desktop. 

 

Step 1: 
Create a new folder in My Documents named CSE3 with ALL CAPS and NO SPACES!! 

There are three ways to do this: 

1) Go to the File menu and select New => Folder 

2) Select New Folder on the menu on the left-hand side of the window 

3) Right click the mouse and select New => Folder 

 

Step 2: 
Open up your new CSE3 folder and create another new folder called Lab2 with THE FIRST LETTER 

CAPITALIZED and NO SPACES!!! 

 

Now you have created a basic file structure.  In this lab, we are going to create two Microsoft Word 

documents: ColorModels.doc and MyMajor.doc.  Once we add these files, this file structure would be 

displayed visually as: 

 

  

 

 

 

 

 

 

 

Step 3: 

Terminology: 

• My Documents, CSE3, and Lab2 are DIRECTORIES 

• ColorModels.docx and MyMajor.docx are FILES  

o with the FILE EXTENSION “.docx”.   

You need to make sure you understand these terms as they are fair game for your quizzes and exams. 

 

B. Pathname Notation 
The image above is a visual representation of the file structure.  An individual file or folder can also be 

described in Pathname Notation. 

 

Step 1: 

Lab 2 
CSE 3, Fall 2009 

In this lab you will learn about file structures and advanced features of 

Microsoft Word.  You will then work on a simple Scratch program for 

homework. 

My Documents 

 CSE3 

  Lab2 

   ColorModels.docx 

   MyMajor.docx 
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The Pathname Notation for ColorModels.doc is  

 “My Documents/CSE3/Lab2/ColorModels.docx” 

What would the Pathname Notation for MyMajor.docx be? 

 

 

C. Microsoft Word 2007 
This quarter we will be using Office 2007 and NOT 2003.  If you are used to using Microsoft Vista, this 

is probably what you have used before. If not, it's going to be quite different from what you are used to. 

 

Step1: 

We need to open Microsoft Word  

Go to: 

Start => All Programs => Microsoft Office => Microsoft Office Word 2007.   

The first time you open Microsoft Office Word 2007, your computer will want to configure it.  This 

will take a few minutes.  Be patient. 

Click OK on any dialog boxes that show up. 

 

Step 2: 
If you haven't used Office 2007 before, you'll notice that it looks very different from previous versions 

of Office.   

The most obvious change is the strip at the top.  This is known as the Ribbon, and contains all the 

buttons that you used to find by navigating toolbars. 

 

 
 

Step 3: 
The VERY FIRST thing we always want to do when we create a new file is to SAVE IT!!!   

There are two ways to do this: 

• At the very top-left of your screen, you should see a funky, 

multicolored icon in a circle-shaped button.  This is known as the 

Microsoft Office Button.   If you click on it, you will get a list of 

options and can choose the Save or Save As option. 

• Next to the Microsoft Office Button in the very upper left-hand corner, 

you should see a button that looks like an old fashioned floppy disk.  

Click on that icon to save your file.  The area that this icon is located in is known as the 

Quick Access Toolbar. 

Using the toolbar at the top of the Save window, navigate to your Lab2 folder. 

Save the file as ColorModels.docx in your Lab2 folder.  

 

Step 4: 

You might notice that the file extension for Word 2007 is .docx instead of just .doc 

That is because Microsoft has based the new WORD file format on XML.  

Word 2007 can read any file created in an older version of Word. 

Older versions of Word CANNOT read documents created in Word 2007 without a converter, and not 

even always then. 
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D. Copying from the Web 
We’re going to learn a little bit about RGB and CMYK color models. 

 

Step 1:  

Open Firefox and go to http://www.google.com.  

Search for the phrase “rgb additive cmyk subtractive”. 

 

Step 2:  

Click on the first link you see, which should be something like “Graphics Color Models”.   

Spend a few minutes looking through the document to try and understand the difference between the 

two color models.   

 

Now we’re going to copy some text from that webpage into our document.  

 

Step 3:  

Select the text from heading “Color Models” to the bottom of the second paragraph that ends in “for 

printing”. Then copy it by pressing Ctrl-C. 

 

Step 4:  

In Word, go to the Home tab on the Ribbon, and on the far left-hand side you'll see 

a Paste button.   

Do NOT click the Paste button, but instead click the arrow underneath it and choose 

Paste Special. 

It will show you a list paste options.  

You want to select “Unformatted Text”, and then click OK.  

 

If you were to press Ctrl-V and just paste it, it would have automatically selected “HTML Format”, 

which we don’t want here. 

 

Step 5:  

Repeat steps 3 and 4 with the next chunk of text, starting from “Notice the centers…” to “…(see 

below)”.  At this point you should have roughly a page worth of text. 

 

Step 6: 
Finally, go farther down the page and select the text under (and including) the headings: “RGB Color” 

and “CMYK or ‘Process Color’ ” WITHOUT copying the picture.  Paste everything into your 

document as “Unformatted Text” 

 

Step 7: 
Without modifying the format of any of your text, you might want to go through and remove the extra 

empty lines that this process has left between each paragraph. 
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E. Using built-in Styles 
 

Step 1: 

You have probably created your own headings in MS Word before using the Bold, Underline, and Font 

Size buttons in the Font toolbar.  

We’re going to show you a different, more advanced way of doing it that gives you more options. 

 

Step 2: 
Select the text “Color Models” that should be at the top of your screen.   

Because we pasted as “Unformatted Text”, it should look just like all the rest of the text on your screen. 

 

Step 3: 
On the Home tab of the Ribbon, you should see a group called Styles.   

With your text selected, choose the Title style from among your choices (if you don’t 

see it, click on the arrow next to the styles which will show you all your options). 

 

Step 4: 
Next, select the next heading in your document “The Two Most Common Color 

Models” and choose the Heading 1 style. 

 

Step 5: 
Finally select the remaining two sub-headings “RGB  Color” and “CMYK or ‘Process 

Color’” and set both of them to the Heading 2 style. 

 

 

F. Table of Contents 
Why bother using all these fancy styles?  In addition to pre-formatting everything for you (you can 

change the way each style looks if you want to), using the built-in styles allows us to auto-generate a 

Table of Contents. 

 

Step 1: 
Put your curser underneath the Title heading “Color Models”. 

 

Step 2: 
On the References tab, in the Table of Contents group, click on the Table of Contents 

button. 

 

Step 3: 
Choose whichever type of table you like most, and Word will automatically generate one for you at the 

top of the page where your curser is. 

 

Step 4: 
Not that it’s particularly important for a document of this size, but if you hold down Ctrl and click on 

one of the items in the Table of Contents, it will take you directly there.  
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G. Inserting Images 
We don’t want to just copy and paste images in because sometimes the formatting can be changed 

during the process.  If you don’t believe me, try copying and pasting the images from firefox into word. 

 

Step 1:  

There are two images on the webpage that we want to save into our document. 

RIGHT CLICK on each image and select Save Image As… 

Save the image in your Lab2 folder, leaving the names the same as the default. 

 

Step 2:  

In Word, choose the Insert tab, and choose Picture from the Illustrations group. 

Find one of the two pictures you just saved in your Lab2 folder, and insert them into your document. 

Repeat this step to insert the other picture. 

 

Step 3: 
You'll notice that the pictures are attached to the document so that you can't move them around.  Select 

the image so that it has a black line around it.  This should automatically open up the Picture Tools 

option on the Ribbon.   

In the Arrange group, you should see an icon labeled Text Wrapping.  

 

 

Step 4: 
Click the text wrapping button and select Square.  Now you can move the images around the screen 

and place them where desired.  We will do more with text wrapping later on. 

• Put the RGB image in the RGB section 

• Put the CMYK image in the CMYK section 

 

H. Text Wrapping 
Earlier, we modified the text wrapping of the image from In Line with the text to Square.  This works 

very well for square images, but there are better text wrapping schemes for our images. 

 

Step 1: 

Click on one of the pictures.  

Open the Page Layout tab of the Ribbon. 

• Click on the Text wrapping button and choose Tight and the text will wrap tightly around 

the image eliminating any white space.  

• At the bottom of the list, there is also Edit Wrap Points, which allows you to text wrap 

with any arbitrary shape that you want.  

 

Step 2: 

Choose Edit Wrap Points, and arrange your images in an attractive style on the page, following along 

with your TA to see how to use Edit Wrap Points to their best advantage. 

 

Step 3:  

If you see gray dots, you won’t be able to text wrap. In this case, click off the picture and click back on 

the  picture. 
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I. Inserting and Manipulating Textboxes 
Occasionally you will want text that isn’t inline with the rest of the text. An example would be a 

"blurb" about the text that really stands on its own.   

Microsoft Word 2007 has a much greater variety of textbox options available than previous versions of 

Word. 

 

Step 1:  

Chose the Insert tab on the Ribbon.   

In the Text group, click on the Text Box button.   

A menu will pop up with many different pre-formatted text box options.   

• Choose whichever one you want to use and it should appear in the center of your screen. 

• To move your textbox, click on the line around it and drag. 

• To change the text in the textbox, click anywhere inside of it and either just start typing. 

 

Step 2: 
Go back to the webpage that you copied all your information from.  Notice that there are two little 

"blurbs" of information above the two images.  Copy both of these into your textbox, one on top of the 

other.   

• You might want to format the text a little, changing the font size, and making it centered for 

instance.   

o You can format the textbox by selecting the text inside of it and formatting just like 

you would any other text. 

• Make sure you resize the textbox when your formatting is complete so you can see all of the 

information in it. 

o To resize the textbox, click on one of the white dots and drag it in the dimension you 

want. Corner dots allow you to resize both width and length at the same time. 

• Play around with some of the new, built in formatting features in Word 2007 

 

Step 3:  

If you move your new textbox around and it is on top of the existing text, be sure to text wrap the 

textbox in the same way you did the images.  This may or may not be a problem. 
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J. Outline Format 
You might notice in these lab write-ups, that I use bullet points frequently to organize information.  

Bullet points or numbered outlines are a useful way to display certain kinds of information. 

 

Step 1: 
At the very bottom of your document, create a new section titled “Summary”.   

You can use the Style group of the Home tab to make it a Heading 1. 

 

Step 2: 
Underneath your new heading, create an asterisk – the little fuzzy star on top of the ‘8’ button on your 

keyboard (*). 

 

Step 3: 
If you hit the space bar, it will automatically turn it into a bullet point for you. 

If you hit the Tab button, the bullet will move to the right and change shape. 

If you hit Shift-Tab, the bullet will move back to the left. 

 

Step 4: 
Try to create the following mini-list: 

• RGB 

o Additive 

• CMYK 

o Subtractive 

 

Step 5: 
If you right-click on your new bulleted list, you can modify the bullets or change them to a Numbering 

format.  Whatever you like. 

 

Step 6: 
Now that you’ve added a new heading, you want to update 

your Table of Contents. 

Right click on your Table of Contents and choose: Update 

Field.  (This can also be done on the Ribbon). 

When you see the dialog box at right, choose Update entire 

table as shown and hit OK. 

Your new Summary section should now appear. 

 

 

K. Page Numbers 
If you have a long paper that’s many pages in length, you might want to include page numbers.  Word 

will automatically generate these for you. 

 

Step 1: 
Go to the Insert tab, and click the Page Number tab from the Header & Footer group. 

 

Step 2: 
You will be given several choices for formatting.  Choose whichever option you like. 
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L. Inserting Footnotes 
Footnotes are useful for making citations.  Footnotes in Word are automatically numbered so you don’t 

have to add them in order.  We have really plagiarized Mike’s webpage today, so we really should cite 

our sources. 

 

Step 1:  

Click on the location you want to add your footnote (typically at the end of a sentence, 

paragraph, or title). Then go to the References tab on the Ribbon, and in the Footnotes 

group, click on the Insert Footnote button.  

 

Step 2:  

A small superscript number will appear at the bottom of the page. Go ahead and type footnote text for 

it, for example, the web address where you took this information from. 

 

Step 4:  

After you have added at least one footnote, save your finished document in your Lab2 directory. It 

should look roughly like the following: 
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M. Saving as Other File Types (PDF, HTML) 
There are many reasons not to use Word files. People may not have Microsoft Word, or may not have 

the right version of Microsoft Word.  Here we will consider other alternatives.  

The first alternate option is PDF, which is the format of this lab writeup that you are reading. Microsoft 

Word 2007 has build in conversion support for PDF, but you have to download and install it separately.  

Another option is to use a free program called PrimoPDF.  With PrimoPDF, you will create a PDF by 

“printing” to it rather than “saving” it. 

 

Step 1:  

Select the Microsoft Office Button and choose Print. 

 

Step 2:  

Change the “zz_Null_Printer” name to PrimoPDF. Then click OK. 

 

Step 3:  

You should see a window pop up with two print settings, Screen and Print. Print is optimized for 

printing, so it has higher resolution. Screen is lower resolution, and designed for screen viewing. You 

should pick Print. 

 

Step 4:  

Click on the three dots near the lower right corner of the window, and select where you want to save it. 

Also give a shorter file name with no spaces. Then click Save, and then finally OK. Acrobat Reader 

should automatically open at this point. 

 

 

We can also, save our file as HTML.  When Word saves as HTML, it takes the images out and creates a 

separate directory for the images.  

 

Step 5:  

Click on the Microsoft Office Button in the upper left-hand corner of your screen. 

Hover your curser over the Save As button, and choose the last option, Other Formats. 

 

Step 6:  

A dialog box should pop up. 

In the “Save as Type” at the bottom, select Web Page (NOT “Single file web page”), and then click 

Save. Notice that a new directory “lab2_files” was created along with your image. 

 

HTML formatting is not as precise as Word or PDFs, so expect images to be jumbled around. In 

general, HTML is good when you want quick easy access via the web without much formatting, Word 

documents are good when you need other people to edit it, and PDFs are good when people are just 

going to print it or you have very specific formatting and layout. 
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N. Your Major… 
You’ve now learned how to use some of the more advanced features in Microsoft Word.  It’s your turn 

to apply these to a document of your own choosing. 

 

Step 1: 
Create a Word document and save it as MyMajor.docx in your Lab2 folder. 

 

Step 2: 

Find information on your major, department, or career goals online, including images, and use it to 

create your Word document. 

You can also create your own content such as paragraphs and bulleted or numbered lists about your 

major or the classes you’ve taken or plan to take that contribute to it.   

 

Step 4: 
Your finished document needs to contain: 

• At least one Image 

• The image should have Text Wrapping 

• At least one Textbox 

• At least one Bulleted or Numbered list. 

• At least one Footnote noting where you got the information. 

• A Table of Contents that makes use of all the nice styles that you incorporate. 

  

Step 5:  

Save the file as a Word DOCX, a PDF, 

and a Web Page (HTM). 

 

Your final document might look 

something like this: 
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Lab Checkoff:  

Go to your homepage and demonstrate to the person checking you off that  you have: 

 ColorModels.pdf and ColorModels.htm 

 MyMajor.pdf and MyMajor.htm 

Each file should have: 

 At least one Image 

 Text Wrapping 

 At least one Textbox 

 At least one Footnote 

 A bulleted or numbered list 

 A table of Contents 

Make sure you get checked off before you leave. 

Homework Checkoff: 

You need to have a working game with a sprite that moves horizontally and a ball that 
falls vertically as in the description. 

You need to keep score and stop and display a message if the player looses the game. 

 

O. Putting Files up on the Server 
Transfer the files to your web server.  

See Lab1 if you don’t remember how to do this 

 Move the entire CSE3 folder into your public_html folder  

 REMEMBER to move it into the WHITESPACE inside public_html 

 

To see your files online, go to your personal homepage, and add /CSE/Lab2 on the end of the address 

in the address bar at the top of the window.  Your address bar should look something like: 

 

http://acsweb.ucsd.edu/~_________/CSE3/Lab2 

 

You should be able to see a list of all the documents you put online.  Next week we’ll create a webpage 

to display your work more clearly. 

 

P. Homework 
You have another Scratch project that you are going to work on for this week's homework.  You can 

find a pdf with instructions on the same Labs page as this lab write-up. 

 

You need to do everything EXCEPT the optional enhancements at the end. You should try some of 

these enhancements for fun. 

You are welcome to customize the background and sprite costumes to be whatever you like. 

You need to be ready to have your homework checked off at the beginning of your next lab. 

 


