Learning About Technology

- People do not have any innate technological abilities
  - Our experience using (related) devices, including software, shows us what to expect
  - Designers who create devices, including software, know about this experience and design products to match what we already know
The Desktop

- Image displayed on the monitor when a PC starts up
  - Colored or patterned background
  - Information displayed on top, bottom, or side
- Three types of icons:
  - Applications (programs)
  - Folders (directories)
  - Files (documents)

The Desktop (cont'd)

- "Desktop" is a metaphor
  - An analogy for computation
    - Working at PC is analogous to working at a desk
      - Work goes in files
      - Files go in folders
      - Tools (a program or a calculator) are used to perform tasks

Playing Recorded Music

- Example of metaphoric user interface
  - Software that plays CDs on computer has Graphical User Interface (GUI)
  - This GUI resembles a familiar music player
    - Buttons resemble an ordinary CD player
    - User can apply knowledge of CD player to learn to use this GUI without special instruction because the metaphor is familiar
Understanding the Designer's Intent

- Software designers try to pick easy-to-understand user interfaces
- We can expect good software to be well crafted so we can "brain out" how it works
- We use this idea every time we use new software

Consistent Interfaces

- Designers use metaphors similarly
- When we see an icon or metaphor we have seen before, we know how it works
- There are standard metaphors found in all GUIs
Command Buttons

- May look like a 3D rectangle or circle, with an icon or text centered on the button
- We click mouse to "press" the button and the command is *invoked*
  - Tells the software to perform the operation
- We receive *feedback* to confirm the button has been clicked
  - Color change, shadow, highlight, or audible click

Slider Control

- Sets a value from a "continuous" range, like volume
- Move slider by placing mouse pointer on it and dragging in the direction of change
  - Scroll bars are a type of slider control

![Figure 2.1: Graphical user interface for playing audio CDs with Windows Media Player](image-url)
Triangle Pointers

- Indicates presence of hidden or alternative information
- Clicking on triangle reveals the information
  - Triangles at the ends of slide bars shift the contents of the window
- Experienced users look for familiar metaphors and learn new ones when they are encountered

Anatomy of an Interface

- **Menu**
  - List of operations the software can perform
  - Grouped by similarity of operations
  - Listed in *menu bar*
  - All operations performed by the software are listed in the menu

Figure 2.4. The three CSS displaying the hidden visual information.

Figure 2.5. The Microsoft Word menu bar for MacOSX with the Edit menu selected.
Menu Operation

- Menus on the top bar are called *pull-down* or *drop-down* menus
  - Mouse click reveals list of operations
  - Sliding mouse down the list highlights items
  - Clicking or releasing button on highlighted item causes computer to perform that operation
- Same operation may be available by icon on a toolbar below the menu
- Menus that display on a (right) mouse click are called *pop-up* menus

Reading a Menu

- Menus provide information about:
  - List of items
  - Submenus
  - Whether an operation is available
  - Where more user input is needed
  - Shortcuts
Submenus

- Menu items that have a category of choices have a triangle pointer at right end
  - Example in the Edit menu: Clear
- Selecting that item brings up another menu (submenu) with additional choices for that main item

Which Operations Are Available?

- GUI menu is created each time it is opened
- Specify which operations are available in a situation
  - e.g., copy is not available if nothing is selected to be copied
- Unavailable operations are shown in lighter color or "grayed out" and can't be selected
  - Example in the Edit menu: Cut

Is More Input Needed?

- Items that need more specification have an ellipsis at right end (…)
  - Example in the Edit menu: Paste Special…
- Selecting item pops up an additional menu requiring more input
- Software continues to ask for information by opening new windows until it has enough
- Then performs operation immediately and closes menu(s) and window(s)
Is There a Shortcut?

- Menu items may have keyboard shortcuts
  - Combination of keyboard characters that have the same effect as clicking menu item
  - Shortcut appears next to menu item
  - Shortcut consists of combination of special key (meta key) and a letter
    - For Mac: special key is Command (clover)
    - For Windows: special key is Control
  - Shortcuts are usually consistent across operating systems

Table 2.1 Standard Shortcuts. These common shortcut letters for standard software operations combine with “Control” (\textasciicircum{} for Windows or “Command” (\textasciicircum{}) for Mac OS X.

<table>
<thead>
<tr>
<th>File Functions</th>
<th>Edit Functions</th>
</tr>
</thead>
<tbody>
<tr>
<td>New N</td>
<td>Cut X</td>
</tr>
<tr>
<td>Open O</td>
<td>Copy C</td>
</tr>
<tr>
<td>Save S</td>
<td>Paste Y</td>
</tr>
<tr>
<td>Print P</td>
<td>Select All A</td>
</tr>
<tr>
<td>Quit Q</td>
<td>Undo Z</td>
</tr>
<tr>
<td></td>
<td>Redo Y</td>
</tr>
<tr>
<td></td>
<td>Find F</td>
</tr>
</tbody>
</table>

Standard GUI Functionality

- Operations that are available in any software because they are needed to process any type of information
  - Save
  - Open
  - Print
- Standard operations usually grouped as File and Edit
File Operations

• Generally apply to whole instances of the type of information being processed
  – Word Processor: Instance is a document
  – MP3 Player: Instance is a song
  – Photo Editor: Instance is a picture

File Operations (cont'd)

• New: Creates a blank instance
• Open: Locates and reads file on disk
• Close: Stops processing current instance, closes window, but keeps program running
• Save: Writes current instance to disk, using previous name and location
• Save As: Writes current instance to disk, using new name and location

File Operations (cont'd)

• Page Setup: Specify how printed document should appear on paper
• Print: Prints copy of current information
• Print Preview: Shows how the information will appear when printed
• Exit or Quit: Ends application
New Instance

- Recall that New creates a "blank" instance
- What is blank information?
  - Information is grouped into types based on properties
    - Digital photographs are a type of information; length and width are among the properties
    - Text documents are a type of information; length of document in characters is a property
  - A blank instance is the structure of the file, with no properties or content filled in
- A prudent user will Save As right away to specify a name and location for this new instance

Edit Operations

- Let you make changes within an instance
- Often involve selection and cursor placement
- Edit operations are performed in standard sequence:
  - Select, Cut/Copy, Indicate Placement, Paste, Revise

Edit Operations (cont'd)

- Undo: Cancels the most recent editing change (may not be available for some operations)
- Repeat: Applies the most recent editing change again
- Copy: Stores a temporary copy of selected information, ready for pasting
Edit Operations (cont’d)

- **Cut:** Removes selected information and saves in temporary storage, ready for pasting
- **Paste:** Takes data held in temporary storage by Cut or Copy, and inserts it into current instance
- **Clear:** Deletes selected information
- **Select All:** Selects the entire instance

Microsoft Office 2007 Ribbon

- **New ribbon** interface in Vista
  - Hides most menu operations until needed
  - Office button (upper left corner) is the *File* menu
  - Edit operations are in several locations
    - Home tab: *Cut, Copy, Paste*
    - Quick Access toolbar (above Home tab): *Undo*
    - Far right end of ribbon: *Find, Replace, Select*
Expecting Feedback

- Feedback is any indication that the computer is still working, or has completed task
  - For editing change, proof of completion is that the revision is visible
  - For button click, software provides an indication like highlighting, shading, graying, underlining, changing color, or audible click

Expecting Feedback (cont'd)

- Most common feedback: Indication that computer is working on time-consuming task
  - Cursor is replaced with icon like hourglass (Windows) or rainbow spinner (Mac)
- Other forms of feedback: busy spinner, running dog or horse, time-estimating meter "fills", completion count

"Clicking Around"

- Exploring a user interface
  - Noting basic GUI features
  - Checking each menu to see what operations are available
- Helps user figure out what operations are available without being taught
- Clicking around works because consistent metaphors and interfaces make new software predictable
“Blazing Away”

• The next step after clicking around
• Assertively exploring features even without a clear idea of their functions
• Nothing will break:
  – Only risk is losing time spent and having to re-start or reboot
  – Remember the Undo operation
• Concentrate on operations related to whatever task needs to be done

Watching Others

• Complicated software systems usually have features that are not obvious, too advanced, or too specialized to learn by clicking around
• Shift-Select Operation
  – Allows you to select adjacent pieces
• Control-Select Operation
  – Allows you to select non-adjacent pieces
• Many obscure features, tricks, and shortcuts can be learned by watching others
A Basic Principle: Form Follows Function

- Fundamental operations of a software system and the way they work are determined by the task being solved
  - GUIs may look different, but two software systems for the same task will have same basic operations and will work similarly

Similar Operations Have Similar Features

- Text processing applications all:
  - Use a cursor to mark your place
  - Have operations for typing, deleting, selecting, copying, searching, replacing, etc.
  - These operations work similarly
    - e.g., backspace key removes character to the left of the cursor
- So how do vendors compete?
  - Add non-fundamental features
  - Make systems more convenient, friendlier, faster, less error-prone, etc.
Take Advantage of Similarities

- *Form follows function* principle is important because:
  - New versions of familiar software will share core functions, and many features and quirks of earlier versions
  - When we must perform a familiar task with unfamiliar software, we are already experienced and familiar with its basic features
  - When we are frustrated with one vendor's software, we can easily learn another

Searching Text Using Find

- An illustration of the principle that *form follows function*
- Text search, or find, is used in many applications such as word processors, browsers, e-mail readers, and operating systems
- Found under Edit or File menu (shortcut Ctrl-F)
- *Tokens* are the things to be searched
  - Single characters like letters, numbers, special symbols
  - Composite items like dates

How to Search

- Searching starts at beginning of document or at current cursor position
  1. "Slide" the search string along the text
  2. At each position, look for token match
  3. If there is a match, the process stops and displays the found instance
  4. If there is no match, slide the search string one position along
  5. If the search string is not found by the end of the text, search stops and is unsuccessful
Search Complications

- **Case Sensitivity:**
  - Computer stores uppercase and lowercase letters as different characters
  - Match only occurs when both the letters and the case are identical
  - Search tools are case-sensitive in word processors but not necessarily in all applications
  - User has the option to ignore case-sensitive capability
    - This is often the default

Search Complications (cont'd)

- **Hidden Text:**
  - There are two types of characters: keyboard characters typed by user, and formatting information added by the application
  - Search generally ignores application's formatting tags
  - Some systems allow user to search for formatted text such as italic.

Search Complications (cont'd)

- **Substrings**
  - User may be looking for words, but the tokens are the characters in the word
  - Search will turn up words that contain the search string (searching for "you" will turn up "your")
  - Word processors usually have ability to search for whole words

- **Multiword Strings**
  - Words are separated by spaces. If the number of spaces in the search string is different from the number in the text being searched, no match is found
Editing Text Using Substitution

- **Search and replace** combines searching and editing to make corrections to documents
- Useful for correcting all occurrences of search string
  - Change "west coast" to "West Coast"
  - Eliminate extra spaces
  - Formatting text

Technology: Take IT Personally

- We have learned we can expect intuitive interfaces
- To learn to use new software, we should ask ourselves:
  - What do I have to learn about this software to do my task?
  - What does the designer of this software expect me to know?
  - What does the designer expect me to do?
  - What metaphor is the software showing me?
  - What additional information does the software need to do its task?
  - Have I seen these operations in other software?

Take IT Personally (Cont'd)

- Other questions you may ask yourself about Information Technology:
  - Is there IT that I am not now using that could help me with my task?
  - Am I more or less productive using this technological solution for my task?
  - Can I customize the technology I'm using to make myself more productive?
  - Have I assessed my uses of information technology recently?