Preface

About This Tutorial

About the In-Depth Tutorial

This tutorial gives a description of the features and additions to Xilinx® ISE™ 11. The primary focus of this tutorial is to show the relationship among the design entry tools, Xilinx and third-party tools, and the design implementation tools.

This guide is a learning tool for designers who are unfamiliar with the features of the ISE software or those wanting to refresh their skills and knowledge.

You may choose to follow one of the three tutorial flows available in this document. For information about the tutorial flows, see “Tutorial Flows.”

Tutorial Contents

This guide covers the following topics.

- Chapter 1, “Overview of ISE,” introduces you to the ISE primary user interface, Project Navigator, and the synthesis tools available for your design.

- Chapter 2, “HDL-Based Design,” guides you through a typical HDL-based design procedure using a design of a runner’s stopwatch. This chapter also shows how to use ISE accessories such as CORE Generator™, and ISE Text Editor.

- Chapter 3, “Schematic-Based Design,” explains many different facets of a schematic-based ISE design flow using a design of a runner’s stopwatch. This chapter also shows how to use ISE accessories such as CORE Generator™, and ISE Text Editor.

- Chapter 4, “Behavioral Simulation,” explains how to simulate a design before design implementation to verify that the logic that you have created is correct.

- Chapter 5, “Design Implementation,” describes how to Translate, Map, Place, Route, and generate a Bit file for designs.

- Chapter 6, “Timing Simulation,” explains how to perform a timing simulation using the block and routing delay information from the routed design to give an accurate assessment of the behavior of the circuit under worst-case conditions.

- Chapter 7, “iMPACT Tutorial” explains how to program a device with a newly created design using the IMPACT configuration tool.
Tutorial Flows

This document contains three tutorial flows. In this section, the three tutorial flows are outlined and briefly described, in order to help you determine which sequence of chapters applies to your needs. The tutorial flows include:

- HDL Design Flow
- Schematic Design Flow
- Implementation-only Flow

HDL Design Flow

The HDL Design flow is as follows:

- Chapter 2, “HDL-Based Design”
- Chapter 4, “Behavioral Simulation”
  Note that although behavioral simulation is optional, it is strongly recommended in this tutorial flow.
- Chapter 5, “Design Implementation”
- Chapter 6, “Timing Simulation”
  Note that although timing simulation is optional, it is strongly recommended in this tutorial flow.
- Chapter 7, “iMPACT Tutorial”

Schematic Design Flow

The Schematic Design flow is as follows:

- Chapter 3, “Schematic-Based Design”
- Chapter 4, “Behavioral Simulation”
  Note that although behavioral simulation is optional, it is strongly recommended in this tutorial flow.
- Chapter 5, “Design Implementation”
- Chapter 6, “Timing Simulation”
  Note that although timing simulation is optional, it is strongly recommended.
- Chapter 7, “iMPACT Tutorial”

Implementation-only Flow

The Implementation-only flow is as follows:

- Chapter 5, “Design Implementation”
- Chapter 6, “Timing Simulation”
  Note that although timing simulation is optional, it is strongly recommended in this tutorial flow.
- Chapter 7, “iMPACT Tutorial”
Additional Resources

To find additional documentation, see the Xilinx website at:


To search the Answer Database of silicon, software, and IP questions and answers, or to create a technical support WebCase, see the Xilinx website at:

## Table of Contents

### Preface: About This Tutorial

- About the In-Depth Tutorial .................................................. 3
- Tutorial Contents ................................................................. 3
- Tutorial Flows ........................................................................ 4
  - HDL Design Flow ................................................................. 4
  - Schematic Design Flow ......................................................... 4
  - Implementation-only Flow ..................................................... 4
- Additional Resources .............................................................. 5

### Chapter 1: Overview of ISE

- Overview of ISE ....................................................................... 13
  - Project Navigator Interface ..................................................... 13
  - Design Panel .......................................................................... 14
    - Sources View ...................................................................... 14
    - Processes View ................................................................... 15
  - Files Panel ............................................................................ 15
  - Libraries Panel ..................................................................... 16
  - Console Panel ........................................................................ 16
  - Errors Panel .......................................................................... 16
  - Warnings Panel ..................................................................... 16
    - Error Navigation to Source .................................................. 16
    - Error Navigation to Answer Record ..................................... 16
  - Workspace ............................................................................ 16
  - Design Summary & Report Viewer ......................................... 16
- Using Project Revision Management Features .......................... 17
  - ISE Project File ...................................................................... 17
  - Making a Copy of a Project .................................................... 17
  - Using the Project Browser ...................................................... 18
  - Using Project Archives .......................................................... 18
    - Creating an Archive ........................................................... 18
    - Restoring an Archive .......................................................... 18

### Chapter 2: HDL-Based Design

- Overview of HDL-Based Design ............................................... 19
- Getting Started ...................................................................... 19
  - Required Software .................................................................. 19
  - Optional Software Requirements .......................................... 20
  - VHDL or Verilog? .................................................................... 20
  - Installing the Tutorial Project Files ....................................... 20
  - Starting the ISE Software ....................................................... 21
  - Creating a New Project .......................................................... 21
    - Creating a New Project: Using the New Project Wizard ......... 21
  - Stopping the Tutorial ............................................................. 23
- Design Description .................................................................. 23
Chapter 3: Schematic-Based Design

Overview of Schematic-Based Design ........................................... 47

Getting Started .............................................................................. 47

Required Software ......................................................................... 47
Installing the Tutorial Project Files ............................................... 48
Starting the ISE Software ............................................................... 48
Creating a New Project ................................................................. 48
Creating a New Project: Using New Project Wizard ...................... 48
Stopping the Tutorial ................................................................. 50

Design Description ....................................................................... 50

Inputs .......................................................................................... 51
Outputs ....................................................................................... 52
Functional Blocks ......................................................................... 52

Design Entry ................................................................................. 53

Opening the Schematic File in the Xilinx Schematic Editor ............ 53
Manipulating the Window View ..................................................... 54
Creating a Schematic-Based Macro ............................................... 54
Defining the time_cnt Schematic .................................................. 55
Adding I/O Markers ...................................................................... 56
Adding Schematic Components ..................................................... 56
Correcting Mistakes ...................................................................... 59
Drawing Wires ............................................................................. 59
Adding Buses ............................................................................... 59

Synthesizing the Design ............................................................... 39

Synthesizing the Design using XST .............................................. 40
Entering Synthesis Options ............................................................ 41
Synthesizing the Design ............................................................... 41
The RTL / Technology Viewer ....................................................... 41
Synthesizing the Design using Synplify/Synplify Pro .................... 43
Examining Synthesis Results ......................................................... 43
Synthesizing the Design Using Precision Synthesis .................... 44
Entering Synthesis Options through ISE ....................................... 45
The RTL/Technology Viewer ......................................................... 45

Inputs .......................................................................................... 24
Outputs ....................................................................................... 24
Functional Blocks ......................................................................... 24

Design Entry ................................................................................. 25

Adding Source Files ...................................................................... 25
Checking the Syntax ...................................................................... 26
Correcting HDL Errors .................................................................. 26
Creating an HDL-Based Module ................................................. 26
Using the New Source Wizard and ISE Text Editor ................. 26
Using the Language Templates .................................................. 29
Adding a Language Template to Your File .................................. 30
Creating a CORE Generator Module ......................................... 31
Creating a CORE Generator Module in the HDL Code ............. 31
Instantiating the CORE Generator Module in the HDL Code ..... 34
Creating a DCM Module ............................................................... 35
Using the Clocking Wizard .......................................................... 35
Instantiating the dcm1 Macro - VHDL Design ......................... 37
Instantiating the dcm1 Macro - Verilog ....................................... 38

Correcting HDL Errors ................................................................. 26
Checking the Syntax ...................................................................... 26
Adding Source Files ...................................................................... 25
Creating a New Project: Using New Project Wizard ................... 48
Starting the ISE Software ............................................................. 48
Creating a New Project ............................................................... 48
Creating a New Project: Using New Project Wizard ................... 48
Stopping the Tutorial ................................................................. 50

Outputs ........................................................................................ 24

Creating a CORE Generator Module ......................................... 31
Creating a CORE Generator Module in the HDL Code ............. 34
Creating a DCM Module ............................................................... 35
Using the Clocking Wizard .......................................................... 35
Instantiating the dcm1 Macro - VHDL Design ......................... 37
Instantiating the dcm1 Macro - Verilog ....................................... 38

Creating a CORE Generator Module ......................................... 31
Creating a CORE Generator Module in the HDL Code ............. 34
Creating a DCM Module ............................................................... 35
Using the Clocking Wizard .......................................................... 35
Instantiating the dcm1 Macro - VHDL Design ......................... 37
Instantiating the dcm1 Macro - Verilog ....................................... 38

Chapter 3: Schematic-Based Design

Overview of Schematic-Based Design ........................................... 47

Getting Started .............................................................................. 47

Required Software ......................................................................... 47
Installing the Tutorial Project Files ............................................... 48
Starting the ISE Software ............................................................. 48
Creating a New Project ............................................................... 48
Creating a New Project: Using New Project Wizard ................... 48
Stopping the Tutorial ................................................................. 50

Design Description ....................................................................... 50

Inputs .......................................................................................... 51
Outputs ....................................................................................... 52
Functional Blocks ......................................................................... 52

Design Entry ................................................................................. 53

Opening the Schematic File in the Xilinx Schematic Editor ............ 53
Manipulating the Window View ..................................................... 54
Creating a Schematic-Based Macro ............................................... 54
Defining the time_cnt Schematic .................................................. 55
Adding I/O Markers ...................................................................... 56
Adding Schematic Components ..................................................... 56
Correcting Mistakes ...................................................................... 59
Drawing Wires ............................................................................. 59
Adding Buses ............................................................................... 59

Synthesizing the Design ............................................................... 39

Synthesizing the Design using XST .............................................. 40
Entering Synthesis Options ............................................................ 41
Synthesizing the Design ............................................................... 41
The RTL / Technology Viewer ....................................................... 41
Synthesizing the Design using Synplify/Synplify Pro .................... 43
Examining Synthesis Results ......................................................... 43
Synthesizing the Design Using Precision Synthesis .................... 44
Entering Synthesis Options through ISE ....................................... 45
The RTL/Technology Viewer ......................................................... 45

Correcting HDL Errors ................................................................. 26
Checking the Syntax ...................................................................... 26
Adding Source Files ...................................................................... 25
Creating a New Project: Using New Project Wizard ................... 48
Starting the ISE Software ............................................................. 48
Creating a New Project ............................................................... 48
Creating a New Project: Using New Project Wizard ................... 48
Stopping the Tutorial ................................................................. 50

Outputs ........................................................................................ 24

Creating a CORE Generator Module ......................................... 31
Creating a CORE Generator Module in the HDL Code ............. 34
Creating a DCM Module ............................................................... 35
Using the Clocking Wizard .......................................................... 35
Instantiating the dcm1 Macro - VHDL Design ......................... 37
Instantiating the dcm1 Macro - Verilog ....................................... 38

Creating a CORE Generator Module ......................................... 31
Creating a CORE Generator Module in the HDL Code ............. 34
Creating a DCM Module ............................................................... 35
Using the Clocking Wizard .......................................................... 35
Instantiating the dcm1 Macro - VHDL Design ......................... 37
Instantiating the dcm1 Macro - Verilog ....................................... 38

Chapter 3: Schematic-Based Design

Overview of Schematic-Based Design ........................................... 47

Getting Started .............................................................................. 47

Required Software ......................................................................... 47
Installing the Tutorial Project Files ............................................... 48
Starting the ISE Software ............................................................. 48
Creating a New Project ............................................................... 48
Creating a New Project: Using New Project Wizard ................... 48
Stopping the Tutorial ................................................................. 50

Design Description ....................................................................... 50

Inputs .......................................................................................... 51
Outputs ....................................................................................... 52
Functional Blocks ......................................................................... 52

Design Entry ................................................................................. 53

Opening the Schematic File in the Xilinx Schematic Editor ............ 53
Manipulating the Window View ..................................................... 54
Creating a Schematic-Based Macro ............................................... 54
Defining the time_cnt Schematic .................................................. 55
Adding I/O Markers ...................................................................... 56
Adding Schematic Components ..................................................... 56
Correcting Mistakes ...................................................................... 59
Drawing Wires ............................................................................. 59
Adding Buses ............................................................................... 59
Chapter 4: Behavioral Simulation

Overview of Behavioral Simulation Flow .......................... 79
ModelSim Setup .................................................. 79
  ModelSim PE and SE ......................................... 80
  ModelSim Xilinx Edition ...................................... 80
ISim Setup ..................................................... 80
Getting Started .................................................. 80
  Required Files ................................................ 80
    Design Files (VHDL, Verilog, or Schematic) ................. 80
    Test Bench File ........................................... 80
    Xilinx Simulation Libraries ................................ 80
Xilinx Simulation Libraries ...................................... 81
  Updating the Xilinx Simulation Libraries ....................... 81
  Mapping Simulation Libraries in the ModelSim.ini File ....... 81
Adding an HDL Test Bench ....................................... 82
  Adding Tutorial Test Bench File ................................ 82
    VHDL Simulation ........................................... 82
    Verilog Simulation ........................................ 84
Behavioral Simulation Using ModelSim ......................... 84
  Locating the Simulation Processes ............................ 84
  Specifying Simulation Properties ............................ 85
  Performing Simulation ....................................... 86
  Adding Signals ............................................... 86
    Adding Dividers ........................................... 88
    Rerunning Simulation ...................................... 88
    Analyzing the Signals ..................................... 89
Chapter 5: Design Implementation

Overview of Design Implementation ........................................... 95
Getting Started ........................................................................ 96
- Continuing from Design Entry ............................................. 96
- Starting from Design Implementation .................................... 96
Specifying Options .................................................................. 97
Creating Timing Constraints .................................................... 98
Translating the Design ............................................................. 99
Using the Constraints Editor ..................................................... 100
Assigning I/O Locations Using PlanAhead ............................... 104
Mapping the Design ............................................................... 107
Using Timing Analysis to Evaluate Block Delays After Mapping ... 109
- Estimating Timing Goals with the 50/50 Rule ........................... 109
- Report Paths in Timing Constraints Option ............................ 110
Placing and Routing the Design ............................................... 111
Using FPGA Editor to Verify the Place and Route .................... 112
Evaluating Post-Layout Timing ................................................. 114
- Viewing the Post-Place & Route Static Timing Report ............ 114
- Analyzing the Design using PlanAhead ................................. 115
Creating Configuration Data .................................................... 116
- Creating a PROM File with iMPACT ..................................... 117
Command Line Implementation .............................................. 119

Chapter 6: Timing Simulation

Overview of Timing Simulation Flow ......................................... 121
Getting Started ....................................................................... 121
- Required Software ............................................................ 121
- Required Files ................................................................... 122
- Specifying a Simulator ........................................................ 122
Timing Simulation Using ModelSim .......................................... 122
- Specifying Simulation Process Properties .............................. 123
- Performing Simulation ........................................................ 125
  - Adding Signals ................................................................ 125
  - Adding Dividers .............................................................. 127
- Rerunning Simulation .......................................................... 128
  - Analyzing the Signals ...................................................... 128
- Saving the Simulation .......................................................... 129
Timing Simulation Using Xilinx ISim ......................................... 130
- Specifying Simulation Process Properties ............................ 130
Performing Simulation ........................................... 131
Adding Signals .................................................. 131
Viewing Full Signal Names ................................... 132
Rerunning Simulation ......................................... 132
Analyzing the Signals ......................................... 133

Chapter 7: iMPACT Tutorial

Device Support .................................................. 135
Download Cable Support ................................. 136
   Parallel Cable IV ............................................. 136
   Platform Cable USB ......................................... 136
   MultiPRO Cable .............................................. 136
Configuration Mode Support ............................ 136
Getting Started ................................................. 136
   Generating the Configuration Files ..................... 136
   Connecting the Cable ..................................... 137
   Starting the Software ..................................... 137
      Opening iMPACT from Project Navigator .......... 137
      Opening iMPACT stand-alone .......................... 137
Creating a iMPACT New Project File ................. 138
Using Boundary Scan Configuration Mode ........... 138
   Specifying Boundary Scan Configuration Mode .... 138
   Assigning Configuration Files ............................ 140
   Saving the Project File .................................... 141
   Editing Preferences ....................................... 141
   Performing Boundary Scan Operations ............... 141
Troubleshooting Boundary Scan Configuration ....... 144
   Verifying Cable Connection ............................. 144
   Verifying Chain Setup ................................... 145
Creating an SVF File ........................................... 146
   Setting up Boundary Scan Chain ....................... 146
      JTAG chain setup for SVF generation ............... 146
      Manual JTAG chain setup for SVF generation .... 146
   Writing to the SVF File .................................. 147
   Stop Writing to the SVF .................................. 148
   Playing back the SVF or XSVF file ..................... 148
Other Configuration Modes ................................. 148
   Slave Serial Configuration Mode ....................... 148
   SelectMAP Configuration Mode .......................... 149
Overview of ISE

This chapter includes the following sections:

- “Overview of ISE”
- “Using Project Revision Management Features”

Overview of ISE

ISE controls all aspects of the design flow. Through the Project Navigator interface, you can access all of the design entry and design implementation tools. You can also access the files and documents associated with your project.

Project Navigator Interface

The Project Navigator Interface, by default, is divided into four panel subwindows, as seen in Figure 1-1. On the top left is the Design, Files and Libraries panels which include display and access to the source files in the project, as well as access to running processes for the currently selected source. At the bottom of the Project Navigator is the Console, Errors and Warnings panels which display status messages, errors, and warnings. To the right is a multi-document interface (MDI) window referred to as the Workspace. It enables you to view design reports, text files, schematics, and simulation waveforms. Each window may be resized, undocked from Project Navigator, moved to a new location within the main Project Navigator window, tiled, layered, or closed. Panels may be opened or closed by using the View -> Panels menu selections. The default layout can always be restored by selecting View > Restore Default Layout. These windows are discussed in more detail in the following sections.
Design Panel

Sources View

The Sources view displays the project name, the target device, and user documents and design source files associated with the selected Design View. The Design View ("Sources for") drop-down list at the top of the Sources tab allows you to view only those source files associated with the selected Design View, such as Synthesis/Implementation or Simulation.

Each file in a Design View has an associated icon. The icon indicates the file type (HDL file, schematic, core, or text file, for example). For a complete list of possible source types and
their associated icons, see the ISE™ Help. Select Help > ISE Help Contents, select the Index tab and search for “Source file types.”

If a file contains lower levels of hierarchy, the icon has a + to the left of the name. You can expand the hierarchy by clicking the +. You can open a file for editing by double-clicking on the filename.

Processes View

The Processes view is context sensitive and it changes based upon the source type selected in the Sources tab and the Top-Level Source in your project. From the Processes tab, you can run the functions necessary to define, run and analyze your design. The Processes tab provides access to the following functions:

- **Design Summary/Reports**
  Provides access to design reports, messages, and summary of results data. Message filtering can also be performed.

- **Design Utilities**
  Provides access to symbol generation, instantiation templates, viewing command line history, and simulation library compilation.

- **User Constraints**
  Provides access to editing location and timing constraints.

- **Synthesis**
  Provides access to Check Syntax, Synthesis, View RTL or Technology Schematic, and synthesis reports. Available processes vary depending on the synthesis tools you use.

- **Implement Design**
  Provides access to implementation tools, and post-implementation analysis tools.

- **Generate Programming File**
  Provides access to bitstream generation.

- **Configure Target Device**
  Provides access to configuration tools for creating programming files and programming the device.

The Processes tab incorporates dependency management technology. The tools keep track of which processes have been run and which processes need to be run. Graphical status indicators display the state of the flow at any given time. When you select a process in the flow, the software automatically runs the processes necessary to get to the desired step. For example, when you run the Implement Design process, Project Navigator also runs the Synthesis process because implementation is dependent on up-to-date synthesis results.

To view a running log of command line arguments used on the current project, expand Design Utilities and select View Command Line Log File. See the Command Line Implementation section of Chapter 5, “Design Implementation” for further details.

Files Panel

The Files panel provides a flat sortable list of all the source files in the project. Files can be sorted by any of the columns in the view. Properties for each file can be viewed and modified by right-clicking on the file and selecting Source Properties.
Libraries Panel

The Libraries tab allows you to manage HDL libraries and their associated HDL source files. You can create, view, and edit libraries and their associated sources.

Console Panel

The Console provides all standard output from processes run from Project Navigator. It displays errors, warnings, and information messages. Errors are signified by a red (X) next to the message, while warnings have a yellow exclamation mark (!).

Errors Panel

Displays only error messages. Other console messages are filtered out.

Warnings Panel

Displays only warning messages. Other console messages are filtered out.

Error Navigation to Source

You can navigate from a synthesis error or warning message in the Console, Errors or Warnings panel to the location of the error in a source HDL file. To do so, select the error or warning message, right-click the mouse, and select Go to Source from the right-click menu. The HDL source file opens and the cursor moves to the line with the error.

Error Navigation to Answer Record

You can navigate from an error or warning message in the Console, Errors or Warnings panel to relevant Answer Records on the http://www.xilinx.com/support website. To navigate to the Answer Record(s), select the error or warning message, right-click the mouse, and select Go to Answer Record from the right-click menu. The default web browser opens and displays all Answer Records applicable to this message.

Workspace

The Workspace is where design editors, viewers, and analysis tools will open. These include ISE Text Editor, Schematic Editor, Timing Constraint Editor, Design Summary & Report Viewer, RTL and Technology Viewers, and Timing Analyzer.

Other tools such as PlanAhead for I/O planning and floorplanning, ISE Simulator (ISim), 3rd party Text Editors, XPower Analyzer, and iMPACT open in separate windows outside the main Project Navigator environment when invoked.

Design Summary & Report Viewer

The Design Summary provides a summary of key design data, as well as access to all of the messages and detailed reports from the synthesis and implementation tools. The summary lists high-level information about your project, including overview information, a device utilization summary, performance data gathered from the Place & Route (PAR) report, constraints information, and summary information from all reports with links to the
individual reports. Messaging features such as message filtering, tagging, and incremental messaging are also available from this view.

Using Project Revision Management Features

ISE Project File

The ISE® project file (.xise extension) is an XML file that contains all source-relevant data for the project as follows:

♦ ISE software version information
♦ List of source files contained in the project
♦ Source settings, including design and process properties

The ISE project file does not contain the following:

♦ Process status information
♦ Command history
♦ Constraints data

*Note:* A .gise and .ise file also exist, which contain generated data, such as process status. You should not need to directly interact with these files.

The ISE project file includes the following characteristics, which are compatible with source control environments:

♦ Contains all of the necessary source settings and input data for the project.
♦ Can be opened in Project Navigator in a read-only state.
♦ Only updated or modified if a source-level change is made to the project.
♦ Can be kept in a directory separate from the generated output directory (working directory).

*Note:* A source-level change is a change to a property or the addition or removal of a source file. Changes to the contents of a source file or changes to the state of an implementation run are not considered source-level changes and do not result in an update to the project file.

Making a Copy of a Project

You can create a copy of a project, *Project > Copy Project*, to experiment with different source options and implementations. Depending on your needs, the design source files for the copied project and their location can vary as follows:

♦ Design source files can be left in their existing location, and the copied project then points to these files.
♦ Design source files, including generated files, can be copied and placed in a specified directory.
♦ Design source files, excluding generated files, can be copied and placed in a specified directory.
Using the Project Browser

The Project Browser, accessible by selecting Project > Project Browser, provides a convenient way to compare, view, and open projects as follows:

♦ Compare key characteristics between multiple projects.
♦ View Design Summary and Reports for a selected project before opening the full project.
♦ Open a selected project in the current Project Navigator session.
♦ Open a selected project in a new Project Navigator session.

Using Project Archives

You can also archive the entire project into a single compressed file. This allows for easier transfer over email and storage of numerous projects in a limited space.

Creating an Archive

To create an archive:

1. Select Project > Archive.
2. In the Create Zip Archive dialog box, enter the archive name and location.

Note: The archive contains all of the files in the project directory along with project settings. Remote sources are included in the archive under a folder named remote_sources. For more information, see the ISE Help.

Restoring an Archive

You cannot restore an archived file directly into Project Navigator. The compressed file can be extracted with any ZIP utility and you can then open the extracted file in Project Navigator.


Chapter 2

HDL-Based Design

This chapter includes the following sections:

- “Overview of HDL-Based Design”
- “Getting Started”
- “Design Description”
- “Design Entry”
- “Synthesizing the Design”

Overview of HDL-Based Design

This chapter guides you through a typical HDL-based design procedure using a design of a runner’s stopwatch. The design example used in this tutorial demonstrates many device features, software features, and design flow practices you can apply to your own design. This design targets a Spartan™-3A device; however, all of the principles and flows taught are applicable to any Xilinx® device family, unless otherwise noted.

The design is composed of HDL elements and two cores. You can synthesize the design using Xilinx Synthesis Technology (XST), Synplify/Synplify Pro, or Precision.

This chapter is the first chapter in the “HDL Design Flow.” After the design is successfully defined, you will perform behavioral simulation (Chapter 4, “Behavioral Simulation”), run implementation with the Xilinx Implementation Tools (Chapter 5, “Design Implementation”), perform timing simulation (Chapter 6, “Timing Simulation”), and configure and download to the Spartan-3A demo board (Chapter 7, “iMPACT Tutorial”).

Getting Started

The following sections describe the basic requirements for running the tutorial.

Required Software

To perform this tutorial, you must have the following software and software components installed:

- Xilinx Series ISE™ 11.x
- Spartan-3A libraries and device files

Note: For detailed software installation instructions, refer to the ISE Design Suite: Installation, Licensing and Release Notes.
This tutorial assumes that the software is installed in the default location 
\texttt{c:\xilinx\11.1\ISE}. If you have installed the software in a different location, substitute your installation path for \texttt{c:\xilinx\11.1\ISE} in the procedures that follow.

### Optional Software Requirements

The following third-party synthesis tools are incorporated into this tutorial, and may be used in place of the Xilinx Synthesis Tool (XST):

- Synplicity Synplify/Synplify C-2009.3 (or above)
- Mentor Precision Synthesis 2009a.76 (or above)

The following third-party simulation tool is optional for this tutorial, and may be used in place of the ISE Simulator:

- ModelSim XE/SE/PE 6.4b or newer

### VHDL or Verilog?

This tutorial supports both VHDL and Verilog designs, and applies to both designs simultaneously, noting differences where applicable. You will need to decide which HDL language you would like to work through for the tutorial, and download the appropriate files for that language. XST can synthesize a mixed-language design. However, this tutorial does not go over the mixed language feature.

### Installing the Tutorial Project Files

The Stopwatch tutorial projects can be downloaded from [http://www.xilinx.com/support/techsup/tutorials/tutorials11.htm](http://www.xilinx.com/support/techsup/tutorials/tutorials11.htm). Download either the VHDL or the Verilog design flow project files.

After you have downloaded the tutorial project files from the web, unzip the tutorial projects into the \texttt{c:\xilinx\11.1\ISE\ISEexamples} directory, replacing any existing files in that directory.

When you unzip the tutorial project files into \texttt{c:\xilinx\11.1\ISE\ISEexamples}, the directory \texttt{wtut_vhd} (for a VHDL design flow) or \texttt{wtut_ver} (for a Verilog design flow) is created within \texttt{c:\xilinx\11.1\ISE\ISEexamples}, and the tutorial files are copied into the newly-created directory.

The following table lists the locations of tutorial source files.

<table>
<thead>
<tr>
<th>Table 2-1: Tutorial Directories</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Directory</strong></td>
</tr>
<tr>
<td>wtut_vhd</td>
</tr>
<tr>
<td>wtut_ver</td>
</tr>
<tr>
<td>wtut_vhd\wtut_vhd_completed</td>
</tr>
<tr>
<td>wtut_ver\wtut_ver_completed</td>
</tr>
</tbody>
</table>

**Note:** Do not overwrite any files in the solution directories.
The completed directories contain the finished HDL source files. This tutorial assumes that the files are unzipped under c:\xilinx\11.1\ISE\ISEexamples, but you can unzip the source files into any directory with read-write permissions. If you unzip the files into a different location, substitute your project path for in the procedures that follow.

Starting the ISE Software

To start ISE:

Double-click the ISE Project Navigator icon on your desktop or select Start > All Programs > Xilinx ISE Design Suite 11 > ISE > Project Navigator.

Creating a New Project

Creating a New Project: Using the New Project Wizard

1. From Project Navigator, select File > New Project.
   The New Project Wizard appears.

2. In the Project Location field, browse to c:\xilinx\11.1\ISE\ISEexamples or to the directory in which you installed the project.
3. Type wtut_vhd or wtut_ver in the Project Name field.
4. Verify that HDL is selected as the Top-Level Source Type and click Next.
The New Project Wizard - Device Properties window appears.

![New Project Wizard - Device Properties](image)

**Figure 2-3: New Project Wizard - Device Properties**

5. Select the following values in the New Project Wizard - Device Properties window:
   - Product Category: **All**
   - Family: **Spartan3A and Spartan3AN**
   - Device: **XC3S700A**
   - Package: **FG484**
   - Speed: **-4**
   - Synthesis Tool: **XST (VHDL/Verilog)**
   - Simulator: **ISim (VHDL/Verilog)**
   - Preferred Language: **VHDL** or **Verilog** depending on preference. This will determine the default language for all processes that generate HDL files. Other properties can be left at their default values.

6. Click **Next**, then **Next**, and then click **Add Source** in the New Project Wizard - Add Existing Sources window.

7. Browse to `c:\xilinx\11.1\ISE\ISEexamples\wtut_vhd` or `c:\xilinx\11.1\ISE\ISEexamples\wtut_ver`.

8. Select the following files (.vhd files for VHDL design entry or .v files for Verilog design entry) and click **Open**.
   - `clk_div_262k`
   - `lcd_control`
   - `statmach`
   - `stopwatch`
9. Click **Next**, then **Finish** to complete the New Project Wizard.

10. In the Adding Source Files dialog box, verify that all added HDL files are associated with **All**, and that they are associated with the **work** library, then click **OK**.

**Figure 2-4:** New Project Wizard - Adding Source Files Dialog

**Figure 2-5:** Adding Source Files... View Association Selection

**Stopping the Tutorial**

You may stop the tutorial at any time and save your work by selecting **File > Save All**.

**Design Description**

The design used in this tutorial is a hierarchical, HDL-based design, which means that the top-level design file is an HDL file that references several other lower-level macros. The lower-level macros are either HDL modules or IP modules.

The design begins as an unfinished design. Throughout the tutorial, you will complete the design by generating some of the modules from scratch and by completing others from existing files. When the design is complete, you will simulate it to verify the design’s functionality.
In the runner’s stopwatch design, there are five external inputs and four external output buses. The system clock is an externally generated signal. The following list summarizes the input and output signals of the design.

**Inputs**

The following are input signals for the tutorial stopwatch design.

- **strtstop**
  Starts and stops the stopwatch. This is an active low signal which acts like the start/stop button on a runner’s stopwatch.

- **reset**
  Puts the stopwatch in clocking mode and resets the time to 0:00:00.

- **clk**
  Externally generated system clock.

- **mode**
  Toggles between clocking and timer modes. This input is only functional while the clock or timer is not counting.

- **lap_load**
  This is a dual function signal. In clocking mode it displays the current clock value in the ‘Lap’ display area. In timer mode it loads the pre assigned values from the ROM to the timer display when the timer is not counting.

**Outputs**

The following are outputs signals for the design.

- **lcd_e, lcd_rs, lcd_rw**
  These outputs are the control signals for the LCD display of the Spartan-3A demo board used to display the stopwatch times.

- **sf_d[7:0]**
  Provides the data values for the LCD display.

**Functional Blocks**

The completed design consists of the following functional blocks.

- **clk_div_262k**
  Macro which divides a clock frequency by 262,144. Converts 26.2144 MHz clock into 100 Hz 50% duty cycle clock.

- **dcm1**
  Clocking Wizard macro with internal feedback, frequency controlled output, and duty-cycle correction. The CLKFX_OUT output converts the 50 MHz clock of the Spartan-3A demo board to 26.2144 MHz.

- **debounce**
  Schematic module implementing a simplistic debounce circuit for the strtstop, mode, and lap_load input signals.
- **lcd_control**
  Module controlling the initialization of and output to the LCD display.

- **statmach**
  State machine HDL module which controls the state of the stopwatch.

- **timer_preset**
  CORE Generator™ 64x20 ROM. This macro contains 64 preset times from 0:00:00 to 9:59:99 which can be loaded into the timer.

- **time_cnt**
  Up/down counter module which counts between 0:00:00 to 9:59:99 decimal. This macro has five 4-bit outputs, which represent the digits of the stopwatch time.

### Design Entry

For this hierarchical design, you will examine HDL files, correct syntax errors, create an HDL macro, and add a CORE Generator and a Clocking module. You will create and use each type of design macro. All procedures used in the tutorial can be used later for your own designs.

With the wtut_vhd.ise or wtut_ver.ise project open in Project Navigator, the Hierarchy view in the Design tab displays all of the source files currently added to the project, with the associated entity or module names (see Figure 2-6).

Instantiated components with no entity or module declaration are displayed with a red question mark.

### Adding Source Files

HDL files must be added to the project before they can be synthesized. Three HDL files have already been added to this project. An additional file must be added.

1. Select **Project > Add Source**.
2. Select `time_cnt.vhd` or `time_cnt.v` from the project directory and click **Open**.
3. In the Adding Source Files dialog box, verify that `time_cnt` is associated with **All** and that the associated library is **work** and click **OK**.

![Figure 2-6: Sources Tab Showing Completed Design](#)
The red question-mark (?) for time_cnt should change to show the VHD file icon.

```
timer_inst - time_cnt - time_cnt_arch (time_cnt.vhd)
```

*Figure 2-7:  time_cnt.vhd File in Sources Tab*

Each source Design unit is represented under the sources tab using the following syntax: `<instance name> - <entity name> - <architecture name>* - (<file name>)`.

*VHDL only

### Checking the Syntax

To check the syntax of source files:

1. Select `stopwatch.vhd` or `stopwatch.v` in the Sources tab. When you select the HDL file, the Processes tab displays all processes available for this file.
2. In the Processes tab, click the `+` next to Synthesize to expand the process hierarchy.
3. Double-click **Check Syntax** in the Synthesize hierarchy.

**Note:** Check Syntax is not available when Synplify is selected as the synthesis tool.

### Correcting HDL Errors

The `time_cnt` module contains a syntax error that must be corrected. The red “x” beside the Check Syntax process indicates an error was found during the analysis. In the Console tab, Project Navigator reports errors with a red (X) and warnings with a yellow (!).

To display the error in the source file:

1. Click the file name in the error message in the Console or Errors tab. The source code comes up in the main display tab, with an yellow arrow icon next to the line with the error.
2. Correct any errors in the HDL source file. The comments above the error explain this simple fix.
3. Select **File > Save** to save the file.
4. Re-analyze the file by selecting the HDL file and right-clicking on the **Check Syntax** process and selecting **Rerun**.

### Creating an HDL-Based Module

Next you will create a module from HDL code. With ISE, you can easily create modules from HDL code using the ISE Text Editor. The HDL code is then connected to your top-level HDL design through instantiation and is compiled with the rest of the design.

You will author a new HDL module. This macro will be used to debounce the startstop, mode and lap_load inputs.

### Using the New Source Wizard and ISE Text Editor

In this section, you create a file using the New Source wizard, specifying the name and ports of the component. The resulting HDL file is then modified in the ISE Text Editor.
To create the source file:

1. Select **Project > New Source**.
   The dialog box New Source Wizard opens in which you specify the type of source you want to create.

2. Select **VHDL Module** or **Verilog Module**.

3. In the File Name field, type **debounce**.

4. Click **Next**.

5. Enter two input ports named **sig_in** and **clk** and an output port named **sig_out** for the **debounce** component in this way:
   a. In the first three Port Name fields type **sig_in**, **clk** and **sig_out**.
   b. Set the Direction field to **in** for **sig_in** and **clk** and to **out** for **sig_out**.
   c. Leave the Bus designation boxes unchecked.
6. Click **Next** to complete the Wizard session.
   
   A description of the module displays.

7. Click **Finish** to open the empty HDL file in the ISE Text Editor.

   The VHDL file and Verilog file are displayed below.

```
-- Module Name: debounce - Behavioral
-- Project Name:
-- Target Devices:
-- Tool versions:
-- Description:
-- Dependencies:
--
-- Revision: 0.01 - File Created
-- Additional Comments:
--
library IEEE;
use IEEE.STD_LOGIC_1164.ALL;
use IEEE.STD_LOGIC_ARITH;
use IEEE.STD_LOGIC_UNSIGNED;
--
-- Vacomment the following library declaration if instantiating
-- any Xilinx primitives in this code.
--library UNISIM;
--use UNISIM.VComponents.all;
entity debounce is
  Port ( sig_in : in STD_LOGIC;
        clk : in STD_LOGIC;
        sig_out : out STD_LOGIC);
end debounce;
architecture Behavioral of debounce is
begin
end Behavioral;
```

**Figure 2-9: New Source Wizard for Verilog**

**Figure 2-10: VHDL File in ISE Text Editor**
In the ISE Text Editor, the ports are already declared in the HDL file, and some of the basic file structure is already in place. Keywords are displayed in blue, comments in green, and values are black. The file is color-coded to enhance readability and help you recognize typographical errors.

Using the Language Templates

The ISE Language Templates include HDL constructs and synthesis templates which represent commonly used logic components, such as counters, D flip-flops, multiplexers, and primitives. You will use the Debounce Circuit template for this exercise.

Note: You can add your own templates to the Language Templates for components or constructs that you use often.

To invoke the Language Templates and select the template for this tutorial:

1. From Project Navigator, select Edit > Language Templates.
   Each HDL language in the Language Templates is divided into five sections: Common Constructs, Device Macro Instantiation, Device Primitive Instantiation, Simulation Constructs, Synthesis Constructs and User Templates. To expand the view of any of these sections, click the + next to the section. Click any of the listed templates to view the template contents in the right pane.

2. Under either the VHDL or Verilog hierarchy, expand the Synthesis Constructs hierarchy, expand the Coding Examples hierarchy, expand the Misc hierarchy, and select the template called Debounce Circuit (VHDL) or One Shot, Debounce Circuit (Verilog). Use the appropriate template for the language you are using.

   Upon selection, the HDL code for a debounce circuit is displayed in the right pane.

   Figure 2-11: Verilog File in ISE Text Editor

   In the ISE Text Editor, the ports are already declared in the HDL file, and some of the basic file structure is already in place. Keywords are displayed in blue, comments in green, and values are black. The file is color-coded to enhance readability and help you recognize typographical errors.
Adding a Language Template to Your File

You will now use “Use in File” method for adding templates to your HDL file. Refer to “Working with Language Templates” in the ISE Help for additional usability options, including drag and drop options.

To add the template to your HDL file:

1. Open or bring forward the debounce.v or debounce.vhd source file. Position the cursor under the architecture begin statement in the VHDL file, or under the module and pin declarations in the Verilog file.

2. Return to the Language Templates window, right-click on the Debounce Circuit template in the template index, and select Use In File.

3. Close the Language Templates window.
4. Open the `debounce.v` or `debounce.vhd` source file to verify that the Language Template was properly inserted.

5. (Verilog only) Complete the Verilog module by doing the following:
   a. Remove the reset logic (not used in this design) by deleting the three lines beginning with `if` and ending with `else`.
   b. Change `<reg_name>` to `q` in all six locations.
   c. Change `<clock>` to `clk`; `<input>` to `sig_in`; and `<output>` to `sig_out`.

   **Note:** You can select Edit -> Find & Replace to facilitate this. The Find fields appear at the bottom of the Text Editor.

   c. Change `<clock>` to `clk`; `<input>` to `sig_in`; and `<output>` to `sig_out`.

6. (VHDL only) Complete the VHDL module by doing the following:
   a. Move the line beginning with the word `signal` so that it is between the `architecture` and `begin` keywords.
   b. Remove the reset logic (not used in this design) by deleting the five lines beginning with `if` and ending with `else`, and delete one of the `end if;` lines.
   c. Use Edit > Find & Replace to change `<clock>` to `clk`; `D_IN` to `sig_in`; and `Q_OUT` to `sig_out`.

   You now have complete and functional HDL code.

7. Save the file by selecting File > Save.

8. Select one of the `debounce` instances in the Sources tab.

9. In the Processes tab, double-click Check Syntax. Verify that the syntax check passes successfully. Correct any errors as necessary.

10. Close the ISE Text Editor.

### Creating a CORE Generator Module

CORE Generator is a graphical interactive design tool that enables you to create high-level modules such as memory elements, math functions and communications and IO interface cores. You can customize and pre-optimize the modules to take advantage of the inherent architectural features of the Xilinx FPGA architectures, such as Fast Carry Logic, SRL16s, and distributed and block RAM.

In this section, you will create a CORE Generator module called `timer_preset`. The module will be used to store a set of 64 values to load into the timer.

#### Creating a CORE Generator Module

To create a CORE Generator module:

1. In Project Navigator, select Project > New Source.
2. Select IP (CORE Generator & Architecture Wizard).
3. Type `timer_preset` in the File name field.
4. Click Next.
5. Expand the IP tree selector to locate Memories & Storage Elements > RAMs & ROMs.
6. Select Distributed Memory Generator, then click Next and click Finish to open the Distributed Memory Generator customization GUI. This customization GUI enables you to customize the memory to the design specifications.
7. Fill in the Distributed Memory Generator customization GUI with the following settings:
   - Component Name: **timer_preset** - Defines the name of the module.
   - Depth: 64 - Defines the number of values to be stored
   - Data Width: 20 - Defines the width of the output bus.
   - Memory Type: **ROM**

8. Click **Next**.

9. Leave Input and output options as Non Registered; Click **Next**.
10. Specify the Coefficients File: Click the **Browse** button and select *definition1_times.coe* located in the project directory.

11. Check that *only* the following pins are used (used pins are highlighted on the symbol on the left side of the customization GUI):
   - a[5:0]
   - spo[19:0]

12. Click **Generate**.

The module is created and automatically added to the project library.

**Note:** A number of files are added to the *ipcore_dir* sub-directory of the project directory. Some of these files are:

- **timer_preset.vho** or **timer_preset.veo**
  These are the instantiation templates used to incorporate the CORE Generator module into your source HDL.

- **timer_preset.vhd** or **timer_preset.v**
  These are HDL wrapper files for the core and are used only for simulation.

- **timer_preset.ngc**
This file is the netlist that is used during the Translate phase of implementation.

♦ timer_preset.xco
This file stores the configuration information for the timer_preset module and is used as the project source in the ISE project.

♦ timer_preset.mif
This file provides the initialization values of the ROM for simulation.

Instantiating the CORE Generator Module in the HDL Code
Next, instantiate the CORE Generator module in the HDL code using either a VHDL flow or a Verilog flow.

VHDL Flow
To instantiate the CORE Generator module using a VHDL flow:
1. In Project Navigator, double-click stopwatch.vhd to open the file in ISE Text Editor.
2. Place your cursor after the line that states:
   -- Insert CORE Generator ROM component declaration here
3. Select Edit > Insert File, then select ipcore_dir/timer_preset.vho and click Open.
   The VHDL template file for the CORE Generator instantiation is inserted.
4. Highlight the inserted code from
   -- Begin Cut here for INSTANTIATION Template ----
   to
   --INST_TAG_END ------ END INSTANTIATION Template ----
5. Select Edit > Cut.
6. Place the cursor after the line that states:
   --Insert CORE Generator ROM Instantiation here
7. Select Edit > Paste to place the core instantiation.
8. Change the instance name from your_instance_name to t_preset.

Figure 2-18: VHDL Component Declaration for CORE Generator Module
9. Edit this instantiated code to connect the signals in the Stopwatch design to the ports of the CORE Generator module as shown below.

```vhdl
169     ------ Insert CORE Generator ROM instantiation here
170     --------------- Begin Cut here for INSTANTIATION Template ----- INST_TAG
171     t_preset : timer_preset
172     port map (  
173         a => address,
174         spo => preset_time);
175     -- INST_TAG_END ------ End INSTANTIATION Template ---------------
```

Figure 2-19: VHDL Component Instantiation of CORE Generator Module

10. The inserted code of timer_preset.vho contains several lines of commented text for instruction and legal documentation. Delete these commented lines if desired.

11. Save the design using File > Save, and close the ISE Text Editor.

Verilog Flow

To instantiate the CORE Generator module using a Verilog flow:

1. In Project Navigator, double-click stopwatch.v to open the file in the ISE Text Editor.
2. Place your cursor after the line that states:

   ```verilog
   //Place the Coregen module instantiation for timer_preset here
   ```

4. The inserted code of timer_preset.veo contains several lines of commented text for instruction and legal documentation. Delete these commented lines if desired.
5. Change the instance name from YourInstanceName to t_preset.
6. Edit this code to connect the signals in the Stopwatch design to the ports of the CORE Generator module as shown below.

```verilog
36     // Place the Coregen module instantiation for timer_preset here
37     //------------ Begin Cut here for INSTANTIATION Template -----// INST_TAG
38     timer_preset t_preset (  
39         .a(address), // Bus [5 : 0]
40         .spo(preset_time); // Bus [19 : 0]
41     // INST_TAG_END ------ End INSTANTIATION Template --------
```

Figure 2-20: Verilog Component Instantiation of the CORE Generator Module

7. Save the design using File > Save and close stopwatch.v in the ISE Text Editor. The core module should now appear beneath the Stopwatch module in the hierarchy.

Creating a DCM Module

The Clocking Wizard, a part of the Xilinx Architecture Wizard, enables you to graphically select Digital Clock Manager (DCM) features that you wish to use. In this section you will create a basic DCM module with CLK0 feedback and duty-cycle correction.

Using the Clocking Wizard

To create the dcm1 module:
1. In Project Navigator, select **Project > New Source**.
2. In the New Source dialog box, select **IP (CoreGen & Architecture Wizard)** source and type **dcm1** for the file name.
3. Click **Next**.
4. In the Select IP dialog box, select **FPGA Features and Design > Clocking > Spartan-3E, Spartan-3A > Single DCM SP**.

![New Source Wizard](image)

5. Click **Next**, then **Finish**. The Clocking Wizard is launched.
6. Verify that **RST, CLK0** and **LOCKED** ports are selected.
7. Select **CLKFX** port.
8. Type **50** and select **MHz** for the Input Clock Frequency.
9. Verify the following settings:
   - **Phase Shift**: **NONE**
   - **CLKIN Source**: **External, Single**
   - **Feedback Source**: **Internal**
   - **Feedback Value**: **1X**
   - **Use Duty Cycle Correction**: Selected
10. Click the **Advanced** button.
11. Select **Wait for DCM lock before DONE Signal goes high**.
12. Click **OK**.
13. Click **Next**, and then click **Next** again.
14. Select **Use output frequency** and type **26.2144** in the box and select **MHz**.

\[(26.2144 MHz)/2^{18} = 100\text{Hz}\]

15. Click **Next**, and then click **Finish**.

The dcm1.xaw file is added to the list of project source files in the Sources tab.

**Instantiating the dcm1 Macro - VHDL Design**

Next, you will instantiate the dcm1 macro for your VHDL or Verilog design. To instantiate the dcm1 macro for the VHDL design:

1. In Project Navigator, in the Sources tab, select dcm1.xaw.
2. In the Processes tab, right-click **View HDL Instantiation Template** and select **Process Properties**.
3. Choose **VHDL** for the HDL Instantiation Template Target Language value and click **OK**.
4. In the Processes tab, double-click **View HDL Instantiation Template**.
5. Highlight the component declaration template in the newly opened HDL Instantiation Template (dcm1.vhi), shown below.

```
-- Notes:
-- 1) This instantiation template has been su
-- std_logic and std_logic_vector for the por
-- 2) To use this template to instantiate the

COMPONENT dcm1
  PORT(
    CLXIN_IN : IN std_logic;
    RST_IN : IN std_logic;
    CLKFX_OUT : OUT std_logic;
    CLXIN_BUFG_OUT : OUT std_logic;
    CLK0_OUT : OUT std_logic;
    LOCKED_OUT : OUT std_logic
  );
END COMPONENT;
```

**Figure 2-22: VHDL DCM Component Declaration**

6. Select **Edit > Copy**.
7. Place the cursor in the stopwatch.vhd file in a section labeled
   -- Insert dcm1 component declaration here.
8. Select **Edit > Paste** to paste the component declaration.
9. Highlight the instantiation template in the newly opened HDL Instantiation Template, shown below.

```
19  Inst_dcm1: dcm1 PORT MAP(
20      CLKIN_IN => ,
21      RST_IN  => ,
22      CLKFX_OUT => ,
23      CLKIN_IBUF_OUT => ,
24      CLKO_OUT => ,
25      LOCKED_OUT =>
26  );
```

*Figure 2-23: VHDL DCM Component Instantiation*

10. Select `Edit > Copy`.

11. Place the cursor in the `stopwatch.vhd` file below the line labeled

```
-- Insert dcm1 instantiation here
```

12. Select `Edit > Paste` to paste the instantiation template.

13. Make the necessary changes as shown in the figure below.

```
141     ------ Insert dcm1 instantiation here
142     Inst_dcm1: dcm1 PORT MAP(
143      CLKIN_IN => clk,
144      RST_IN  => reset,
145      CLKFX_OUT => clk_262144k,
146      CLKIN_IBUF_OUT => open,
147      CLKO_OUT => open,
148      LOCKED_OUT => locked
149  );
```

*Figure 2-24: VHDL Instantiation for dcm1*


The `dcm1` module should now appear beneath the `stopwatch` module in the design hierarchy.

**Instantiating the dcm1 Macro - Verilog**

To instantiate the `dcm1` macro for your Verilog design:

1. In Project Navigator, in the Sources tab, select `dcm1.xaw`.
2. In the Processes tab, double-click `View HDL Instantiation Template`. 
3. From the newly opened HDL Instantiation Template (dcm1.tfi), copy the instantiation template, shown below.

```vhdl
4 // Instantiate the module
5 dcm1 instance_name (
6 .CLKEN_IN(CLKEN_IN),
7 .RST_IN(RST_IN),
8 .CLKFX_OUT(CLKFX_OUT),
9 .CLKIN_IBUFG_OUT(CLKIN_IBUFG_OUT),
10 .CLKO_OUT(CLKO_OUT),
11 .LOCKED_OUT(LOCKED_OUT)
12 );
```

*Figure 2-25: dcm1 Macro and Instantiation Templates*

4. Paste the instantiation template into the section in stopwatch.v labeled //Insert dcm1 instantiation here.

5. Make the necessary changes as shown in the figure below.

```vhdl
82 //Insert dcm1 instantiation here
83
84 dcm1 inst_dcm1 (z
85 .CLKIN_IN(clock),
86 .RST_IN(reset),
87 .CLKFX_OUT(clk_26214k),
89 .CLKIN_IBUFG_OUT(),
90 .CLKO_OUT(),
91 .LOCKED_OUT(locked)
92 );
```

*Figure 2-26: Verilog Instantiation for dcm1*

6. Select **File > Save** to save the stopwatch.v file.

The dcm1 module should now appear beneath the stopwatch module in the design hierarchy.

**Synthesizing the Design**

So far you have been using XST (the Xilinx synthesis tool) for syntax checking. Next, you will synthesize the design using either XST, Synplify/Synplify Pro or Precision. The synthesis tool uses the design's HDL code and generates a supported netlist type (EDIF or NGC) for the Xilinx implementation tools. The synthesis tool performs three general steps (although all synthesis tools further break down these general steps) to create the netlist:

- **Analyze / Check Syntax**
  Checks the syntax of the source code.

- **Compile**
  Translates and optimizes the HDL code into a set of components that the synthesis tool can recognize.

- **Map**
  Translates the components from the compile stage into the target technology’s primitive components.
The synthesis tool can be changed at any time during the design flow. To change the synthesis tool:

1. Select the targeted part in the Sources tab.
2. Right-click and select Design Properties.
3. In the Design Properties dialog box, click on the Synthesis Tool value and use the pull-down arrow to select the desired synthesis tool from the list.

**Note:** If you do not see your synthesis tool among the options in the list, you may not have the software installed or may not have it configured in ISE. The Synthesis tools are configured in the Preferences dialog box (Edit > Preferences, expand ISE General, then click Integrated Tools).

**Note:** Changing the design flow results in the deletion of implementation data. You have not yet created any implementation data in this tutorial. For projects that contain implementation data, Xilinx recommends that you make a copy of the project using File > Copy Project if you would like to make a backup of the project before continuing.

**Synthesizing the Design using XST**

Now that you have created and analyzed the design, the next step is to synthesize the design. During synthesis, the HDL files are translated into gates and optimized for the target architecture.

Processes available for synthesis using XST are as follows:

- **View RTL Schematic**
  Generates a schematic view of your RTL netlist.

- **View Technology Schematic**
  Generates a schematic view of your Technology netlist.

- **Check Syntax**
  Verifies that the HDL code is entered properly.

- **Generate Post-Synthesis Simulation Model**
  Creates HDL simulation models based on the synthesis netlist.

**Entering Synthesis Options**

Synthesis options enable you to modify the behavior of the synthesis tool to make optimizations according to the needs of the design. One commonly used option is to control synthesis to make optimizations based on area or speed. Other options include controlling the maximum fanout of a flip-flop output or setting the desired frequency of the design.

To enter synthesis options:

1. Select stopwatch.vhd (or stopwatch.v) in the Sources view.
2. In the Processes view, right-click the Synthesize process and select Process Properties.
3. Ensure that the Property display level option is set to Advanced. This will allow you to view the full set of process properties available.
4. Under the Synthesis Options tab, set the Netlist Hierarchy property to a value of Rebuilt.
5. Click OK.
Synthesizing the Design

Now you are ready to synthesize your design. To take the HDL code and generate a compatible netlist:

1. Select `stopwatch.vhd` (or `stopwatch.v`).
2. Double-click the Synthesize process in the Processes view.

The RTL / Technology Viewer

XST can generate a schematic representation of the HDL code that you have entered. A schematic view of the code helps you analyze your design by displaying a graphical connection between the various components that XST has inferred. There are two forms of the schematic representation:

- **RTL View** - Pre-optimization of the HDL code.
- **Technology View** - Post-synthesis view of the HDL design mapped to the target technology.

To view a schematic representation of your HDL code:

1. In the Processes tab, click the + next to Synthesize to expand the process hierarchy.
2. Double-click View RTL Schematic or View Technology Schematic.
3. If the Set RTL/Tech Viewer Startup Mode dialog appears, select Start with the Explorer Wizard.
4. In the Create RTL Schematic start page, select the `clk_divider` and `debounce` components from the Available Elements list, then click the Add -> button to move the selected items to the Selected Elements list.
5. Click Create Schematic.

![Create RTL Schematic start page](image)

*Figure 2-27: Create RTL Schematic start page*

The RTL Viewer allows you to select the portions of the design to display as schematic. When the schematic is displayed, double-click on the symbol to push into the schematic and view the various design elements and connectivity. Right-click the schematic to view the various operations that can be performed in the schematic viewer.
You have completed XST synthesis. An NGC file now exists for the Stopwatch design. To continue with the HDL flow:

• Go to Chapter 4, “Behavioral Simulation,” to perform a pre-synthesis simulation of this design.
  
  OR

• Proceed to Chapter 5, “Design Implementation,” to place and route the design.

*Note:* For more information about XST constraints, options, reports, or running XST from the command line, see the XST User Guide. This guide is available in the collection of software manuals and is accessible from ISE by selecting Help > Software Manuals, or from the web at http://www.xilinx.com/support/software Manuals.htm.

**Synthesizing the Design using Synplify/Synplify Pro**

Now that you have entered and analyzed the design, the next step is to synthesize the design. In this step, the HDL files are translated into gates and optimized to the target architecture. To access Synplify’s RTL viewer and constraints editor you must run Synplify outside of ISE.

To synthesize the design, set the global synthesis options:

1. Select stopwatch.vhd (or stopwatch.v).

2. In the Processes tab, right-click the Synthesize process and select Process Properties.

3. Check the Write Vendor Constraint File box.

4. Click OK to accept these values.

5. Double-click the Synthesize process to run synthesis.

  *Note:* This step can also be done by selecting stopwatch.vhd (or stopwatch.v), clicking Synthesize in the Processes tab, and selecting Process > Run.

Processes available in Synplify and Synplify Pro synthesis include:

• View Synthesis Report

---

*Figure 2-28: RTL Schematic*
Lists the synthesis optimizations that were performed on the design and gives a brief timing and mapping report.

- **View RTL Schematic**
  Accessible from the Launch Tools hierarchy, this process displays Synplify or Synplify Pro with a schematic view of your HDL code

- **View Technology Schematic**
  Accessible from the Launch Tools hierarchy, this process displays Synplify or Synplify Pro with a schematic view of your HDL code mapped to the primitives associated with the target technology.

**Examining Synthesis Results**

To view overall synthesis results, double-click **View Synthesis Report** under the **Synthesize** process. The report consists of the following four sections:

- “Compiler Report”
- “Mapper Report”
- “Timing Report”
- “Resource Utilization”

**Compiler Report**

The compiler report lists each HDL file that was compiled, names which file is the top level, and displays the syntax checking result for each file that was compiled. The report also lists FSM extractions, inferred memory, warnings on latches, unused ports, and removal of redundant logic.

**Note:** Black boxes (modules not read into a design environment) are always noted as unbound in the Synplify reports. As long as the underlying netlist (.ngo, .ngc or .edn) for a black box exists in the project directory, the implementation tools merge the netlist into the design during the Translate phase.

**Mapper Report**

The mapper report lists the constraint files used, the target technology, and attributes set in the design. The report lists the mapping results of flattened instances, extracted counters, optimized flip-flops, clock and buffered nets that were created, and how FSMs were coded.

**Timing Report**

The timing report section provides detailed information on the constraints that you entered and on delays on parts of the design that had no constraints. The delay values are based on wireload models and are considered preliminary. Consult the post-place and
route timing reports discussed in Chapter 5, “Design Implementation,” for the most accurate delay information.

Performance Summary

***************

Worst slack in design: -1.581

<table>
<thead>
<tr>
<th>Starting Clock</th>
<th>Requested Frequency</th>
<th>Estimated Frequency</th>
<th>Requested Period</th>
<th>Estimated Period</th>
<th>Slack</th>
</tr>
</thead>
<tbody>
<tr>
<td>stopwatch clk_divider clk_100_inferred_clock</td>
<td>305.3 MHz</td>
<td>259.5 MHz</td>
<td>3.276</td>
<td>3.854</td>
<td>-0.578</td>
</tr>
<tr>
<td>stopwatch dcmi_inst CLXFX_BUF_derived_clock</td>
<td>111.6 MHz</td>
<td>94.9 MHz</td>
<td>8.959</td>
<td>10.540</td>
<td>-1.581</td>
</tr>
</tbody>
</table>

Figure 2-29: Synplify’s Estimated Timing Data

Resource Utilization

This section of the report lists all of the resources that Synplify uses for the given target technology.

You have now completed Synplify synthesis. At this point, a netlist EDN file exists for the Stopwatch design.

To continue with the HDL flow:
- Go to Chapter 4, “Behavioral Simulation,” to perform a pre-synthesis simulation of this design.
  OR
  - Proceed to Chapter 5, “Design Implementation,” to place and route the design.

Synthesizing the Design Using Precision Synthesis

Now that you have entered and analyzed the design, the next step is to synthesize the design. In this step, the HDL files are translated into gates and optimized to the target architecture.

Processes available for Precision Synthesis include:
- **Check Syntax**
  Checks the syntax of the HDL code.
- **View Log File**
  Lists the synthesis optimizations that were performed on the design and gives a brief timing and mapping report.
- **View RTL Schematic**
  Accessible from the Launch Tools hierarchy, this process displays Precision with a schematic-like view of your HDL code
- **View Technology Schematic**
Accessible from the Launch Tools hierarchy, this process displays Precision with a schematic-like view of your HDL code mapped to the primitives associated with the target technology.

- **View Critical Path Schematic**

Accessible from the Launch Tools hierarchy, this process displays Precision with a schematic-like view of the critical path of your HDL code mapped to the primitives associated with the target technology.

**Entering Synthesis Options through ISE**

Synthesis options enable you to modify the behavior of the synthesis tool to optimize according to the needs of the design. For the tutorial, the default property settings will be used.

1. Select `stopwatch.vhd` (or `stopwatch.v`) in the Sources tab.
2. Double-click the **Synthesize** process in the Processes tab.

**The RTL/Technology Viewer**

Precision Synthesis can generate a schematic representation of the HDL code that you have entered. A schematic view of the code helps you analyze your design by seeing a graphical connection between the various components that Precision has inferred. To launch the design in the RTL viewer, double-click the **View RTL Schematic** process. The following figure displays the design in an RTL view.

![Stopwatch Design in Precision Synthesis RTL Viewer](image)

**Figure 2-30:**  *Stopwatch Design in Precision Synthesis RTL Viewer*

You have now completed the design synthesis. At this point, an EDN netlist file exists for the Stopwatch design.

To continue with the HDL flow:

- Go to **Chapter 4, “Behavioral Simulation,”** to perform a pre-synthesis simulation of this design.
  OR
- Proceed to **Chapter 5, “Design Implementation,”** to place and route the design.
Chapter 3

Schematic-Based Design

This chapter includes the following sections:

- “Overview of Schematic-Based Design”
- “Getting Started”
- “Design Description”
- “Design Entry”

Overview of Schematic-Based Design

This chapter guides you through a typical FPGA schematic-based design procedure using the design of a runner’s stopwatch. The design example used in this tutorial demonstrates many device features, software features, and design flow practices that you can apply to your own designs. The stopwatch design targets a Spartan™-3A device; however, all of the principles and flows taught are applicable to any Xilinx® device family, unless otherwise noted.

This chapter is the first in the “Schematic Design Flow.” In the first part of the tutorial, you will use the ISE™ design entry tools to complete the design. The design is composed of schematic elements, CORE Generator™ component, and HDL macros. After the design is successfully entered in the Schematic Editor, you will perform behavioral simulation (Chapter 4, “Behavioral Simulation”), run implementation with the Xilinx Implementation Tools (Chapter 5, “Design Implementation”), perform timing simulation (Chapter 6, “Timing Simulation”), and configure and download to the Spartan-3A (XC3S700A) demo board (see Chapter 7, “iMPACT Tutorial.”).

Getting Started

The following sections describe the basic requirements for running the tutorial.

Required Software

You must have Xilinx ISE11 installed to follow this tutorial. For this design you must install the Spartan-3A libraries and device files.

A schematic design flow is supported on both Windows and Linux platforms.
This tutorial assumes that the software is installed in the default location, at 
c:\xilinx\11.1\ISE. If you have installed the software in a different location, 
substitute that for your installation path.

**Note:** For detailed instructions about installing the software, refer to the ISE 11.1 Installation Guide 
and Release Notes.

### Installing the Tutorial Project Files

The tutorial project files can be downloaded to your local machine from 

Download the Watch Schematic Design Files (`wtut_sch.zip`). The download contains 
two directories:
- `wtut_sc\`  
  (Contains source files for schematic tutorial. The schematic tutorial project will be 
  created in this directory).
- `wtut_sc\wtut_sc_completed\`  
  (Contains the completed design files for the schematic-based tutorial design, 
  including schematic, HDL, and State Machine files. Do not overwrite files under this 
  directory.)

Unzip the tutorial design files in any directory with read-write permissions. The schematic 
tutorial files are copied into the directories when you unzip the files. This tutorial assumes 
that the files are unarchived under `c:\xilinx\11.1\ISE\ISEexamples`. If you restore 
the files to a different location, substitute `c:\xilinx\11.1\ISE\ISEexamples` with 
the project path.

### Starting the ISE Software

To launch the ISE software package:

1. Double-click the ISE Project Navigator icon on your desktop, or select Start > All 
   Programs > Xilinx ISE Design Suite 11 > ISE > Project Navigator.

**Figure 3-1: Project Navigator Desktop Icon**

### Creating a New Project

Creating a New Project: Using New Project Wizard


2. Browse to `c:\xilinx\11.1\ISE\ISEexamples` or enter the directory in the 
   Project Location field.

3. Type `wtut_sc` as the Project Name. Notice that `wtut_sc` is appended to the Project 
   Location value.

4. Select Schematic as the Top-Level Source Type, and then click Next.
5. Select the following values in the New Project Wizard - Device Properties window:
   - Product Category: **All**
   - Family: **Spartan3A and Spartan3AN**
   - Device: **XC3S700A**
   - Package: **FG484**
   - Speed: **-4**
   - Synthesis Tool: **XST (VHDL/Verilog)**
   - Simulator: **ISim (VHDL/Verilog)**
   - Preferred Language: **VHDL** or **Verilog** depending on preference. This will determine the default language for all processes that generate HDL files. Other properties can be left at their default values.

6. Click **Next** twice, and then click **Add Source** in the New Project Wizard - Add Existing Sources window.

7. Browse to `c:\xilinx\11.1\ISE\ISEexamples\wtut_sc`

8. Select the following files and click **Open**.
   - `cd4rled.sch`
   - `ch4rled.sch`
   - `clk_div_262k.vhd`
   - `lcd_control.vhd`
   - `stopwatch.sch`
   - `statmach.vhd`

9. Click **Next**, then **Finish** to complete the New Project Wizard.
10. Verify that all added source files are set to Design View Association of **All**, and Library is **work**.

![Adding Source Files](image)

*Figure 3-3: Adding Source Files*

11. Click **OK**.

**Stopping the Tutorial**

If you need to stop the tutorial at any time, save your work by selecting **File > Save All**.

**Design Description**

The design used in this tutorial is a hierarchical, schematic-based design, which means that the top-level design file is a schematic sheet that refers to several other lower-level macros. The lower-level macros are a variety of different types of modules, including schematic-based modules, a CORE Generator module, an Architecture Wizard module, and HDL modules.

The runner’s stopwatch design begins as an unfinished design. Throughout the tutorial, you will complete the design by creating some of the modules and by completing others from existing files. A schematic of the completed stopwatch design is shown in the following figure. Through the course of this chapter, you will create these modules, instantiate them, and then connect them.
After the design is complete, you will simulate the design to verify its functionality. For more information about simulating your design, see Chapter 4, “Behavioral Simulation.”

There are five external inputs and four external outputs in the completed design. The following sections summarize the inputs and outputs, and their respective functions.

**Inputs**

The following are input signals for the tutorial stopwatch design.

- **strtstop**
  Starts and stops the stopwatch. This is an active low signal which acts like the start/stop button on a runner’s stopwatch.

- **reset**
Chapter 3: Schematic-Based Design

Puts the stopwatch in clocking mode and resets the time to 0:00:00.

- **clk**
  Externally generated system clock.

- **mode**
  Toggles between clocking and timer modes. This input is only functional while the clock or timer is not counting.

- **lap_load**
  This is a dual function signal. In clocking mode it displays the current clock value in the 'Lap' display area. In timer mode it will load the pre-assigned values from the ROM to the timer display when the timer is not counting.

Outputs

The following are outputs signals for the design.

- **lcd_e, lcd_rs, lcd_rw**
  These outputs are the control signals for the LCD display of the Spartan-3A demo board used to display the stopwatch times.

- **sf_d[7:0]**
  Provides the data values for the LCD display.

Functional Blocks

The completed design consists of the following functional blocks. Most of these blocks do not appear on the schematic sheet in the project until after you create and add them to the schematic during this tutorial.

The completed design consists of the following functional blocks.

- **clk_div_262k**
  Macro which divides a clock frequency by 262,144. Converts 26.2144 MHz clock into 100 Hz 50% duty cycle clock.

- **dcm1**
  Clocking Wizard macro with internal feedback, frequency controlled output, and duty-cycle correction. The CLKFX_OUT output converts the 50 MHz clock of the Spartan-3A demo board to 26.2144 MHz.

- **debounce**
  Module implementing a simplistic debounce circuit for the sqrtstop, mode, and lap_load input signals.

- **lcd_control**
  Module controlling the initialization of and output to the LCD display.

- **statmach**
  State machine module which controls the state of the stopwatch.

- **timer_preset**
  CORE Generator™ 64X20 ROM. This macro contains 64 preset times from 0:00:00 to 9:59:99 which can be loaded into the timer.
• time_cnt
  Up/down counter module which counts between 0:00:00 to 9:59:99 decimal. This macro has five 4-bit outputs, which represent the digits of the stopwatch time.

Design Entry

In this hierarchical design, you will create various types of macros, including schematic-based macros, HDL-based macros, and CORE Generator macros. You will learn the process for creating each of these types of macros, and you will connect the macros together to create the completed stopwatch design. All procedures used in the tutorial can be used later for your own designs.

Opening the Schematic File in the Xilinx Schematic Editor

The stopwatch schematic available in the wtut_sc project is incomplete. In this tutorial, you will update the schematic in the Schematic Editor. After you have created the project in ISE, you can now open the stopwatch.sch file for editing. To open the schematic file, double-click stopwatch.sch in the Sources window.
The stopwatch schematic diagram opens in the Project Navigator Workspace. You will see the unfinished design with elements in the lower right corner as shown in the figure below.

![Incomplete Stopwatch Schematic](image)

Figure 3-5: Incomplete Stopwatch Schematic

**Manipulating the Window View**

The View menu commands enable you to manipulate how the schematic is displayed. Select View > Zoom > In until you can comfortably view the schematic.

The schematic window can be undocked from the Project Navigator framework by selecting Window > Float while the schematic is selected in the workspace.

After being undocked, the schematic window can be redocked by selecting Window > Dock.

**Creating a Schematic-Based Macro**

A schematic-based macro consists of a symbol and an underlying schematic. You can create either the underlying schematic or the symbol first. The corresponding symbol or schematic file can then be generated automatically.
In the following steps, you will create a schematic-based macro by using the New Source Wizard in Project Navigator. An empty schematic file is then created, and you can define the appropriate logic. The created macro is then automatically added to the project’s library.

The macro you will create is called `time_cnt`. This macro is a binary counter with five, 4-bit outputs, representing the digits of the stopwatch.

To create a schematic-based macro:

1. In Project Navigator, select **Project > New Source**. The New Source dialog box opens:

   ![New Source Dialog Box](image)

   *Figure 3-6: New Source Dialog Box*

   The New Source dialog displays a list of all of the available source types.

2. Select **Schematic** as the source type.

3. Enter `time_cnt` as the file name.

4. Click **Next** and click **Finish**.

   A new schematic called `time_cnt.sch` is created, added to the project, and opened for editing.

5. Change the size of the schematic sheet by doing the following.
   - Right-click on the schematic page and select **Object Properties**.
   - Click on the down arrow next to the sheet size value and select $D = 34 \times 22$.
   - Click **OK** and then click **Yes** to acknowledge that changing the sheet size cannot be undone with the **Edit > Undo** option.

**Defining the `time_cnt` Schematic**

You have now created an empty schematic for `time_cnt`. The next step is to add the components that make up the `time_cnt` macro. You can then reference this macro symbol by placing it on a schematic sheet.
Adding I/O Markers

I/O markers are used to determine the ports on a macro, or the top-level schematic. The name of each pin on the symbol must have a corresponding connector in the underlying schematic. Add I/O markers to the time_cnt schematic to determine the macro ports.

To add the I/O markers:

1. Select Tools > Create I/O Markers.
   The Create I/O Markers dialog box opens.

2. In the Inputs box, enter \( q(19:0) , \text{load}, \text{up}, \text{ce}, \text{clk}, \text{clr} \).

3. In the Outputs box, enter \( \text{hundredths}(3:0), \text{tenths}(3:0), \text{sec_lsb}(3:0), \text{sec_msb}(3:0), \text{minutes}(3:0) \).

4. Click OK. The eleven I/O markers are added to the schematic sheet.

   Note: The Create I/O Marker function is available only for an empty schematic sheet. However, I/O markers may be added to nets at any time by selecting Add > I/O Marker and selecting the desired net.

Adding Schematic Components

Components from the device and project libraries for the given project are available from the Symbol Browser, and the component symbol can be placed on the schematic. The available components listed in the Symbol Browser are arranged alphabetically within each library.

1. From the menu bar, select Add > Symbol or click the Add Symbol icon from the Tools toolbar.

   Note: The Options window changes depending on which tool you have selected in the Tools toolbar.
This opens the Symbol Browser to the left of the schematic editor, displaying the libraries and their corresponding components.

![Symbol Browser](image)

**Figure 3-9: Symbol Browser**

The first component you will place is a `cd4rled`, a 4-bit, loadable, bi-directional, BCD counter with clock enable and synchronous clear.

2. Select the `cd4rled` component, using one of two ways:
   - Highlight the project directory category from the Symbol Browser dialog box and select the component `cd4rled` from the symbols list.
   - or
   - Select **All Symbols** and type `cd4rled` in the Symbol Name Filter at the bottom of the Symbol Browser window.

3. Move the mouse back into the schematic window.
   You will notice that the cursor has changed to represent the `cd4rled` symbol.

4. Move the symbol outline near the top and center of the sheet and click the left mouse button to place the object.

   **Note:** You can rotate new components being added to a schematic by selecting Ctrl+R. You can rotate existing components by selecting the component, and then selecting Ctrl+R.
5. Place three more cd4rled symbols on the schematic by moving the cursor with attached symbol outline to the desired location, and clicking the left mouse button. See Figure 3-10

![Figure 3-10: Partially Completed time_cnt Schematic](image)

6. Follow the procedure outlined in steps 1 through 4 above to place the following components on the schematic sheet:
   - AND2b1
   - ch4rled
   - AND5

Refer to Figure 3-10 for placement locations.

To exit the Symbols Mode, press the **Esc** key on the keyboard.
For a detailed description of the functionality of Xilinx Library components, right-click on the component and select **Object Properties**. In the Object Properties window, select **Symbol Info**. Symbol information is also available in the Libraries Guides, accessible from the collection of software manuals on the web at [http://www.xilinx.com/support/software_manuals.htm](http://www.xilinx.com/support/software_manuals.htm).

### Correcting Mistakes

If you make a mistake when placing a component, you can easily move or delete the component.

To move the component, click the component and drag the mouse around the window.

Delete a placed component in one of two ways:

- Click the component and press the **Delete** key on your keyboard.
- Right-click the component and select **Delete**.

### Drawing Wires

Use the Add Wire icon in the Tools toolbar to draw wires (also called nets) to connect the components placed in the schematic.

Perform the following steps to draw a net between the AND2b1 and top cd4rled components on the `time_cnt` schematic.

1. Select **Add > Wire** or click the **Add Wire** icon in the Tools toolbar.

2. Click the output pin of the AND2b1 and then click the destination pin CE on the cd4rled component. The Schematic Editor draws a net between the two pins.

3. Draw a net to connect the output of the AND5 component to the inverted input of the AND2b1 component. Connect the other input of the AND2b1 to the `ce` input IO marker.

4. Connect the `load`, `up`, `clk`, and `clr` input IO markers respectively to the L, UP, C, and R pins of each of the five counter blocks and connect the `CEO` pin of the first four counters to the `CE` pin of the next counter as shown in Figure 3-10.

To specify the shape of the net:

1. Move the mouse in the direction you want to draw the net.
2. Click the mouse to create a 90-degree bend in the wire.

To draw a net between an already existing net and a pin, click once on the component pin and once on the existing net. A junction point is drawn on the existing net.

### Adding Buses

In the Schematic Editor, a bus is simply a wire that has been given a multi-bit name. To add a bus, use the methodology for adding wires and then add a multi-bit name. Once a bus
has been created, you have the option of “tapping” this bus off to use each signal individually.

The next step is to create three buses for each of the five outputs of the time_cnt schematic. The results can be found in the completed schematic.

To add the buses hundredths(3:0), tenths(3:0), sec_lsb(3:0), sec_msb(3:0) and minutes(3:0) to the schematic, perform the following steps:

1. Select all of the output IO markers by drawing a box around them and then drag the group so that minutes(3:0) is below the Q3 output of the bottom counter block.
2. Select Add > Wire or click the Add Wire icon in the Tools toolbar.
3. Click in the open space just above and to the right of the top cd4rled and then click again on the pin of the hundredths(3:0) I/O marker. The thick line should automatically be drawn to represent a bus with the name matching that of the I/O marker.

4. Repeat Steps 2 and 3 for the four remaining buses.
5. After adding the five buses, press Esc or right-click at the end of the bus to exit the Add Wire mode.

Adding Bus Taps

Next, add nets to attach the appropriate pins from the cd4rled and ch4rled counters to the buses. Use Bus Taps to tap off a single bit of a bus and connect it to another component.

**Note:** Zooming in on the schematic enables greater precision when drawing the nets.

To tap off a single bit of each bus:

1. Select Add > Bus Tap or click the Add Bus Tap icon in the Tools toolbar.

2. From the Options tab to the left of the schematic, choose the **Right** orientation for the bus tap.
3. Click on the hundredths(3:0) bus with the center bar of the cursor.
   The **Selected Bus Name** and the **Net Name** values of the options window are now populated.

   **Note:** The indexes of the Net Name may be incremented or decremented by clicking the arrow buttons next to the Net Name box.

4. With hundredths(3) as the Net Name value, move the cursor so the tip of the attached tap touches the Q3 pin of the top cd4rled component.

   **Note:** Four selection squares appear around the pin when the cursor is in the correct position.

5. Click once when the cursor is in the correct position.
   A tap is connected to the hundredths(3:0) bus and a wire named hundredths(3) is drawn between the tap and the Q3 pin.
   Click successively on pins Q2, Q1, and Q0 to create taps for the remaining bits of the hundredths(3:0) bus.

6. Repeat Steps 3 to 6 to tap off four bits from each of the five buses.

   **Note:** It is the name of the wire that makes the electrical connection between the bus and the wire (e.g sec_msb(2) connects to the third bit of sec(3:0)). The bus tap figure is for visual purposes only. The following section shows additional electrical connections by name association.

7. Press **Esc** to exit the Add Net Name mode.

8. Compare your `time_cnt` schematic with Figure 3-15 to ensure that all connections are made properly.

---

### Adding Net Names

First, add a hanging wire to each of the five inputs of the AND5 component and to the TC pin of each of the counter blocks.

Next, add net names to the wires. To add the net names:

1. Select **Add > Net Name** or click the **Add Net Name** icon in the Tools toolbar.

   ![Add Net Name Icon](image)

   **Figure 3-14: Add Net Name Icon**

2. Type `tc_out0` in the Name box and select **Increase the Name** in the Add Net Names Options dialog box.
   The net name `tc_out0` is now attached to the cursor.

3. Click the net attached to the first input of the AND5 component.
   The name is then attached to the net. The net name appears above the net if the name is placed on any point of the net other than an end point.

4. Click on the remaining input nets of the AND5 to add `tc_out1`, `tc_out2`, `tc_out3` and `tc_out4`.
   The Schematic Editor increments the net Name as each name is placed on a net.
   Alternatively, name the first net `tc_out4` and select **Decrease the name** in the Add Net Names Options dialog box, and nets are named from the bottom up.

5. Repeat step 2 and then click successively on the nets connected to the TC output to add `tc_out0`, `tc_out1`, `tc_out2`, `tc_out3`, and `tc_out4` to these nets.
**Note:** Each of the wires with identical names are now electrically connected. In this case, the nets do not need to be physically connected on the schematic to make the logical connection. Finally, connect the input pins of the counters through net name association.

1. Select **Add > Wire** or click the **Add Wire** icon and add a hanging net to the four data pins of each of the five counters.
2. Select **Add > Net Name** or click the **Add Net Name** icon in the Tools toolbar.
3. Type **q(0)** in the Name box of the Add Net Name Options dialog box.
4. Select **Increase the name** in the Add Net Name options dialog box.
   The net name q(0) is now attached to the cursor.
5. Click successively on each of the nets connected to data inputs, starting from the top so that the net named q(0) is attached to the D0 pin of the top counter and the net named q(19) is attached to the D3 pin of the bottom counter. Refer to Figure 3-15.

**Note:** If the nets appear disconnected, select **View > Refresh** to refresh the screen.

---

**Checking the Schematic**

The time_cnt schematic is now complete.

Verify that the schematic does not contain logical errors by running a design rule check (DRC). To do this, select **Tools > Check Schematic**. The Console window should report that no errors or warnings are detected. If an error or warning is displayed, fix the reported problem before proceeding.
Saving the Schematic

1. Save the schematic by selecting File > Save, or by clicking the Save icon in the toolbar.

   \[\text{Figure 3-16: Save Icon}\]

2. Close the time_cnt schematic.

Creating and Placing the time_cnt Symbol

The next step is to create a “symbol” that represents the time_cnt macro. The symbol is an instantiation of the macro. After you create a symbol for time_cnt, you will add the symbol to a top-level schematic of the stopwatch design. In the top-level schematic, the symbol of the time_cnt macro will be connected to other components in a later section in this chapter.

Creating the time_cnt symbol

You can create a symbol using either a Project Navigator process or a Tools menu command.

To create a symbol that represents the time_cnt schematic using a Project Navigator process:

1. In the Sources window, select time_cnt.sch.
2. In the Processes window, click the + beside Design Utilities to expand the hierarchy.
3. Double-click Create Schematic Symbol.

To create a symbol that represents the time_cnt schematic using a Tools menu command:

1. With the time_cnt schematic sheet open, select Tools > Symbol Wizard.
2. In the Symbol Wizard, select Using Schematic, and then select time_cnt in the schematic value field.
3. Click Next, then Next, then Next again, and then Finish to use the wizard defaults.
4. View and then close the time_cnt symbol.

Placing the time_cnt Symbol

Next, place the symbol that represents the macro on the top-level schematic (stopwatch.sch).

1. In the Sources window, double-click stopwatch.sch to open the schematic.
2. Select the Add Symbol icon.

   \[\text{Figure 3-17: Add Symbol Icon}\]
3. In the Symbol Browser, select the local symbols library
   (c:\xilinx\11.1\ISE\ISEexamples\wtut_sc), and then select the newly
   created time_cnt symbol.

4. Place the time_cnt symbol in the schematic so that the output pins line up with the five
   buses driving inputs to the lcd_control component. This should be close to grid
   position [1612,1728]. Grid position is shown at the bottom right corner of the Project
   Navigator window, and is updated as the cursor is moved around the schematic.
   **Note:** Do not worry about connecting nets to the input pins of the time_cnt symbol. You will do
   this after adding other components to the stopwatch schematic.

5. Save the changes and close stopwatch.sch.

Creating a CORE Generator Module

CORE Generator is a graphical interactive design tool that enables you to create high-level
modules such as memory elements, math functions, communications, and IO interface
cores. You can customize and pre-optimize the modules to take advantage of the inherent
architectural features of the Xilinx FPGA architectures, such as Fast Carry Logic, SRL16s,
and distributed and block RAM.

In this section, you will create a CORE Generator module called timer_preset. The module
is used to store a set of 64 values to load into the timer.

Creating a CORE Generator Module

To create a CORE Generator module:

1. In Project Navigator, select Project > New Source.
2. Select IP (Coregen & Architecture Wizard).
3. Type timer_preset in the File name field.
4. Click Next.
5. Double-click Memories & Storage Elements > RAMs & ROMs.
6. Select Distributed Memory Generator, then click Next and click Finish to open the
   Distributed Memory Generator customization GUI. This customization GUI enables
   you to customize the memory to the design specifications.

![Figure 3-18: New Source Wizard - New IP Module](image)

7. Fill in the Distributed Memory Generator customization GUI with the following
   settings:
   ♦ Component Name: timer_preset - Defines the name of the module.
Depth: **64** - Defines the number of values to be stored
- Data Width: **20** - Defines the width of the output bus.
- Memory Type: **ROM**

8. Click **Next**.

9. Leave Input and Output options as Non Registered; Click **Next**.

10. Specify the Coefficients File: Click the Browse button and select `definition1_times.coe`.

11. Check that **only** the following pins are used (used pins are highlighted on the symbol on the left side of the customization GUI):
- `a[5:0]`
- `spo[19:0]`

12. Click **Generate**.

The module is created and automatically added to the project library.

**Note:** A number of files are added to the project directory. Some of these files are:
- `timer_preset.sym`  
  This file is a schematic symbol file.
- `timer_preset.vhd` or `timer_preset.v`  
  These are HDL wrapper files for the core and are used only for simulation.
- `timer_preset.ngc`  
  This file is the netlist that is used during the Translate phase of implementation.
- `timer_preset.xco`
This file stores the configuration information for the timer_preset module and is used as a project source.

- **timer_preset.mif**
  This file provides the initialization values of the ROM for simulation.

### Creating a DCM Module

The Clocking Wizard, a Xilinx Architecture Wizard, enables you to graphically select Digital Clock Manager (DCM) features that you wish to use. In this section, you will create a basic DCM module with CLK0 feedback and duty-cycle correction.

#### Using the Clocking Wizard

Create the dcm1 module as follows:

1. In Project Navigator, select **Project > New Source**.
2. In the New Source dialog box, select the **IP (Coregen & Architecture Wizard)** source type, and type **dcm1** for the file name.
3. Click **Next**.
4. In the Select IP dialog box, select **FPGA Features and Design > Clocking > Spartan-3E, Spartan-3A > Single DCM SP**.

![Image of Selecting Single DCM Core Type]

*Figure 3-20: Selecting Single DCM Core Type*

5. Click **Next**, then click **Finish**. The Clocking Wizard is launched.
6. Verify that **RST, CLK0** and **LOCKED** ports are selected.
7. Select **CLKFX** port.
8. Type **50** and select **MHz** for the Input Clock Frequency.
9. Verify the following settings:
   - **Phase Shift**: **NONE**
   - **CLKIN Source**: **External, Single**
   - **Feedback Source**: **Internal**
Feedback Value: **1X**
Use Duty Cycle Correction: Selected

10. Click the **Advanced** button.

11. Select the **Wait for DCM Lock before DONE Signal goes high** option.

12. Click **OK**.

13. Click **Next**, and then **Next** again.

14. Select **Use output frequency** and type **26.2144** in the box and select **MHz**.

\[
(26.2144\text{MHz})/2^{18} = 100\text{Hz}
\]

15. Click **Next**, and then click **Finish**.

The `dcm1.xaw` file is created and added to the list of project source files in the Sources tab.

**Creating the dcm1 Symbol**

Next, create a symbol representing the dcm1 macro. This symbol will be added to the top-level schematic (`stopwatch.sch`) later in the tutorial.

1. In Project Navigator, in the Sources tab, select `dcm1.xaw`.

2. In the Processes tab, double-click **Create Schematic Symbol**.
Creating an HDL-Based Module

With ISE, you can easily create modules from HDL code. The HDL code is connected to your top-level schematic design through instantiation and compiled with the rest of the design.

You will author a new HDL module. This macro will be used to debounce the start/stop, mode and lap_load inputs.

Using the New Source Wizard and ISE Text Editor

In this section, you create a file using the New Source wizard, specifying the name and ports of the component. The resulting HDL file is then modified in the ISE Text Editor.

To create the source file:
1. Select **Project > New Source**.
   
   A dialog box opens in which you specify the type of source you want to create.

2. Select **VHDL Module** or **Verilog Module**.

3. In the File Name field, type **debounce**.

4. Click **Next**.

5. Enter two input ports named sig_in and clk and an output port named sig_out for the debounce component as follows:
   
   a. In the first three Port Name fields type **sig_in, clk** and **sig_out**.
   
   b. Set the Direction field to **input** for **sig_in** and **clk** and to **output** for **sig_out**.
   
   c. Leave the Bus designation boxes unchecked.

6. Click **Next** to complete the Wizard session.

   A description of the module displays.

7. Click **Finish** to open the empty HDL file in the ISE Text Editor.

   The VHDL file is displayed in Figure 3-23. The Verilog HDL file is displayed in Figure 3-24.
Figure 3-23: VHDL File in ISE Text Editor

```vhdl
-- Dependencies:
--
-- Revision:
-- Revision 0.01 - File Created
-- Additional Comments:
--
library IEEE;
use IEEE.STD_LOGIC_1164.ALL;
use IEEE.STD_LOGIC_ARITH.ALL;
--- Uncomment the following library declaration if instantiating
--- any Xilinx primitives in this code.
--library UNISIM;
--use UNISIM.VComponents.all;

entity debounce is
  Port ( sig_in : in STD_LOGIC;
         clk : in STD_LOGIC;
         sig_out : out STD_LOGIC);
end debounce;

architecture Behavioral of debounce is
begin
```

Figure 3-24: Verilog File in ISE Text Editor

```verilog
module debounce(sig_in, clk, sig_out);
  input sig_in;
  input clk;
  output sig_out;
endmodule
```
In the ISE Text Editor, the ports are already declared in the HDL file, and some of the basic file structure is already in place. Keywords are displayed in blue, comments in green, and values are black. The file is color-coded to enhance readability and help you recognize typographical errors.

### Using the Language Templates

The ISE Language Templates include HDL constructs and synthesis templates which represent commonly used logic components, such as counters, D flip-flops, multiplexers, and primitives. You will use the Debounce Circuit template for this exercise.

**Note:** You can add your own templates to the Language Templates for components or constructs that you use often.

To invoke the Language Templates and select the template for this tutorial:

1. From Project Navigator, select **Edit > Language Templates**.
   
   Each HDL language in the Language Templates is divided into five sections: Common Constructs, Device Primitive Instantiation, Simulation Constructs, Synthesis Constructs and User Templates. To expand the view of any of these sections, click the + next to the section. Click any of the listed templates to view the template contents in the right pane.

2. Under either the VHDL or Verilog hierarchy, expand the Synthesis Constructs hierarchy, expand the Coding Examples hierarchy, expand the Misc hierarchy, and select the template called Debounce Circuit. Use the appropriate template for the language you are using.

   When the template is selected in the hierarchy, the contents display in the right pane.

![Figure 3-25: Language Templates](image-url)
Adding a Language Template to Your File

You will now use “Use in File” method for adding templates to your HDL file. Refer to “Working with Language Templates” in the ISE Help for additional usability options, including drag and drop options.

To add the template to your HDL file:

1. Open or bring forward the debounce.v or debounce.vhd source file. Position the cursor under the architecture begin statement in the VHDL file, or under the module and pin declarations in the Verilog file.

2. Return to the Language Templates window, right-click on the Debounce Circuit template in the template index, and select Use In File.

3. Close the Language Templates window.

4. Open the debounce.v or debounce.vhd source file to verify that the Language Template was properly inserted.

5. (Verilog only) Complete the Verilog module by doing the following:
   a. Remove the reset logic (not used in this design) by deleting the three lines beginning with if and ending with else.
   b. Change <reg_name> to q in all six locations.
   c. Change <clock> to clk; <D_IN> to sig_in; and <Q_OUT> to sig_out.

6. (VHDL only) Complete the VHDL module by doing the following:
   a. Move the line beginning with the word signal so that it is between the architecture and begin keywords.
   b. Remove the reset logic (not used in this design) by deleting the five lines beginning with if (reset)... and ending with else, and delete one of the end if; lines.
   c. Use Edit > Find & Replace to change <clock> to clk; D_IN to sig_in; and Q_OUT to sig_out.

You now have complete and functional HDL code.

7. Save the file by selecting File > Save.

8. Select one of the debounce instances in the Sources tab.

9. In the Processes tab, double-click Check Syntax. Verify that the syntax check passes successfully. Correct any errors as necessary.

10. Close the ISE Text Editor.
Creating Schematic Symbols for HDL modules

Next, create the schematic symbols for both the debounce and statmach HDL files.

1. In the Sources tab, select `debounce.vhd` or `debounce.v`.
2. In the Processes tab, click the + beside Design Utilities to expand the hierarchy.
3. Double-click Create Schematic Symbol.
4. Repeat this procedure for the `statmach.vhd` file.

You are now ready to place the symbols on the stopwatch schematic.

Placing the statmach, timer_preset, dcm1 and debounce Symbols

You can now place the statmach, timer_preset, dcm1, and debounce symbols on the stopwatch schematic (`stopwatch.sch`). In Project Navigator, double-click `stopwatch.sch`. The schematic file opens in the Workspace.

1. Select Add > Symbol or click the Add Symbol icon from the Tools toolbar.

   ![Add Symbol Icon](image)

   *Figure 3-27: Add Symbol Icon*

   This opens the Symbol Browser to the left of the Schematic Editor, which displays the libraries and their corresponding components.

2. View the list of available library components in the Symbol Browser.

3. Locate the project-specific macros by selecting the project directory name in the Categories window.

4. Select the appropriate symbol, and add it to the stopwatch schematic in the approximate location, as shown in Figure 3-28.

   *Note:* Do not worry about drawing the wires to connect the symbols. You will connect components in the schematic later in the tutorial.
5. Save the schematic.

Figure 3-28: Placing Design Macros

Changing Instance Names

When a symbol is placed on a schematic sheet it is given a unique instance name beginning with the prefix XLXI_. To help make the hierarchy more readable in the Project Navigator Sources window, change the names of the added symbol instances as follows.

1. Right-click on the dcm1 symbol instance and select Object Properties from the right-click menu

2. Change the value of the InstName field to dcm_inst and then click OK.

Repeat steps 1 and 2 to change the following symbol instance names.

- Name the statmach instance timer_state.
- Name the top debounce instance lap_load_debounce.
- Name the middle debounce instance mode_debounce.
• Name the bottom debounce instance `strtstop_debounce`.
• Name the timer_preset instance `t_preset`.
• Name the time_cnt instance `timer_cnt`.

Hierarchy Push/Pop

First, perform a hierarchy “push down,” which enables you to focus in on a lower-level of
the schematic hierarchy to view the underlying file. Push down into the time_cnt macro,
which is a schematic-based macro created earlier in this tutorial, and examine its
components.

To push down into `time_cnt` from the top-level, `stopwatch`, schematic:
1. Click the `time_cnt` symbol in the schematic, and select the Hierarchy Push icon. You can
also right-click the macro and select Symbol > Push into Symbol.

   ![Hierarchy Push Icon](Figure 3-29: Hierarchy Push Icon)

   In the `time_cnt` schematic, you see five counter blocks. Push into any of the counter
blocks by selecting the block and clicking on the Hierarchy Push icon. This process
may be repeated until the schematic page contains only Xilinx primitive components.
If a user pushes into a symbol that has an underlying HDL or IP core file, the
appropriate text editor or customization GUI will open and be ready to edit the file.

2. After examining the macro, return to the top-level schematic by selecting View > Pop
to Calling Schematic, or select the Hierarchy Pop icon when nothing in the
schematic is selected. You can also right-click in an open space of the schematic and
select Pop to Calling Schematic.

   ![Hierarchy Pop Icon](Figure 3-30: Hierarchy Pop Icon)

Specifying Device Inputs/Outputs

Use the I/O marker to specify device I/O on a schematic sheet. All of the Schematic Editor
schematics are netlisted to VHDL or Verilog and then synthesized by the synthesis tool of
choice. When the synthesis tool synthesizes the top-level schematic’s HDL, the I/O
markers are replaced with the appropriate pads and buffers.

Adding Input Pins

Next, add five input pins to the stopwatch schematic: reset, clk, lap_load, mode and
strtstop.

To add these components:

• Draw a hanging wire to the two inputs of dcm1 and to the sig_in pin of each debounce
  symbol
  Refer to “Drawing Wires” for detailed instructions.
Adding I/O Markers and Net Names

It is important to label nets and buses for several reasons:

- It aids in debugging and simulation, as you can more easily trace nets back to your original design.
- Any nets that remain unnamed in the design will be given generated names that will mean nothing to you later in the implementation process.
- Naming nets also enhances readability and aids in documenting your design.

Label the five input nets you just drew. Refer to the completed schematic below. To label the reset net:

1. Select **Add > Net Name**.
2. Type `reset` into the Name box.
   The net name is now attached to the cursor.
3. Place the name on the leftmost end of the net, as illustrated in Figure 3-31.
4. Repeat Steps 1 through 3 for the `clk`, `lap_load`, `mode`, and `strtstop` pins.
   Once all of the nets have been labeled, add the I/O marker.
5. Select **Add > I/O Marker**.
6. Click and drag a box around the name of the five labeled nets, as illustrated in Figure 3-31, to place an input port on each net.

![Figure 3-31: Adding I/O Markers to Labeled Nets](image)
Assigning Pin Locations

Xilinx recommends that you let the automatic placement and routing (PAR) program define the pinout of your design. Pre-assigning locations to the pins can sometimes degrade the performance of the place-and-route tools. However, it may be necessary at some point to lock the pinout of a design so that it can be integrated into a Printed Circuit Board (PCB).

For this tutorial, the inputs and outputs will be locked to specific pins in order to place and download the design to the Spartan-3A demo board. Because the tutorial stopwatch design is simple and timing is not critical, the example pin assignments will not adversely affect the ability of PAR to place and route the design.

Assign a LOC parameter to the output nets on the stopwatch schematic, as follows:

1. Right-click on the clk net and select **Object Properties** from the right-click menu.
2. Click the **New** button under Net Attributes to add a new property.
3. Enter **LOC** for the Attribute Name and **E12** for the Attribute Value.
4. Click **OK** to return to the Object Properties dialog box.

5. To make the LOC attribute visible, select the **Add** button adjacent to the LOC attribute in the Attribute window.
6. In the Net Attribute Visibility window, click on a location near the center of the displayed net and then select **OK**.

   This will display the LOC attribute on the schematic above the clk net.

   Click **OK** to close the Object properties window.

   The above procedure constrains clk to pin E12. Notice that the LOC property has already been added to the sf_d(7:0) bus. The remaining pin location constraints will be added in “Using the Constraints Editor” and “Assigning I/O Locations Using PlanAhead” of Chapter 5, “Design Implementation”.

   **Note:** To turn off the Location constraint without deleting it, select the loc attribute, and click **Edit Traits**. Select **VHDL or Verilog** and select **Ignore this attribute**.

Completing the Schematic

Complete the schematic by wiring the components you have created and placed, adding any additional necessary logic, and labeling nets appropriately. The following steps guide you through the process of completing the schematic. You may also want to use the completed schematic shown below to complete the schematic. Each of the actions referred
to in this section has been discussed in detail in earlier sections of the tutorial. Please see the earlier sections for detailed instructions.

To complete the schematic diagram:

1. Draw a hanging wire to the LOCKED_OUT pin of DCM1 and name the wire `locked`. See “Drawing Wires” and “Adding Net Names.”

2. Draw a hanging wire to the clk input of both the time_cnt and statmach macros. (See “Drawing Wires.”)
3. Name both wires `clk_100`. (See “Adding Net Names.”)

   **Note:** Remember that nets are logically connected if their names are the same, even if the net is not physically drawn as a connection in the schematic. This method is used to make the logical connection of clk_100 and several other signals.

   Draw a wire to connect the clk inputs of the three debounce macros and name the wire `clk_26214k`.

4. Draw wires between the sig_out pins of the debounce components and the lap_load, mode_in and strtrstop pin of the statmach macro. Label the nets `ll_debounced`, `mode_debounced`, and `strtrstop_debounced`. See “Drawing Wires” and “Adding Net Names.”

5. Add hanging wires to the dcm_lock pin and the reset pin of the statmach macro. Name them `locked` and `reset`, respectively.

6. Draw a hanging wire to the clken output of the statmach component and another hanging wire to the ce pin of the time_cnt component. Name both wires `clk_en_int`.

7. Draw hanging wires from the rst output pin of the statmach macro and the clr pin of the time_cnt macro. See “Drawing Wires.” Label both wires `rst_int`.

8. Draw a wire from the bus output of the timer_preset to the q(19:0) input of the time_cnt macro. See “Drawing Wires.” Notice how the wire is automatically converted to a bus.

9. Draw a hanging bus on the input of the timer_preset macro and name the bus `address(5:0)`.

10. Draw wires from the lap_trigger and mode outputs of the statmach macro to the lap and mode inputs of the lcd_control macro. See “Drawing Wires.” Name the nets `lap` and `mode_control` respectively.

11. Draw hanging wires from the load output of the statmach macro and the load input of the time_cnt macro. See “Drawing Wires.” Name both wires `load`.

12. Draw a hanging wire to the up input time_cnt macro. See “Drawing Wires.” Name the wire `mode_control`.

The schematic is now complete.

Save the design by selecting **File > Save**.

You have now completed the schematic design.

To continue with the schematic flow, do the following:

- Go to Chapter 4, “Behavioral Simulation,” to perform a pre-synthesis simulation of this design.
- Proceed to Chapter 5, “Design Implementation,” to place and route the design.
Behavioral Simulation

This chapter contains the following sections.

- “Overview of Behavioral Simulation Flow”
- “ModelSim Setup”
- “ISim Setup”
- “Getting Started”
- “Adding an HDL Test Bench”
- “Behavioral Simulation Using ModelSim”
- “Behavioral Simulation Using ISim”

Overview of Behavioral Simulation Flow

Xilinx® ISE™ provides an integrated flow with the Mentor ModelSim simulator and the Xilinx ISim simulator that allows simulations to be run from the Xilinx Project Navigator. The examples in this tutorial demonstrate how to use the integrated flow. Whether you use the ModelSim simulator or the ISim simulator with this tutorial, you will achieve the same simulation results.

For additional information about simulation, and for a list of other supported simulators, see Chapter 7 of the Synthesis and Simulation Design Guide. This Guide is accessible from within ISE by selecting Help > Software Manuals, and from the web at http://www.xilinx.com/support/software_manuals.htm.

This tutorial provides an introduction to the simulation flow within ISE Project Navigator, including highlights of features within the ModelSim and ISim simulators. For more detailed information about using these simulators, see ModelSim documentation at http://www.model.com, or the ISim in-depth tutorial available at http://www.xilinx.com/support/techsup/tutorials/tutorials11.htm.

ModelSim Setup

In order to use this tutorial, you must install ModelSim on your computer. The following sections discuss requirements and setup for ModelSim PE, ModelSim SE, and ModelSim XE.
ModelSim PE and SE

ModelSim PE and ModelSim SE are full versions of ModelSim available for purchase directly from Mentor Graphics. In order to simulate with the ISE 11 libraries, use ModelSim 6.4b or newer. Older versions may work but are not supported. For more information about ModelSim PE or SE, please contact Mentor Graphics.

ModelSim Xilinx Edition

ModelSim Xilinx Edition III (MXE III) is the Xilinx version of ModelSim which is based on ModelSim PE. There are two versions of MXE III available for purchase from Xilinx: a free “starter” version, and a full version. For more information about MXE III, including how to purchase the software, please visit http://www.xilinx.com/ise/optional_prod/mxe.htm

ISim Setup

ISim is automatically installed and set up with the ISE 11.1 installer on supported operating systems. Please see list of operating systems supported by ISim on the web at http://www.xilinx.com/ise/ossupport/index.htm#simulator

Getting Started

The following sections outline the requirements for performing behavioral simulation in this tutorial.

Required Files

The behavioral simulation flow requires design files, a test bench file, and Xilinx simulation libraries.

Design Files (VHDL, Verilog, or Schematic)

This chapter assumes that you have completed the design entry tutorial in either Chapter 2, “HDL-Based Design,” or Chapter 3, “Schematic-Based Design.” After you have completed one of these chapters, your design includes the required design files and is ready for simulation.

Test Bench File

In order to simulate the design, a test bench file is required to provide stimulus to the design. VHDL and Verilog test bench files are available with the tutorial files. You may also create your own test bench file.

Xilinx Simulation Libraries

Xilinx simulation libraries are required when a Xilinx primitive or IP core is instantiated in the design. The design in this tutorial requires the use of simulation libraries because it contains instantiations of a digital clock manager (DCM) and a CORE Generator™ component. For information on simulation libraries and how to compile them, see the next section, “Xilinx Simulation Libraries.”
Xilinx Simulation Libraries

To simulate designs that contain instantiated Xilinx primitives, CORE Generator components, and other Xilinx IP cores you must use the Xilinx simulation libraries. These libraries contain models for each component. These models reflect the functions of each component, and provide the simulator with the information required to perform simulation.

For a detailed description of each library, see Chapter 5 of the Synthesis and Simulation Design Guide. This Guide is accessible from within ISE by selecting Help > Software Manuals, and from the web at http://www.xilinx.com/support/documentation/dt_ise11-1.htm.

Updating the Xilinx Simulation Libraries

The Xilinx simulation libraries contain models that are updated on a regular basis.

- The XilinxCoreLib models are updated each time an IP Update is installed.
- All other models are updated each time a service pack is installed.

When the models are updated, you must recompile the libraries. The compiled Xilinx simulation libraries are then available during the simulation of any design.

ModelSim PE or SE

If you are using ModelSim PE or SE, you must compile the simulation libraries with the updated models. See Chapter 6 of the Synthesis and Simulation Design Guide. This Guide is accessible from within ISE by selecting Help > Software Manuals, or from the web at http://www.xilinx.com/support/documentation/dt_ise11-1.htm.

ModelSim Xilinx Edition III

Updated models for ModelSim Xilinx Edition III (MXE III) are precompiled and available on the Xilinx support website. Download the latest precompiled models from the Download Center at http://www.xilinx.com/support/download/index.htm.

Xilinx ISim

Updated simulation libraries for the ISim are precompiled and installed with ISE installations and software updates.

Mapping Simulation Libraries in the Modelsim.ini File

ModelSim uses the modelsim.ini file to determine the location of the compiled libraries. For instance, if you compiled the UNISIM library to c:\lib\UNISIM, the following mapping appears in the modelsim.ini file:

```
UNISIM = c:\lib\UNISIM
```

**Note:** The modelsim.ini is not applicable to the ISE Simulator.

ModelSim searches for a modelsim.ini file in the following locations until one is found:

- The modelsim.ini file pointed to by the MODELSIM environment variable.
- The modelsim.ini file in the current working directory.
- The modelsim.ini file in the directory where ModelSim is installed.
If the MODELSIM environment variable is not set, and the modelsim.ini file has not been copied to the working directory, the modelsim.ini file in the ModelSim installation directory is used.

**ModelSim PE or SE**

If you are using ModelSim PE or SE, refer to the *Development System Reference Guide* and use COMPXLIB to compile the libraries. While compiling the libraries, COMPXLIB also updates the modelsim.ini file with the correct library mapping. Open the modelsim.ini file and make sure that the library mappings are correct.

For future projects, you can copy the modelsim.ini file to the working directory and make changes that are specific to that project, or you can use the MODELSIM environment variable to point to the desired modelsim.ini file.

**ModelSim Xilinx Edition III**

If you are using ModelSim Xilinx Edition III (MXE III), open the modelsim.ini file in the directory where MXE III was installed. All of the Xilinx simulation libraries are already mapped to the proper location.

**ISE Simulator**

The modelsim.ini file is not applicable to the ISE Simulator.

---

**Adding an HDL Test Bench**

In order to add an HDL test bench to your design project, you can either add a test bench file provided with this tutorial, or create your own test bench file and add it to your project.

**Adding Tutorial Test Bench File**

This section demonstrates how to add a pre-existing test bench file to the project. A VHDL test bench and Verilog test fixture are provided with this tutorial.

*Note:* To create your own test bench file in ISE, select **Project > New Source**, and select either **VHDL Test Bench** or **Verilog Text Fixture** in the New Source Wizard. An empty stimulus file is added to your project. You must define the test bench in a text editor.

**VHDL Simulation**

To add the tutorial VHDL test bench to the project:

1. Select **Project > Add Source**.
2. Select the test bench file `stopwatch_tb.vhd`.
3. Click **Open**.
4. Check that **Simulation** is selected for the file Association type.
5. Click **OK**.

![Adding Source Files window]

Figure 4-1: Adding Source Files... adding VHDL Test Bench

ISE recognizes the top-level design file associated with the test bench, and adds the test bench in the correct order.
Verilog Simulation

To add the tutorial Verilog test fixture to the project:

1. Select **Project > Add Source**.
2. Select the file *stopwatch_tb.v*.
3. Click **Open**.
4. Check that **Simulation** is selected for the file association type.
5. Click **OK**.

![Figure 4-2: Adding Source Files... Adding Verilog Test Fixture](image)

ISE recognizes the top-level design file associated with the test fixture, and adds the test fixture in the correct order.

Behavioral Simulation Using ModelSim

Now that you have a test bench in your project, you can perform behavioral simulation on the design using the ModelSim simulator. ISE has full integration with the ModelSim Simulator. ISE enables ModelSim to create the work directory, compile the source files, load the design, and perform simulation based on simulation properties.

To simulate with ISim, skip to “Behavioral Simulation Using ISim.” Whether you choose to use the ModelSim simulator or the ISim simulator for this tutorial, the end result is the same.

To select ModelSim as your project simulator:

1. In the Sources tab, right-click the device line (xc3s700A-4fg484).
2. Select **Properties**.
3. In the Simulator field of the Project Properties dialog box, select the ModelSim type and HDL language combination you are using.

Locating the Simulation Processes

The simulation processes in ISE enable you to run simulation on the design using ModelSim. To locate the ModelSim simulator processes:

1. In the Sources tab, select **Behavioral Simulation** in the Sources for field.
2. Select the test bench file (*stopwatch_tb*).
3. In the Processes tab, click the + beside ModelSim Simulator to expand the process hierarchy.
If ModelSim is installed but the processes are not available, the Project Navigator preferences may not be set correctly.

To set the ModelSim location:

1. Select Edit > Preferences.
2. Click the + next to ISE General to expand the ISE preferences
3. Click Integrated Tools in the left pane.
4. In the right pane, under Model Tech Simulator, browse to the location of the modelsim executable. For example,
   
   C:\modeltech_xe\win32xoem\modelsim.exe

The following simulation processes are available:

- **Simulate Behavioral Model**
  
  This process starts the design simulation.

**Specifying Simulation Properties**

You will perform a behavioral simulation on the stopwatch design after you have set some process properties for simulation.

ISE allows you to set several ModelSim Simulator properties in addition to the simulation netlist properties. To see the behavioral simulation properties, and to modify the properties for this tutorial:

1. In the Sources tab, select the test bench file (*stopwatch_tb*).
2. Click the + sign next to ModelSim Simulator to expand the hierarchy in the Processes tab.
3. Right-click Simulate Behavioral Model.
4. Select Properties.
5. In the Process Properties dialog box, (Figure 4-3) set the Property display level to Advanced. This global setting enables you to now see all available properties.
6. Change the Simulation Run Time to **2000 ns**.

![Process Properties - Simulation Properties](image)

**Figure 4-3: Behavioral Simulation Process Properties**

7. Click **OK**.

For a detailed description of each property available in the Process Properties dialog box, click **Help**.

### Performing Simulation

Once the process properties have been set, you are ready to run ModelSim. To start the behavioral simulation, double-click **Simulate Behavioral Model**. ModelSim creates the work directory, compiles the source files, loads the design, and performs simulation for the time specified.

The majority of this design runs at 100 Hz and would take a significant amount of time to simulate. The first outputs to transition after RESET is released are the SF_D and LCD_E control signals at around 33 mS. This is why the counter may seem like it is not working in a short simulation. For the purpose of this tutorial, only the DCM signals are monitored to verify that they work correctly.

### Adding Signals

To view internal signals during the simulation, you must add them to the Wave window. ISE automatically adds all the top-level ports to the Wave window. Additional signals are displayed in the Signal window based on the selected structure in the Structure window.

There are two basic methods for adding signals to the Simulator Wave window.

- Drag and drop from the Signal/Object window.
- Highlight signals in the Signal/Object window, and select **Add > Wave > Selected Signals**.
The following procedure explains how to add additional signals in the design hierarchy. In this tutorial, you will be adding the DCM signals to the waveform.

If you are using ModelSim version 6.0 or higher, all the windows are docked by default. To undock the windows, click the **Undock** icon.

![Undock icon](image)

To add additional signals in the design hierarchy:

1. In the Structure/Instance window, click the + next to uut to expand the hierarchy. Figure 4-5 shows the Structure/Instance window for the VHDL flow. The graphics and the layout of the Structure/Instance window for a schematic or Verilog flow may be different.

![Structure/Instance Window - VHDL flow](image)

2. Select **dcm_inst** in the Structure/Instance window. The signals listed in the Signal/Object window are updated.

3. Click and drag **CLKIN_IN** from the Signal/Object window to the Wave window.

4. In the Signal/Object window, select the following signals. To select multiple signals, hold down the Ctrl key:
   - RST_IN
   - CLKFX_OUT
   - CLK0_OUT
   - LOCKED_OUT
5. Right-click in the Signal/Object window.
6. Select **Add to Wave > Selected Signals**.

**Adding Dividers**

In ModelSim, you can add dividers in the Wave window to make it easier to differentiate the signals. To add a divider called **DCM Signals**:

1. Right click anywhere in the signal section of the Wave window. If necessary, undock the window and maximize the window for a larger view of the waveform.
2. Select **Insert Divider**.
3. Enter **DCM Signals** in the Divider Name box.
4. Click **OK**.
5. Click and drag the newly created divider to above the CLKIN_IN signal.

After adding the DCM Signals divider, the waveform will look like **Figure 4-6**.

The waveforms have not been drawn for any of the newly added signals. This is because ModelSim did not record the data for these signals. By default, ModelSim records data only for the signals that have been added to the Wave window while the simulation is running. After new signals are added to the Wave window, you must rerun the simulation for the desired amount of time.

**Rerunning Simulation**

To rerun simulation in ModelSim:

1. Click the **Restart Simulation** icon.

![Restart Simulation Icon]
2. In the Restart dialog box, click **Restart**.
3. At the ModelSim command prompt, enter **run 2000 ns**.
4. Press **Enter**.

   ![Figure 4-8: Restart Dialog Box](image)

   **Figure 4-8:** Restart Dialog Box

   ![Figure 4-9: Entering the Run Command](image)

   **Figure 4-9:** Entering the Run Command

The simulation runs for 2000 ns. The waveforms for the DCM are now visible in the Wave window.

**Analyzing the Signals**

The DCM signals can be analyzed to verify that they work as expected. The CLK0_OUT needs to be 50 MHz and the CLKFX_OUT should be ~26 MHz. The DCM outputs are valid only after the LOCKED_OUT signal is high; therefore, the DCM signals are analyzed only after the LOCKED_OUT signal has gone high.

ModelSim enables you to add cursors to measure the distance between signals. To measure the CLK0_OUT:

1. Select **Add > Wave > Cursor** twice to add two cursors.
2. Click and drag one cursor to the first rising edge transition on the CLK0_OUT signal after the LOCKED_OUT signal has gone high.
3. Click and drag the second cursor just to the right of the first.
4. Click the **Find Next Transition** icon twice to move the cursor to the next rising edge on the CLK0_OUT signal.

   ![Figure 4-10: Find Next Transition Icon](image)

   **Figure 4-10:** Find Next Transition Icon
5. Look at the bottom of the waveform for the distance between the two cursors. The measurement should read 20000 ps. This converts to 50 MHz, which is the input frequency from the test bench, which in turn should be the DCM CLK0 output.

6. Measure CLKFX_OUT using the same steps as above. The measurement should read 38462 ps. This comes out to approximately 26 MHz.

**Saving the Simulation**

The ModelSim simulator enables you to save the signals list in the Wave window after new signals or stimuli are added, and after simulation is rerun. The saved signals list can easily be opened each time the simulation is started.

To save the signals list:
1. In the Wave window, select **File > Save as**.
2. In the Save Format dialog box, rename the file name from the default `wave.do` to `dcm_signal.do`.
3. Click `Save`.

After restarting the simulation, select **File > Load** in the Wave window to load this file.

Your behavioral simulation is complete. To implement the design, follow the steps in Chapter 5, “Design Implementation.”

**Behavioral Simulation Using ISim**

Follow this section of the tutorial if you have skipped the previous section, “Behavioral Simulation Using ModelSim.”

Now that you have a test bench in your project, you can perform behavioral simulation on the design using the ISE Simulator (ISim). ISE has full integration with ISim. ISE enables ISim to create the work directory, compile the source files, load the design, and perform simulation based on simulation properties.

To select ISim as your project simulator:
1. In the Sources view, right-click the device line (xc3s700A-4fg484).
2. Select **Design Properties**.
3. In the Project Properties dialog box, select **ISim (VHDL/Verilog)** in the Simulator field.

**Locating the Simulation Processes**

The simulation processes in ISE enable you to run simulation on the design using ISim. To locate the ISim processes:
1. In the Sources view, select **Behavioral Simulation** in the Sources for field.
2. Select the test bench file (`stopwatch_tb`).
3. Click the + beside ISim Simulator in the Processes view to expand the process hierarchy.
The following simulation processes are available:

- **Check Syntax**  
  This process checks for syntax errors in the test bench.

- **Simulate Behavioral Model**  
  This process starts the design simulation.

### Specifying Simulation Properties

You will perform a behavioral simulation on the stopwatch design after you set some process properties for simulation.

ISE allows you to set several ISim properties in addition to the simulation netlist properties. To see the behavioral simulation properties, and to modify the properties for this tutorial:

1. In the Sources tab, select the test bench file (*stopwatch_tb*).
2. Click the + sign next to ISim Simulator to expand the hierarchy in the Processes tab.
3. Right-click the **Simulate Behavioral Model** process.
4. Select **Process Properties**.
5. In the Process Properties dialog box, set the Property display level to **Advanced**. This global setting enables you to now see all available properties.
6. Change the Simulation Run Time to **2000 ns**.
7. Click **OK**.

*Note:* For a detailed description of each property available in the Process Property dialog box, click **Help**.

![Figure 4-11: Behavioral Simulation Process Properties](image-url)
Performing Simulation

Once the process properties have been set, you are ready to run ISim to simulate the design. To start the behavioral simulation, double-click **Simulate Behavioral Model**. ISim creates the work directory, compiles the source files, loads the design, and performs simulation for the time specified.

The majority of this design runs at 100 Hz and would take a significant amount of time to simulate. The first outputs to transition after RESET is released are SF_D and LCD_E at around 33 mS. This is why the counter may seem like it is not working in a short simulation. For the purpose of this tutorial, only the DCM signals are monitored to verify that they work correctly.

Adding Signals

To view signals during the simulation, you must add them to the Waveform window. ISE automatically adds all the top-level ports to the Waveform window. Additional signals are displayed in the Instances and Processes panel. The following procedure explains how to add additional signals in the design hierarchy. For the purpose of this tutorial, add the DCM signals to the waveform.

To add additional signals in the design hierarchy:

1. In the Instances and Processes panel, click the > next to **stopwatch_tb** to expand the hierarchy.
2. Click the > next to **UUT** to expand the hierarchy.

The figure below shows the contents of the Instances and Processes panel for the VHDL flow. The graphics and the layout of the window for a schematic or Verilog flow may be different.

![Sim Hierarchy Window - VHDL flow](image)

*Figure 4-12: Sim Hierarchy Window - VHDL flow*
3. Select the **Inst_dcm1** in the Instances and Processes panel.

4. Click and drag **CLKIN_IN** from the Sim Objects window to the Waveform window.

5. Select the following signals:
   - **RST_IN**
   - **CLKFX_OUT**
   - **CLK0_OUT**
   - **LOCKED_OUT**
   
   To select multiple signals, hold down the **Ctrl** key.

6. Drag all the selected signals to the waveform. Alternatively, right click on a selected signal and select **Add To Wave Window**.

![Figure 4-13: Adding Signals to the Simulation Waveform](image)

Notice that the waveforms have not been drawn for the newly added signals. This is because ISim did not record the data for these signals. By default, ISim records data only for the signals that have been added to the waveform window while the simulation is running. Therefore, when new signals are added to the waveform window, you must rerun the simulation for the desired amount of time.

**Rerunning Simulation**

To rerun the simulation in ISim:

1. Click the **Restart Simulation** icon.

![Figure 4-14: ISE Simulator Restart Simulation Icon](image)

2. At the ISE Simulator command prompt in the Console, enter **run 2000 ns** and press **Enter**.

The simulation runs for 2000 ns. The waveforms for the DCM are now visible in the Waveform window.

**Analyzing the Signals**

Now the DCM signals can be analyzed to verify that they work as expected. The **CLK0_OUT** should be 50 MHz and the **CLKFX_OUT** should be ~26 MHz. The DCM...
outputs are valid only after the LOCKED_OUT signal is high; therefore, the DCM signals are analyzed only after the LOCKED_OUT signal has gone high.

ISim can add markers to measure the distance between signals. To measure the CLK0_OUT:

1. If necessary, zoom in on the waveform using the zoom local toolbar icons.
2. Click on the Snap to Transition toolbar button in the waveform viewer local toolbar.

![Snap to Transition toolbar button](image)

Figure 4-15: Snap to Transition toolbar button

3. Click on the first rising edge transition on the CLK0_OUT signal after the LOCKED_OUT signal has gone high, then drag the cursor to the right to the next rising edge transition of the CLK0_OUT signal.
4. At the bottom of the waveform window, the start point time, end point time, and delta times are shown. The delta should read 20,000 ps (or 20 ns). This converts to 50 MHz which is the input frequency from the test bench, which in turn is the DCM CLK0 output.

![Waveform viewer displaying time between transitions](image)

Figure 4-16: Waveform viewer displaying time between transitions

5. Measure CLKFX_OUT using the same steps as above. The measurement should read 38,500 ps (or 38.5 ns). This equals approximately 26 MHz.

Your behavioral simulation is complete. To implement the design, follow the steps in Chapter 5, “Design Implementation.”
This chapter contains the following sections.

- “Overview of Design Implementation”
- “Getting Started”
- “Specifying Options”
- “Creating Timing Constraints”
- “Translating the Design”
- “Using the Constraints Editor”
- “Assigning I/O Locations Using PlanAhead”
- “Mapping the Design”
- “Using Timing Analysis to Evaluate Block Delays After Mapping”
- “Placing and Routing the Design”
- “Using FPGA Editor to Verify the Place and Route”
- “Evaluating Post-Layout Timing”
- “Creating Configuration Data”
- “Command Line Implementation”

Overview of Design Implementation

Design Implementation is the process of translating, mapping, placing, routing, and generating a BIT file for your design. The Design Implementation tools are embedded in the ISE™ software for easy access and project management.

This chapter is the first in the “Implementation-only Flow” and is a subsequent chapter for the “HDL Design Flow” and the “Schematic Design Flow”.

This chapter demonstrates the ISE Implementation flow. The front-end design has already been compiled in an EDA interface tool. For details about compiling the design, see Chapter 2, “HDL-Based Design” or Chapter 3, “Schematic-Based Design.” In this chapter, you will be passing a synthesized netlist (EDN, NGC) from the front-end tool to the back-end Design Implementation tools, and you will be incorporating placement constraints through a User Constraints File (UCF). You will also add timing constraints as well as additional placement constraints.
Chapter 5: Design Implementation

Getting Started

The tutorial design emulates a runner’s stopwatch with actual and lap times. There are five inputs to the system: CLK, RESET, LAP_LOAD, MODE, and SRTSTP. This system generates a traditional stopwatch with lap times and a traditional timer on a LCD display.

Continuing from Design Entry

If you have followed the tutorial using either the HDL Design flow or the Schematic Design flow, you have created a project, completed source files, and synthesized the design.

If you do not have a stopwatch.ucf constraint file in your project, create one as follows:

1. In the Sources tab, select the top-level source file stopwatch.
2. Select Project > New Source.
4. Type stopwatch.ucf as the file name.
5. Click Next.
6. Click Finish.

With a UCF in the project, you are now ready to begin this chapter. Skip to the “Specifying Options” section.

Starting from Design Implementation

If you are beginning the tutorial from this chapter, you will need to download the pre-synthesized design files provided on the Xilinx® web-site, create a project in ISE and then add the downloaded source files to the project.

1. Unzip the tutorial zip file wtut_edif.zip to an empty working directory.
2. The following files are included in the ZIP file.

<table>
<thead>
<tr>
<th>Table 5-1: Tutorial Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name</td>
</tr>
<tr>
<td>stopwatch.edf</td>
</tr>
<tr>
<td>timer_preset.ngc</td>
</tr>
<tr>
<td>stopwatch.ucf</td>
</tr>
</tbody>
</table>
Specifying Options

This section describes how to set some properties for design implementation. The implementation properties control how the software maps, places, routes, and optimizes a design.

To set the implementation property options for this tutorial:

1. In the Sources view in the Design tab, select the stopwatch top-level file. **Note:** Be sure the Implementation view is active by selecting it from the Sources for: dropdown menu in the Sources view.

2. In the Processes view in the Design tab, right-click the Implement Design process.

3. Select Process Properties from the right-click menu.

   The Process Properties dialog box provides access to the Translate, Map, Place and Route, and Timing Report properties. You will notice a series of categories, each contains properties for one of these phases of design implementation.

4. Ensure that you have set the Property display level to Advanced. This global setting enables you to see all available properties.

5. Click the Place & Route Properties category.

6. Change the Place & Route Effort Level (Overall) to High.
This option increases the overall effort level of Place and Route during implementation.

![Figure 5-1: Place & Route Properties](image)

7. Click **OK** to exit the Process Properties dialog box.

### Creating Timing Constraints

The User Constraints File (UCF) is a text file and may be edited directly with a text editor. To facilitate editing of this file, graphical tools are provided to create and edit constraints. The Constraints Editor and PlanAhead are graphical tools that enable you to enter timing and I/O and placement constraints.

To launch the Constraints Editor:

1. In the Sources tab, select the **Stopwatch** module.
2. In the Processes tab, expand the **User Constraints** hierarchy.
3. Double-click **Create Timing Constraints**.

This automatically runs the Translate step, which is discussed in the following section. Then the Constraints Editor opens.

**Translating the Design**

ISE manages the files created during implementation. The ISE tools use the settings that you specified in the Process Properties dialog box. This gives you complete control over how a design is processed. Typically, you set your options first. You then run through the entire flow by running **Implement Design**. The Implement Design process includes the three sub-processes Translate, Map and Place&Rout. You can simply run the Implement Design process to automate the running of all three sub-processes, or you may run the sub-processes individually. In this tutorial you will run the processes individually in order to more easily see and understand each step.

During translation, the NGDBuild program performs the following functions:

- Converts input design netlists and writes results to a single merged NGD netlist. The merged netlist describes the logic in the design as well as any location and timing constraints.
- Performs timing specification and logical design rule checks.
- Adds constraints from the User Constraints File (UCF) to the merged netlist.
Using the Constraints Editor

When you run the Create Timing Constraints process, Translate is automatically run and ISE launches the Constraints Editor.

The Constraints Editor enables you to:

- Edit constraints previously defined in a UCF file.
- Add new constraints to your design.

Input files to the Constraints Editor are:

- **NGD (Native Generic Database) File**
  The NGD file serves as input to the mapper, which then outputs the physical design database, an NCD (Native Circuit Description) file.

- **Corresponding UCF (User Constraint File)**
  All UCF files that are part of the ISE project are passed to Constraints Editor.

Multiple UCF files are supported in ISE projects. All constraint files in the project are read by the Constraints Editor and constraints that are edited are updated in the constraint file they originated in. New constraints are written to the UCF file specified in Constraints Editor.

The Translate step (NGDBuild) uses the UCF file, along with design source netlists, to produce a newer NGD file, which incorporates the changes made. The Map program (the next section in the design flow) then reads the NGD. In this design, the stopwatch.ngd and stopwatch.ucf files are automatically read into the Constraints Editor.

In the following section, a PERIOD, Global OFFSET IN, Global OFFSET OUT, and TIMEGRP OFFSET IN constraint will be created and written in the UCF and used during implementation. The Clock Domains branch of the Timing Constraints tab automatically displays all the clock nets in your design, and enables you to define the associated period, pad to setup, and clock to pad values. Note that many of the internal names will vary depending on the design flow and synthesis tool used.

![Constraints Editor in Project Navigator - Clock Domains](image)

*Figure 5-3: Constraints Editor in Project Navigator - Clock Domains*

In the Constraints Editor, edit the constraints as follows:
1. Double-click the row containing the \texttt{clk} signal in the Unconstrained Clocks table. The Clock Period dialog box opens.

2. For the Clock Signal Definition, verify that \textbf{Specify Time} is selected. This enables you to define an explicit period for the clock.

3. Enter a value of \texttt{7.0} in the Time field.

4. Verify that \texttt{ns} is selected from the Units drop-down list.

\begin{figure}
\centering
\includegraphics[width=0.5\textwidth]{figures/period_constraint.png}
\caption{PERIOD Constraint Values}
\end{figure}

5. For the Input Jitter section, enter a value of \texttt{60} in the Time field.

6. Verify that \texttt{ps} is selected from the Units drop-down list.

\begin{figure}
\centering
\includegraphics[width=0.5\textwidth]{figures/input_jitter_constraint.png}
\caption{INPUT JITTER Constraint Value}
\end{figure}

7. Click \textbf{OK}.

The period constraint is displayed in the constraint table at the top of the window. The period cell is updated with the global clock period constraint that you just defined (with a default 50\% duty cycle).

8. Select the \texttt{Inputs} branch under Timing Constraints in the Constraint Type tree view.

9. Double-click on the \texttt{clk} signal in the Global OFFSET IN Constraint table to bring up the Create Setup Time (OFFSET IN) wizard.

10. Keep the default values on the first page of the screen and click \textbf{Next}. 
11. In the External setup time (offset in) field, enter **6 ns**.

12. In the Data valid duration field, enter **6 ns**.

This creates a Global OFFSET IN constraint for the CLK signal.

13. Click **Finish**.

14. Select the **Outputs** branch under Timing Constraints in the Constraint Type tree view.

15. Double-click the **clk** signal in the Global OFFSET OUT Constraint table.

16. In the External clock to pad (offset out) field, enter a value of **38 ns**.
This creates a Global OFFSET OUT constraint for the CLK signal

17. Click OK.

18. In the Unconstrained Output Ports table, select the \( sf_{d<0>}\) through \( sf_{d<7>}\) signals using Shift-Click to select multiple rows.


20. In the Create Time Group dialog, type `display_grp` for the Time group name, then click OK.

21. When asked if you would like to create an offset constraint, click OK.

22. In the External clock to pad (offset out) field, enter 32 ns.
23. Click **OK**.

24. Select **File > Save** in the Constraints Editor.
   The changes are now saved in the `stopwatch.ucf` file in your current working directory.

25. Close the Constraints Editor by selecting **File > Close**.

### Assigning I/O Locations Using PlanAhead

Use PlanAhead to add and edit the pin locations and area group constraints defined in the NGD file. PlanAhead writes the constraints to the project UCF file. In the case of multiple UCF files in the project, you will be asked to specify which constraint file new constraints should be written to. If you modify existing constraints they will be written back to the same constraint file they originated in. PlanAhead also provides device specific design rule checks to aid you in pin planning and placement.

The Translate step uses the design UCF file, along with the design source netlists, to produce a newer NGD file. The NGD file incorporates the changes made in the design and the UCF file from the previous section.

This section describes the creation of IOB assignments for several signals.

1. Select the `stopwatch` module in the Sources window of the Design tab.
2. Click the `+` next to **User Constraints** to expand the process hierarchy in the Processes window.
I/O Pin Planning can be performed either Pre- or Post-Synthesis. Whenever possible it is recommended that the process be run Post-Synthesis since the design then contains information needed for I/O and clock related design rule checks that can be performed by PlanAhead.

This process launches PlanAhead. If the design has not yet completed synthesis, Project Navigator will first automatically run synthesis before launching PlanAhead for I/O Planning.

The Welcome to PlanAhead screen provides links to detailed documentation, tutorials, and other training material to help you learn more about PlanAhead. This tutorial provides a simple overview of the use and capabilities of PlanAhead; for more information and to learn about the full capabilities, please visit the other resources available.

![PlanAhead Welcome screen](image)

**Figure 5-11: Floorplan Area/IO/Logic - Post Synthesis**

**Figure 5-12: PlanAhead Welcome screen**
4. Click **Close** on the Welcome dialog to proceed into PlanAhead.

5. In the I/O Ports tab, expand the **Scalar Ports** tree under All ports. You will now create pin assignments for the `lcd_e`, `lcd_rs`, and `lcd_rw` I/O signals.

6. Locate the `lcd_e` output signal, then click and drag it into the Package view and drop it on the **AB4** pin location.

7. Repeat the previous step to place the following additional output pins.
Mapping the Design

Now that the implementation properties and constraints have been defined, continue with the implementation of the design.

1. Select the stopwatch module in the Sources window.

2. In the Processes tab, expand the Implement Design process, then run the Map process by right-clicking on Map and selecting Run.

   Notes: This can also be accomplished by double-clicking Map.

If the Translate process is not up-to-date, Project Navigator automatically runs that process as well.

The design is mapped into CLBs and IOBs. Map performs the following functions:

- Allocates CLB and IOB resources for all basic logic elements in the design.
- Processes all location and timing constraints, performs target device optimizations, and runs a design rule check on the resulting mapped netlist.

---

8. Using either the drag and drop or Port Properties method, place the following input signals onto the appropriate I/O pin locations:

   - LCD_RS: Y14
   - LCD_RW: W13

Alternatively, you can type the location in the Site field in the I/O Port Properties tab when the I/O signal is selected.

9. Once the pins are locked down, select File > Save Project. The changes are saved in the project’s stopwatch.ucf file.


---

Mapping the Design

---

Figure 5-15: Assigning I/O pins via I/O Port Properties
Each step generates its own report as shown in the following table.

Table 5-2: Reports Generated by Map

<table>
<thead>
<tr>
<th>Translation Report</th>
<th>Includes warning and error messages from the translation process.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Map Report</td>
<td>Includes information on how the target device resources are allocated, references to trimmed logic, and device utilization.</td>
</tr>
<tr>
<td>All NGDBUILD and MAP Reports</td>
<td>For detailed information on the Map reports, refer to the Development System Reference Guide. This Guide is available with the collection of software manuals and is accessible from ISE by selecting Help &gt; Software Manuals, or from the web at <a href="http://www.xilinx.com/support/documentation/dt_ise11-1.htm">http://www.xilinx.com/support/documentation/dt_ise11-1.htm</a></td>
</tr>
</tbody>
</table>

To view a report:

1. Open the Design Summary/Reports window. If it is not already open in the Workspace you can open it by running the Design Summary/Reports process.

Figure 5-16: Opening the Design Summary/Reports
2. Select a report such as the Translation Report or Map Report in the Detailed Reports section of the Design Summary.
3. Review the report.
4. The Design Summary also provides a Summary of the design results, and a list of all of the messages (Errors, Warnings, INFO) generated by the implementation run.

Using Timing Analysis to Evaluate Block Delays After Mapping

After the design is mapped, evaluate the Logic Level details in the Post-Map Static Timing Report to evaluate the logical paths in the design. Evaluation verifies that block delays are reasonable given the design specifications. Because the design is not yet placed and routed, actual routing delay information is not available. The timing report describes the logical block delays and estimated routing delays. The net delays provided are based on an optimal distance between blocks (also referred to as unplaced floors).

Estimating Timing Goals with the 50/50 Rule

For a preliminary indication of how realistic your timing goals are, evaluate the design after the map stage. A rough guideline (known as the 50/50 rule) specifies that the block delays in any single path make up approximately 50% of the total path delay after the design is routed. For example, a path with 10 ns of block delay should meet a 20 ns timing constraint after it is placed and routed.

If your design is extremely dense, the Post-Map Static Timing Report provides a summary analysis of your timing constraints based on block delays and estimates of route delays.
This analysis can help to determine if your timing constraints are going to be met. This report is produced after Map and prior to Place and Route (PAR).

Report Paths in Timing Constraints Option

Use the Post-Map Static Timing Report to determine timing violations that may occur prior to running PAR. Since you defined timing constraints for the stopwatch design, the timing report will display the path for each of the timing constraints.

To view the Post-Map Static Timing Report and review the PERIOD Constraints that were entered earlier:

1. In the Processes tab, click the + next to Map to expand the process hierarchy.
2. Double-click **Generate Post-Map Static Timing**.
3. To open the Post-Map Static Timing Report, double-click **Analyze Post-Map Static Timing**.

Timing Analyzer automatically launches and displays the report.

4. Select the **TS_inst_dcm1_CLKFX_BUF** timing constraint under the Timing tab.

The work space shows the report for the selected constraint. At the top of this report, you will find the selected period constraint and the minimum period obtained by the tools after mapping. By default, only three paths per timing constraint will be shown. Selecting one of...
the three paths allows you to see a breakdown of the path which contains the component and routing delays.

Notice that the report displays the percentage of logic versus the percentage of routing at the end of each path (e.g. 88.0% logic, 12.0% route). The unplaced floors listed are estimates (indicated by the letter “e” next to the net delay) based on optimal placement of blocks.

5. After viewing the report, close the Timing Analyzer by selecting **File > Close**.

**Note:** Even if you do not generate a timing report, PAR still processes a design based on the relationship between the block delays, floors, and timing specifications for the design. For example, if a PERIOD constraint of **8 ns** is specified for a path, and there are block delays of **7 ns** and unplaced floor net delays of **3 ns**, PAR stops and generates an error message. In this example, PAR fails because it determines that the total delay (**10 ns**) is greater than the constraint placed on the design (**8 ns**). The Post-Map Static Timing Report will list any pre-PAR timing violations.

### Placing and Routing the Design

After the mapped design is evaluated, the design can be placed and routed.

One of two place-and-route algorithms is performed during the Place & Route (PAR) process:

- **Timing Driven PAR**
  
  PAR is run with the timing constraints specified in the input netlist and/or in the constraints file.

- **Non-Timing Driven PAR**
  
  PAR is run, ignoring all timing constraints.

Since you defined timing constraints earlier in this chapter, the Place & Route (PAR) process performs timing driven placement and routing.

1. To run PAR, in the Processes tab, double-click **Place & Route** under the Implement Design process group.

To review the reports that are generated after the Place & Route process is completed:

2. Open the Design Summary window by running the **Design Summary/Reports** process or by clicking on the Design Summary/Reports toolbar icon.

3. Select the **Place & Route Report** in the Detailed Reports section.

**Note:** Additional optional Place & Route Reports can also be generated by enabling their creation in the Place & Route process properties. When these are created, they will appear in the Design Summary in the Secondary Reports section.

<table>
<thead>
<tr>
<th>Table 5-3: Reports Generated by PAR</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Report</strong></td>
</tr>
<tr>
<td>Place &amp; Route Report</td>
</tr>
<tr>
<td>Asynchronous Delay Report</td>
</tr>
</tbody>
</table>

ISE 11 In-Depth Tutorial  
www.xilinx.com
Using FPGA Editor to Verify the Place and Route

Use the FPGA Editor to display and configure Field Programmable Gate Arrays (FPGAs).

The FPGA Editor reads and writes Native Circuit Description (NCD) files, Macro files (NMC) and Physical Constraints Files (PCF).

Use FPGA Editor to:

- Place and route critical components before running the automatic place-and-route tools.
- Finish placement and routing if the routing program does not completely route your design.
- Add probes to your design to examine the signal states of the targeted device. Probes are used to route the value of internal nets to an IOB (Input/Output Block) for analysis during debugging of a device.
- Run the BitGen program and download the resulting bitstream file to the targeted device.
• View and change the nets connected to the capture units of an Integrated Logic Analyzer (ILA) core in your design.

To view the actual design layout of the FPGA:

1. Click the + next to Place & Route to expand the process hierarchy, and double-click View/Edit Routed Design (FPGA Editor).

2. In FPGA Editor, change the List Window from All Components to All Nets. This enables you to view all of the possible nets in the design.
3. Select the **clk_262144K** (Clock) net to see the fanout of the clock net.

4. To exit FPGA Editor, select **File > Exit**.

**Evaluating Post-Layout Timing**

After the design is placed and routed, you can analyze the Post-Place & Route timing results to verify how the design performs against your specified timing goals.

There are multiple ways in which you can analyze timing:

- Viewing the Post-Place & Route Static Timing Report
- Using PlanAhead for Post-Place & Route Timing Analysis
- Using hyperlinks in Design Summary to analyze individual timing constraints

**Viewing the Post-Place & Route Static Timing Report**

This report evaluates the logical block delays and the routing delays. The net delays are now reported as actual routing delays after the Place and Route process. To display this report:

1. In the Design Summary/Reports, select **Static Timing** in the Design Overview section. Alternatively you can run the **Analyze Post-Place & Route Static Timing** process in the Process view under Implement Design > Place & Route > Generate Post-Place & Route Static Timing.
The following is a summary of the Post-Place & Route Static Timing Report for the stopwatch design:

♦ The minimum period value increased due to the actual routing delays.

The Post-Map timing report showed logic delays contributed to 80% to 90% of the minimum period attained. The post-layout report indicates that the logical delay value now equals between 30% and 40% of the period. The total unplaced floors estimate changed as well.

♦ The post-layout result does not necessarily follow the 50/50 rule previously described because the worst case path primarily includes component delays.

♦ For some hard to meet timing constraints, the worst case path is mainly made up of logic delay. Since total routing delay makes up only a small percentage of the total path delay spread out across two or three nets, expecting the timing of these paths to be reduced any further is unrealistic. In general, you can reduce excessive block delays and improve design performance by decreasing the number of logic levels in the design.

Analyzing the Design using PlanAhead

PlanAhead can be used to perform post-layout design analysis. Graphical layout analysis and timing path viewing, as well as floorplanning can be performed to both analyze design results as well as aid in design closure.

1. From the process tree, run the **Analyze Timing/Floorplan Design (PlanAhead)** process under Place & Route.

![Analyze Timing/Floorplan Design (PlanAhead) process](image)

**Figure 5-24: Analyze Timing / Floorplan Design (PlanAhead) process**

2. When PlanAhead opens, select one of the timing paths in the **Timing Results** tab. You will be able to view the path graphically in the Device view, and also view details of the path and the associated delays in the Properties tab.
3. Zoom in on the path in the Device view by clicking and dragging a box around the area of interest.

For a detailed tutorial on the full set of capabilities in PlanAhead related to timing analysis and design closure, see the Design Analysis and Floorplanning tutorial available in PlanAhead by selecting Help > Tutorial > Design Analysis and Floorplanning.


Creating Configuration Data

After analyzing the design, you need to create configuration data. A configuration bitstream is created for downloading to a target device or for formatting into a PROM programming file.

In this tutorial, you will create configuration data for a Xilinx Serial PROM. To create a bitstream for the target device, set the properties and run configuration as follows:

1. Right-click the Generate Programming File process.
3. Click the Startup Options category.
4. Change the FPGA Start-Up Clock property from CCLK to JTAG Clock.
Creating Configuration Data

Note: You can use CCLK if you are configuring Select Map or Serial Slave.

5. Click OK.

6. In the Processes tab, double-click Generate Programming File to create a bitstream of this design.

The BitGen program creates the bitstream file (in this tutorial, the stopwatch.bit file), which contains the actual configuration data.

7. To review the Programming File Generation Report, open the Bitgen Report in the Design Summary/Report Viewer. Verify that the specified options were used when creating the configuration data.

Creating a PROM File with iMPACT

To program a single device using iMPACT, all you need is a bitstream file. To program several devices in a daisy chain configuration, or to program your devices using a PROM, you must use iMPACT to create a PROM file. iMPACT accepts any number of bitstreams and creates one or more PROM files containing one or more daisy chain configurations.

In iMPACT, a wizard enables you to do the following:

- Create a PROM file.
- Add additional bitstreams to the daisy chain.
- Create additional daisy chains.
- Remove the current bitstream and start over, or immediately save the current PROM file configuration.

For this tutorial, create a PROM file in iMPACT as follows:

1. In the Processes tab, double-click Generate Target PROM/ACE File, located under the Configure Target Device process hierarchy.

2. In iMPACT, double-click on Create PROM File (PROM File Formatter) in the iMPACT Flows window.

Figure 5-26: Process Properties Startup Options

Figure 5-27: Create PROM File
3. In the PROM File Formatter window, select **Xilinx Flash/PROM** in the Select Storage Target section.
4. Click the green arrow to activate the next section.
5. In the Add Storage Device(s) section, click the **Auto Select PROM** checkbox.
6. Click the green arrow to activate the next section.
7. In the Enter Data section, enter an Output File Name of **stopwatch1**.
8. Verify that the Checksum Fill Value is set to **FF** and the File Format is **MCS**.

![PROM File Formatter](image)

**Figure 5-28: PROM File Formatter**

9. Click **OK** to close the PROM File Formatter.
10. In the Add Device dialog box, click **OK** and then select the **stopwatch.bit** file.
   
   **Note:** You will receive a warning that the startup clock is being changed from jtag to CCLK.

11. Click **No** when you are asked if you would like to add another design file to the datastream.
12. Click **OK** to complete the process.
13. Select the device graphic in the workspace area, then in the iMPACT Processes view, select **Generate File...**

   iMPACT displays the PROM associated with your bit file.

![PROM File](image)

**Figure 5-29: PROM File**

14. To close iMPACT, select **File > Exit**.
15. If prompted to save the project, select **Yes**, then name the project file **stopwatch_impact.ipf**.

   With the resulting **stopwatch.bit**, **stopwatch1.mcs** and a MSK file generated along with the BIT file, you are ready for programming your device using iMPACT. For more
information on programming a device, see the iMPACT Help, available from the iMPACT application by selecting Help > Help Topics.

This completes the Design Implementation chapter of the tutorial. For more information on this design flow and implementation methodologies, see the ISE Help, available from the ISE application by selecting Help > Help Topics.

Command Line Implementation

ISE allows a user to easily view and extract the command line arguments for the various steps of the implementation process. This allows a user to verify the options being used or to create a command batch file to replicate the design flow.

At any stage of the design flow you can look at the command line arguments for completed processes by double-clicking View Command Line Log File from the Design Utilities process hierarchy in the Processes view. This process opens a file named <source_name>.cmd_log in read-only mode.

To create an editable batch file, select File > Save As and enter the desired file name.

Sections of the Command Line Log File may also be copied from <source_name>.cmd_log using either the copy-and-paste method or the drag-and-drop method into a text file.

For a complete listing of command line options for most Xilinx executables, refer to the Command Line Tools User Guide. Command line options are organized according to implementation tools. This Guide is available with the collection of software manuals and is accessible from ISE by selecting Help > Software Manuals, or from the web at http://www.xilinx.com/support/software_manuals.htm. Command line options may also be obtained by typing the executable name followed by the \-h option at a command prompt.
Chapter 6

Timing Simulation

This chapter includes the following sections.

- “Overview of Timing Simulation Flow”
- “Getting Started”
- “Timing Simulation Using ModelSim”
- “Timing Simulation Using Xilinx ISim”

Overview of Timing Simulation Flow

Timing simulation uses the block and routing delay information from a routed design to give a more accurate assessment of the behavior of the circuit under worst-case conditions. For this reason, timing simulation is performed after the design has been placed and routed.

Timing (post-place and route) simulation is a highly recommended part of the HDL design flow for Xilinx® devices. Timing simulation uses the detailed timing and design layout information that is available after place and route. This enables simulation of the design, which closely matches the actual device operation. Performing a timing simulation in addition to a static timing analysis will help to uncover issues that cannot be found in a static timing analysis alone. To verify the design, the design should be analyzed both statically and dynamically.

In this chapter, you will perform a timing simulation using either the ModelSim simulator or the Xilinx ISE Simulator.

Getting Started

The following sections outline the requirements to perform this part of the tutorial flow.

Required Software

To simulate with ModelSim, you must have Xilinx ISE™ 11 and ModelSim simulator installed. Refer to Chapter 4, “Behavioral Simulation” for information on installing and setting up ModelSim. Simulating with the Xilinx ISE simulator requires that the ISE 11 software is installed.
Chapter 6: Timing Simulation

Required Files

The timing simulation flow requires the following files:

- **Design Files (VHDL or Verilog)**
  
  This chapter assumes that you have completed Chapter 5, “Design Implementation,” and thus, have a placed and routed design. The Netgen tool will be used in this chapter to create a simulation netlist from the placed and routed design which will be used to represent the design during the Timing Simulation.

- **Test Bench File (VHDL or Verilog)**
  
  In order to simulate the design, a test bench is needed to provide stimulus to the design. You should use the same test bench that was used to perform the behavioral simulation. Please refer to the “Adding an HDL Test Bench” in Chapter 4 if you do not already have a test bench in your project.

- **Xilinx Simulation Libraries**
  
  For timing simulation, the SIMPRIM library is needed to simulate the design.
  
  To perform timing simulation of Xilinx designs in any HDL simulator, the SIMPRIM library must be set up correctly. The timing simulation netlist created by Xilinx is composed entirely of instantiated primitives, which are modeled in the SIMPRIM library.
  
  If you completed Chapter 4, “Behavioral Simulation”, the SIMPRIM library should already be compiled. For more information on compiling and setting up Xilinx simulation libraries, see to “Xilinx Simulation Libraries” in Chapter 4.

Specifying a Simulator

To select either the desired simulator to simulate the stopwatch design, complete the following:

1. In the Sources tab, right-click the device line (xc3s700A-4fg484) and select **Properties**.
2. In the Project Properties dialog box click the down arrow in the Simulator value field to display a list of simulators.
   
   **Note:** ModelSim and Xilinx ISim are the only simulators that are integrated with Project Navigator. Selecting a different simulator (e.g. NC-Sim or VCS) will set the correct options for Netgen to create a simulation netlist for that simulator but Project Navigator will not directly open the simulator. For additional information about simulation, and for a list of other supported simulators, see Chapter 5 of the Synthesis and Verification Guide. This Guide is accessible from within ISE by selecting Help > Software Manuals, and from the web at http://www.xilinx.com/support/software_manuals.htm
3. Select **ISim (VHDL/Verilog)** or **Modelsim** with the appropriate version and language in the Simulator value field.

Timing Simulation Using ModelSim

Xilinx ISE provides an integrated flow with the Mentor ModelSim simulator. ISE enables you to create work directories, compile source files, initialize simulation, and control simulation properties for ModelSim.

**Note:** To simulate with ISim, skip to “Timing Simulation Using Xilinx ISim”. Whether you choose to use the ModelSim simulator or ISim for this tutorial, the end result is the same.
Specifying Simulation Process Properties

To set the simulation process properties:

1. In the Sources tab, select **Post-Route Simulation** in the Sources for field.
2. Select the test bench file *(stopwatch_tb)*.
3. In the Processes tab, click the + next to ModelSim Simulator to expand the process hierarchy.

   **Note:** If the ModelSim Simulator processes do not appear, it means that either ModelSim is not selected as the Simulator in the Project Properties dialog box, or Project Navigator cannot find modelsim.exe.

If ModelSim is installed but the processes are not available, the Project Navigator preferences may not be set correctly. To set the ModelSim location, select **Edit > Preferences**, click the + next to ISE General to expand the ISE preferences, and click **Integrated Tools** in the left pane. In the right pane, under Model Tech Simulator, browse to the location of modelsim.exe file. For example,

   `c:\modeltech_xe\win32xoem\modelsim.exe`.

4. Right-click **Simulate Post-Place & Route Model**.
5. Select **Properties**.

   The Process Properties dialog box displays.

6. Select the **Simulation Model Properties** category.

   The properties should appear as shown in Figure 6-1. These properties set the options that NetGen uses when generating the simulation netlist. For a description of each property, click the **Help** button.

7. Ensure that you have set the Property display level to **Advanced**.

   This global setting enables you to see all available properties.
For this tutorial, the default Simulation Model Properties are used.

![Simulation Model Properties](image)

**Figure 6-1: Simulation Model Properties**

8. Select the **Display Properties** category.
   
   This tab gives you control over the ModelSim simulation windows. By default, three windows open when timing simulation is launched from ISE. They are the Signal window, the Structure window, and the Wave window. For more details on ModelSim Simulator windows, refer to the *ModelSim User Guide*.

9. Select the **Simulation Properties** category.
   
   The properties should appear as shown in Figure 6-2. These properties set the options that ModelSim uses to run the timing simulation. For a description of each property, click the **Help** button.
10. In the Simulation Properties tab, set the Simulation Run Time property to **2000 ns**.

![Simulation Properties](image)

**Figure 6-2: Simulation Properties**

11. Click **OK** to close the Process Properties dialog box.

### Performing Simulation

To start the timing simulation, double-click **Simulate Post-Place and Route Model** in the Processes tab.

ISE will run Netgen to create the timing simulation model. ISE will then call ModelSim and create the working directory, compile the source files, load the design, and run the simulation for the time specified.

**Note:** The majority of this design runs at 100 Hz and would take a significant amount of time to simulate. This is why the counter will seem like it is not working in a short simulation. For the purpose of this tutorial, only the DCM signals will be monitored to verify that they work correctly.

### Adding Signals

To view signals during the simulation, you must add them to the Wave window. ISE automatically adds all the top-level ports to the Wave window. Additional signals are displayed in the Signal window based on the selected structure in the Structure window.

There are two basic methods for adding signals to the Simulator Wave window:

- Drag and drop from the Signal/Object window.
- Highlight signals in the Signal/Object window and then select **Add > Wave > Selected Signals**.
Chapter 6: Timing Simulation

The following procedure explains how to add additional signals in the design hierarchy. In this tutorial, you will be adding the DCM signals to the waveform.

**Note:** If you are using ModelSim version 6.0 or higher, all the windows are docked by default. All windows can be undocked by clicking the **Undock** icon.

1. In the Structure/Instance window, click the + next to uut to expand the hierarchy. **Figure 6-4** shows the Structure/Instance window for the Schematic flow. The graphics and the layout of the Structure/Instance window for a Verilog or VHDL flow may appear different.

2. Click the Structure/Instance window and select **Edit > Find**.
3. Type in **X_DCM** in the search box and select **Entity/Module** in the Field section.
4. Once ModelSim locates **X_DCM**, select **X_DCM_SP** and click on the signals/objects window. All the signal names for the DCM will be listed.
5. Select the Signal/Object window and select **Edit > Find**.
6. Type **CLKIN** in the search box and select the **Exact** checkbox.
7. Click and drag **CLKIN** from the Signal/Object window to the Wave window.

**Figure 6-3:** Undock icon

**Figure 6-4:** Structure/Instance Window - Schematic Flow
8. Click and drag the following signals from the Signal/Object window to the Wave window:
   ♦ RST
   ♦ CLKFX
   ♦ CLK0
   ♦ LOCKED

   **Note:** Multiple signals can be selected by holding down the Ctrl key. In place of using the drag and drop method select **Add to Wave > Selected Signals**.

**Adding Dividers**

Modelsim has the capability to add dividers in the Wave window to make it easier to differentiate the signals. To add a divider called DCM Signals:

1. Click anywhere in the Wave window.
2. If necessary, undock the window and then maximize the window for a larger view of the waveform.
3. Right-click the Wave window and click **Insert > Divider**.
4. Enter **DCM Signals** in the Divider Name box.
5. Click and drag the newly created divider to above the CLKIN signal.

   **Note:** Stretch the first column in the waveform to see the signals clearly. The hierarchy in the signal name can also be turned off by selecting **Tools > Options > Wave Preferences**. In the Display Signal Path box, enter 2 and click **OK**.

The waveform should look as shown in **Figure 6-5**.

---

**Figure 6-5: The Resulting Waveform**
Notice that the waveforms have not been drawn for the newly added signals. This is because ModelSim did not record the data for these signals. By default, ModelSim will only record data for the signals that have been added to the Wave window while the simulation is running. Therefore, after new signals are added to the Wave window, you need to rerun the simulation for the desired amount of time.

Rerunning Simulation

To restart and re-run the simulation:

1. Click the Restart Simulation icon.

   ![Restart Simulation Icon](image)

   Figure 6-6: Restart Simulation Icon

The Restart dialog box opens.

2. Click Restart.

3. At the ModelSim command prompt, enter `run 2000 ns` and hit the Enter key.

   ![Running Command](image)

   Figure 6-8: Entering the Run Command

The simulation will run for 2000 ns. The waveforms for the DCM should now be visible in the Wave window.

Analyzing the Signals

Now the DCM signals can be analyzed to verify that it works as expected. The CLK0 needs to be 50 MHz and the CLKFX should be ~26 MHz. The DCM signals should only be analyzed after the LOCKED signal has gone high. Until the LOCKED signal is high the DCM outputs are not valid.

Modelsim has the capability to add cursors to carefully measure the distance between signals.

To measure the CLK0:
1. Select **Add > Cursor** twice to place two cursors on the wave view.

2. Click and drag the first cursor to the rising edge transition on the CLK0 signal after the LOCKED signal has gone high.

3. Click and drag the second cursor to a position just right of the first cursor on the CLK0 signal.

4. Click the **Find Next Transition** icon twice to move the cursor to the next rising edge on the CLK0 signal.

   ![Find Next Transition Icon](image6-9.png)

   **Figure 6-9: Find Next Transition Icon**

Look at the bottom of the waveform to view the distance between the two cursors. The measurement should read 20000 ps. This converts to 50 Mhz, which is the input frequency from the test bench, which in turn should be the DCM CLK0 output.

Measure CLKFX using the same steps as above. The measurement should read 38462 ps. This equals approximately 26 Mhz.

**Saving the Simulation**

The ModelSim Simulator provides the capability of saving the signals list in the Wave window. Save the signals list after new signals or stimuli are added, and after simulation is rerun. The saved signals list can easily be loaded each time the simulation is started.

1. In the Wave window, select **File > Save Format**.

2. In the Save Format dialog box, rename the filename from the default `wave.do` to `dcm_signal_tim.do`.

   ![Save Format Dialog Box](image6-10.png)

   **Figure 6-10: Save Format Dialog Box**

3. Click **Save**.

   After restarting the simulation, you can select **File > Load** in the Wave window to reload this file.

   Your timing simulation is complete and you are ready to program your device by following Chapter 7, “iMPACT Tutorial.”
Timing Simulation Using Xilinx ISim

Follow this section of the tutorial if you have skipped the previous section, “Timing Simulation Using ModelSim.”

Specifying Simulation Process Properties

To set the simulation process properties:

1. In the Sources tab, select Post-Route Simulation in the Sources for field.
2. Select the test bench file (stopwatch_tb).
3. In the Processes tab, click the + next to Xilinx ISE Simulator to expand the process hierarchy.
4. Right-click Simulate Post-Place & Route Model.
5. Select Process Properties.
   The Process Properties dialog box displays.
   These properties set the options that NetGen uses when generating the simulation netlist. For a description of each property, click the Help button.
7. Ensure that you have set the Property display level to Advanced.
   This global setting enables you to now see all available properties.
   For this tutorial, the default Simulation Model Properties are used.
8. Select the ISE Simulator Properties category.
   The properties should appear as shown in Figure 6-11. These properties set the options the simulator uses to run the timing simulation. For a description of each property, click the Help button.

10. Click OK to close the Process Properties dialog box.
Performing Simulation

To start the timing simulation, double-click **Simulate Post-Place and Route Model** in the Processes tab.

When a simulation process is run, Project Navigator automatically runs Netgen to generate a timing simulation model from the placed and routed design. The ISE Simulator will then compile the source files, load the design, and run the simulation for the time specified.

**Note:** The majority of this design runs at 100 Hz and would take a significant amount of time to simulate. This is why the counter will seem like it is not working in a short simulation. For the purpose of this tutorial, only the DCM signals will be monitored to verify that they work correctly.

Adding Signals

To view signals during the simulation, you must add them to the waveform window. ISE automatically adds all the top-level ports to the waveform window. All available external (top-level ports) and internal signals are displayed in the Sim Hierarchy window.

The following procedure explains how to add additional signals in the design hierarchy. In this tutorial, you will be adding the DCM signals to the waveform.

1. In the Instances and Processes panel, click the > next to stopwatch_tb to expand the hierarchy.
2. Click the > next to UUT to expand the hierarchy.
3. Locate and select Inst_dcm1_DCM_SP_INST
4. In the Objects window, select the locked signal and click on **Add to Wave Window**.

**Figure 6-12** shows the Sim Instances and Sim Objects window for the VHDL flow. The signal names and layout in the Sim Instances window for a schematic or VHDL flow may appear different.
5. Click and drag the following X_DCM_SP signals from the SIM Hierarchy window to the waveform window:
   - RST
   - CLKFX
   - CLK0
   - CLkin

   **Note:** Multiple signals can be selected by holding down the Ctrl key.

**Viewing Full Signal Names**

A signal name may be viewed with either the complete hierarchical name or by the short name which omits hierarchy information. To change the signal name display;

1. Right click the desired signal in the waveform window.
2. Select *Name > Long* or *Name > Short* as desired.

**Note:** Stretch the first column in the waveform to see the signals clearly.

The waveform should appear as shown in Figure 6-13.

![The Resulting Waveform](image)

**Figure 6-13: The Resulting Waveform**

Notice that the waveforms have not been drawn for the newly added signals. This is because the ISE Simulator did not record the data for these signals. The ISE Simulator will only record data for the signals that have been added to the waveform window while the simulation is running. Therefore, after new signals are added to the waveform window, you need to rerun the simulation for the desired amount of time.

**Rerunning Simulation**

To restart and re-run the simulation:
1. Click the **Restart Simulation** icon.

   ![Restart Simulation Icon](image)

   *Figure 6-14: Restart Simulation Icon*

2. At the Sim Console command prompt, enter `run 2000 ns` and hit the **Enter** key.

   ![Run Command](image)

   *Figure 6-15: Entering the Run Command*

   The simulation will run for 2000 ns. The waveforms for the DCM should now be visible in the Simulation window.

**Analyzing the Signals**

Now the DCM signals can be analyzed to verify that it does work as expected. The CLK0 needs to be 50 Mhz and the CLKFX should be ~26 Mhz. The DCM signals should only be analyzed after the LOCKED signal has gone high. Until the LOCKED signal is high the DCM outputs are not valid.

ISE Simulator has the capability to add cursors to carefully measure the distance between signals.

To measure the CLK0:

1. If necessary, zoom in on the waveform using the zoom local toolbar buttons.
2. Click the **Snap to Transition** toolbar button in the waveform viewer local toolbar.
3. Click on the first rising edge transition on the CLK0 signal after the LOCKED signal has gone high, then drag the cursor to the right to the next rising edge transition of the CLK0 signal.

   At the bottom of the waveform window, the start point time, end point time, and delta times are shown. The delta should read 20.0 ns. This converts to 50 Mhz, which is the input frequency from the test bench, which in turn should be the DCM CLK0 output.

   Measure CLKFX using the same steps as above. The measurement should read 38.5 ns, this equals approximately 26 Mhz.
Your timing simulation is complete and you are ready to program your device by following Chapter 7, “iMPACT Tutorial.”.

Figure 6-16: Measuring Transitions
This chapter takes you on a tour of iMPACT, a file generation and device programming tool. iMPACT enables you to program through several parallel cables, including the Platform Cable USB. iMPACT can create bit files, System ACE files, PROM files, and SVF/XSVF files. The SVF/XSVF files can be played backed without having to recreate the chain.

This tutorial contains the following sections:

- **“Device Support”**
- **“Download Cable Support”**
- **“Configuration Mode Support”**
- **“Getting Started”**
- **“Creating a iMPACT New Project File”**
- **“Using Boundary Scan Configuration Mode”**
- **“Troubleshooting Boundary Scan Configuration”**
- **“Creating an SVF File”**
- **“Other Configuration Modes”**

### Device Support

The following devices are supported:

- Virtex™/-E/-II/-II PRO/4/5/6
- Spartan™/-II/-IIE/XL/3/3E/3A/6
- XC4000™/E/L/EX/XL/XLA/XV
- CoolRunner™XPLA3/-II
- XC9500™/XL/XV
- XC18V00P
- XCF00S
- XCF00P
Download Cable Support

Parallel Cable IV

The Parallel Cable connects to the parallel port and can be used to facilitate Slave Serial and Boundary-Scan functionality. For more information, go to http://www.xilinx.com/support, select Documentation > Devices > Configuration Solutions > Configuration Hardware > Xilinx Parallel Cable IV.

Platform Cable USB

The Platform Cable connects to the USB port and can be used to facilitate Slave Serial, and Boundary Scan functionality. For more information, go to http://www.xilinx.com/support, select Documentation > Devices > Configuration Solutions > Configuration Hardware > Platform Cable USB.

MultiPRO Cable

The MultiPRO cable connects to the parallel port and can be used to facilitate Desktop Configuration Mode functionality. For more information, go to http://www.xilinx.com/support, select Documentation > Devices > Configuration Solutions > Configuration Hardware > MultiPRO Desktop Tool.

Configuration Mode Support

Impact currently supports the following configuration modes:

- Boundary Scan — FPGAs, CPLDs, and PROMs (18V00, XCFS, XC FP)
- Slave Serial — FPGAs
- SelectMAP — FPGAs
- Desktop — FPGAs

Getting Started

Generating the Configuration Files

In order to follow this chapter, you must have the following files for the stopwatch design:

- a BIT file—a binary file that contains proprietary header information as well as configuration data.
- a MCS file—an ASCII file that contains PROM configuration information.
- a MSK file—a binary file that contains the same configuration commands as a BIT file, but that has mask data in place of configuration data. This data is not used to configure the device, but is used for verification. If a mask bit is 0, the bit should be verified against the bit stream data. If a mask bit is 1, the bit should not be verified. This file generated along with the BIT file.
These files are generated in Chapter 5, “Design Implementation.”

- The Stopwatch tutorial projects can be downloaded from http://www.xilinx.com/support/techsup/tutorials/tutorials11.htm. Download the project files for either the VHDL, Verilog or Schematic design flow.

Connecting the Cable

Prior to launching iMPACT, connect the parallel side of the cable to your computer’s parallel port, and connect the cable to the Spartan-3 Starter Kit demo board. Be sure that the board is powered.

Starting the Software

This section describes how to start the iMPACT software from ISE™ and how to run it stand-alone.

Opening iMPACT from Project Navigator

To start iMPACT from Project Navigator, double-click Manage Configuration Project (iMPACT) in the Processes tab in the Processes window (see Figure 7-1).

Opening iMPACT stand-alone

To open iMPACT without going through an ISE project, use one of the following methods.

- PC — Click Start > All Programs > Xilinx® ISE Design Suite 11 > Accessories > iMPACT.
- PC, UNIX, or Linux — Type impact at a command prompt.

Creating a iMPACT New Project File

If an iMPACT project doesn’t yet exist, you can create one that will store the settings of the project for future use. To create a new project for this tutorial:

1. In iMPACT, select File -> New Project.
2. In the iMPACT Project dialog box, select create a new project (.ipf).
3. Click the Browse button.
4. Browse to the project directory and then enter stopwatch in the File Name field.
5. Click Save.
6. Click OK.

This creates a new project file in iMPACT. You are prompted to define the project, as described in the next section.

Using Boundary Scan Configuration Mode

For this tutorial, you will be using the Boundary Scan Configuration Mode. Boundary Scan Configuration Mode enables you to perform Boundary Scan Operations on any chain comprising JTAG compliant devices. The chain can consist of both Xilinx® and non-Xilinx devices; however, limited operations will be available for non-Xilinx devices. To perform operations, the cable must be connected and the JTAG pins, TDI, TCK, TMS, and TDO need to be connected from the cable to the board.

Specifying Boundary Scan Configuration Mode

After opening iMPACT, you are prompted to specify the configuration mode and which device you would like to program.

To select Boundary Scan Mode:

1. Select Configure Devices using Boundary-Scan (JTAG) and leave the selection box value of Automatically connect to a cable and identify Boundary-Scan chain.

Note: The selection box also gives you the option to Enter a Boundary Scan Chain, which enables you to then manually add devices to create chain. This option enables you to generate an SVF/XSVF programming file, and is discussed in a later section in this chapter. Automatically detecting and initializing the chain should be performed whenever possible.
2. Click **OK**.

![Welcome to iMPACT](image)

**Figure 7-3: Selecting automatic boundary scan from Wizard**

iMPACT will pass data through the devices and automatically identify the size and composition of the boundary scan chain. Any supported Xilinx device will be recognized and labeled in iMPACT. Any other device will be labeled as unknown. The software will then highlight each device in the chain and prompt you to assign a configuration file or BSDL file.

*Note:* If you were not prompted to select a configuration mode or automatic boundary scan mode, right-click in the iMPACT window and select **Initialize Chain**. The software will identify the chain if the connections to the board are working. Go to “Troubleshooting Boundary Scan Configuration” if you are having problems.
Assigning Configuration Files

After initializing a chain, the software prompts you for a configuration file (see Figure 7-4). The configuration file is used to program the device. There are several types of configuration files.

- A Bitstream file (*.bit, *.rbt, *.isc) is used to configure an FPGA.
- A JEDEC file (*.jed, *.isc) is used to configure a CPLD.
- A PROM file (*.mcs, .exo, .hex, or .tek) is used to configure a PROM.

When the software prompts you to select a configuration file for the first device (XC3S700A):

1. Select the BIT file from your project working directory.
2. Click Open.
3. When prompted to attach SPI or BPI PROMs to the device, select No.
4. When the software prompts you to select a configuration file for the second device (XCF04S), select the MCS file from your project working directory.
5. Click Open.

Note: If a configuration file is not available, a Boundary Scan Description File (BSDL or BSD) file can be applied instead. The BSDL file provides the software with the necessary Boundary Scan information that allows a subset of the Boundary Scan Operations to be available for that device. To
have ISE automatically select a BSDL file (for both Xilinx and non-Xilinx devices), select **Bypass** in the Assign New Configuration File dialog box.

6. When the Device Programming Properties Dialog Box appears (see Figure 7-5). Select the **Verify** option.

   The Verify option enables the device to be readback and compared to the BIT file using the MSK file that was created earlier.

7. Click **OK** to begin programming.

![Device Programming Options](image)

*Figure 7-5: Device Programming Options*

The options available in the Device Programming Properties dialog box vary based on the device you have selected.

### Saving the Project File

Once the chain has been fully described and configuration files are assigned, you should save your iMPACT Project File (IPF) for later use. To do this, select **File > Save Project As**. The Save As dialog box appears and you can browse and save your project file accordingly. To restore the chain after reopening iMPACT, select **File > Open Project** and browse to the IPF.

**Note:** Previous versions of ISE use Configuration Data Files (CDF). These files can still be opened and used in iMPACT. iMPACT Project Files can also be exported to a CDF.

### Editing Preferences

To edit the preferences for the Boundary Scan Configuration, select **Edit > Preferences**. This selection opens the window shown in *Figure 7-6*. Click **Help** for a description of the Preferences.
In this tutorial, keep the default values and click OK.

Performing Boundary Scan Operations

You can perform Boundary Scan operations on one device at a time. The available Boundary Scan operations vary based on the device and the configuration file that was applied to the device. To see a list of the available options, right-click on any device in the chain. This brings up a window with all of the available options.

When you select a device and perform an operation on that device, all other devices in the chain are automatically placed in BYPASS or HIGHZ, depending on your iMPACT Preferences setting. (For more information about Preferences, see “Editing Preferences.”)

To perform an operation, right-click on a device and select one of the options. In this section, you will retrieve the device ID and run the programming option to verify the first device.

1. Right-click on the XC3S700A device.
2. Select **Get Device ID** from the right-click menu.

3. Right-click on the XC3S700A device
4. Right-click on the xc3s700a device again and then click on **Program**.

The Programming operation begins and an operation status window displays. At the same time, the log window reports all of the operations being performed.
When the Program operation completes, a large blue message appears showing that programming was successful (see Figure 7-9). This message disappears after a couple of seconds.

![Programming Operation Complete](https://www.xilinx.com/resources/iseugi/ug695/v112/ch7/image7-9.png)

**Figure 7-9: Programming Operation Complete**

Your design has been programmed and has been verified. The board should now be working and should allow you to start, stop and reset the runner’s stopwatch.

### Troubleshooting Boundary Scan Configuration

#### Verifying Cable Connection

When an error occurs during a Boundary Scan operation, first verify that the cable connection is established and that the software auto detect function is working. If a connection is still not established after plugging the cable into the board and into your machine, right-click in a blank portion of the iMPACT window and select either **Cable Auto Connect** or **Cable Setup**. Cable Auto Connect will force the software to search every port for a connection. Cable Setup enables you to select the cable and the port to which the cable is connected.
When a connection is found, the bottom of the iMPACT window will display the type of cable connected, the port attached to the cable, and the cable speed (see Figure 7-10).

![Figure 7-10: Cable Connection Successful](image)

If a cable is connected to the system and the cable autodetection fails, refer to Xilinx Answer Record #15742. Go to [http://www.xilinx.com/support](http://www.xilinx.com/support) and search for “15742”.

**Verifying Chain Setup**

When an error occurs during a Boundary Scan operation, verify that the chain is set up correctly and verify that the software can communicate with the devices. The easiest way to do this is to initialize the chain. To do so, right-click in the iMPACT window and select *Initialize Chain*. The software will identify the chain if the connections to the board are working.

If the chain cannot be initialized, it is likely that the hardware is not set up correctly or the cable is not properly connected. If the chain can be initialized, try performing simple operations. For instance, try getting the Device ID of every device in the chain. If this can be done, then the hardware is set up correctly and the cable is properly connected.

The debug chain can also be used to manually enter JTAG commands (see Figure 7-11). This can be used for testing commands and verifying that the chain is set up correctly. To use this feature, select **Debug > Enable/Disable Debug Chain** in iMPACT.

![Figure 7-11: Debug Chain](image)
For help using iMPACT Boundary-Scan Debug, use the iMPACT Help (accessible from Help > Help Topics), or file a Web case at http://www.xilinx.com/support.

Creating an SVF File

This section is optional and assumes that you have followed the “Using Boundary Scan Configuration Mode” section and have successfully programmed to a board. In this section, all of the configuration information is written to the SVF file.

iMPACT supports the creation of device programming files in three formats, SVF, XSVF, and STAPL. If you are using third-party programming solutions, you may need to set up your Boundary Scan chain manually and then create a device programming file. These programming files contain both programming instructions and configuration data, and they are used by ATE machines and embedded controllers to perform Boundary Scan operations. A cable normally does not need to be connected because no operations are being performed on devices.

Setting up Boundary Scan Chain

This section assumes that you are continuing from the previous sections of this chapter and already have the chain detected. If not, skip to “Manual JTAG chain setup for SVF generation” to define the chain manually.

JTAG chain setup for SVF generation

1. Select Output > SVF File > Create SVF File to indicate that you are creating a programming file.
2. Enter getid in the File Name field of the Create a New SVF File dialog box and click Save.
3. An informational message appears stating that all device operations will be directed to the .svf file. Click OK.

Manual JTAG chain setup for SVF generation

For this tutorial, you may skip this section if you completed the “Using Boundary Scan Configuration Mode” section.

The Boundary-Scan chain can be manually created or modified as well. To do this,
1. Ensure that you are in Boundary Scan Mode (click the Boundary-Scan tab).
   You can now add one device at a time.
2. Right-click on an empty space in the iMPACT Boundary-Scan window and select Add Xilinx Device or Add Non-Xilinx device.
   An Add Device dialog box appears allowing you to select a configuration file.
3. Select stopwatch.bit and then click Open.
   The device is added where the large cursor is positioned. To add a device between existing devices, click on the line between them and then add the new device.
   Repeat steps 2 and 3 to add the stopwatch.mcs file to the chain.

Note: The boundary scan chain that you manually create in the software must match the chain on the board, even if you intend to program only some of the devices. All devices must be represented in the iMPACT window.
Writing to the SVF File

The process of writing to an SVF file is identical to performing Boundary Scan operations with a cable. You simply right-click on a device and select an operation. Any number of operations can be written to an SVF file.

In this section, you will be writing the device ID to the programming file for the first device, and performing further instructions for the second device.

To write the device ID:

1. Right-click the first device (XC3S700A).
2. Select Get Device ID from the right-click menu.

The instructions that are necessary to perform a Get Device ID operation are then written to the file.

3. To see the results, select View > View SVF-STAPL File. Figure 7-13 shows what the SVF file looks like after the Get Device ID operation is performed.

---

```
// Created using Xilinx IMPACT Software (ISE - 10.1)
// Date: Mon May 19 21:44:00 2008

TRST OFF;
ENDR IDLE;
ENDR IDLE;
STATE RES0;
STATE IDLE;
FREQUENCY 1E6 Hz;
TIR 0 ;
HIR 0 ;
TDR 0 ;
HDR 0 ;
TIR 0 ;
HIR 0 ;
TDR 0 ;
HDR 0 ;
TIR 0 ;
HIR 0 ;
TDR 0 ;
HDR 0 ;
TIR 0 ;
HIR 14 TDI (3ffe) SMASK (3ffe) ;
HDR 2 TDI (00) SMASK (03) ;
TDR 0 ;
//loading device with 'idcode' instruction,
SBR 32 TDI (00000000) SMASK (ffffffff) TDO (12628093) MASK (00000000) ;
TIR 0 ;
HIR 0 ;
TDR 0 ;
HDR 0 ;
TIR 0 ;
HIR 0 ;
TDR 0 ;
HDR 0 ;
TIR 0 ;
HIR 14 TDI (3ffe) SMASK (3ffe) ;
```

---

Figure 7-12: Selecting a Boundary Scan Operation

Figure 7-13: SVF File that Gets a Device ID from the First Device in the Chain
To write further instructions to the SVF for the second device:

1. Right-click the second device (XCF02S).
2. Select **Program** from the right-click menu.

3. Click **OK** in the Programming Properties window.

The instructions and configuration data needed to program the second device are added to the SVF file.

**Stop Writing to the SVF**

After all the desired operations have been performed, you must add an instruction to close the file from further instructions. To stop writing to the programming file:

Select **Output > SVF File > Stop Writing to SVF File**.

To add other operations in the future, you can select **Output > SVF File > Append to SVF File**, select the SVF file and click **Save**.

**Playing back the SVF or XSVF file**

To play back the SVF file that you created to verify the instructions, you will

- Manually create a new chain.
- Assign the SVF file to the chain by right clicking and selecting **Add Xilinx Device** and selecting the SVF file in the search window.
- Right-click on the SVF file in the Boundary-Scan chain and select **Execute XSVF/SVF**.

**Other Configuration Modes**

**Slave Serial Configuration Mode**

Slave Serial Configuration mode allows you to program a single Xilinx device or a serial chain of Xilinx devices. To use the Slave Serial Configuration Mode, double-click Slave Serial in the Configuration Modes tab.
SelectMAP Configuration Mode

With iMPACT, SelectMAP Configuration mode allows you to program up to three Xilinx devices. The devices are programmed one at a time and are selected by the assertion of the correct CS pin. To use the SelectMAP Configuration Mode, double click SelectMAP in the Configuration Modes tab. Only the MultiPRO cable can be used for SelectMAP Configuration.

*Note:* These modes cannot be used with the Spartan-3 Starter Kit.